Regression: Navigating back to details view after a search shows list view instead

Bug #563524 reported by Gary Lasker on 2010-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: software-center

software-center version 2.0

To reproduce:

1. When in the main category screen of the "Get Software" section, click the "Accessories" category.
2. Type "Alarm" into the search field at the upper right.
3. Click the "More Info" button in the "Alarm Clock" row to view the details view for the Alarm Clock application.
4. Click the "Get Software" navigation button to view the main category screen again.
5. Now click the "Back" (left) history navigation button.

What happens:

The navigation buttons are correctly shown as "Get Software->Accessories->Search Results->Alarm Clock", but the *list view* for the search results is displayed (see screenshot).

What should happen:

The *details view* for Alarm Clock should be displayed (see screenshot).

Gary Lasker (gary-lasker) wrote :
summary: - Navigating back to details view after a search shows list view instead
+ Regression: Navigating back to details view after a search shows list
+ view instead
Matthew McGowan (mmcg069) wrote :

i can look into this

Matthew McGowan (mmcg069) wrote :

has this been fixed in trunk? i am not seeing this bug.

Gary Lasker (gary-lasker) wrote :

Hi Matthew! I can still reproduce this in latest trunk. Please give it a shot and be sure to follow the steps exactly. The problem seems to only occur when viewing details from within a search-filtered list (see screenshot in comment #1, four nav buttons total). Also, make sure that the last step before the first back navigation is a click on the "Get Software" navigation button.

Finally, note that the details screen *is* shown correctly when navigating *forward* through the history again -- the problem only occurs with back navigation.

Thanks very much for taking a look at this!

Matthew Paul Thomas (mpt) wrote :

I see the search field momentarily appear containing the word "alarm" before USC incorrectly shows the search results.

Would it be reasonable to hope that if bug 426999 was fixed, this bug would go away by itself?

Michael Vogt (mvo) on 2010-04-16
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

I can also reproduce it, the issue is a async race, the page is set to the details but because we do searches more async now we get a "search-terms-changed" signal afterwards. One possible fix is this:

=== modified file 'softwarecenter/view/availablepane.py'
--- softwarecenter/view/availablepane.py 2010-04-16 20:30:48 +0000
+++ softwarecenter/view/availablepane.py 2010-04-16 21:18:44 +0000
@@ -340,6 +340,9 @@
         """callback when the search entry widget changes"""
         logging.debug("on_search_terms_changed: %s" % new_text)

+ if self.notebook.get_current_page() == self.PAGE_APP_DETAILS:
+ return
+
         # yeah for special cases - as discussed on irc, mpt
         # wants this to return to the category screen *if*
         # we are searching but we are not in any category

Michael Vogt (mvo) on 2010-04-16
Changed in software-center (Ubuntu Lucid):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.0.1

---------------
software-center (2.0.1) lucid; urgency=low

  [ Olivier Tilloy ]
  * When computing the size of a PathPart, always set the requested height
    of the parent PathBar. This prevents the navigation bar from
    "disappearing" (its height was somehow set to 1) (LP: #564042)

  [ Michael Vogt ]
  * cherry r730 lp:~mmcg069/software-center/minor-change/changes:
    - fix CellRendererAppView text rendering when using hicolor gtk theme
    (LP: #564694)
  * softwarecenter/view/viewswitcher.py:
    - fix displaying duplicated entries in the partner channel
      (LP: #564789)
  * softwarecenter/view/availablepane.py,
    softwarecenter/view/channelpane.py,
    softwarecenter/view/installedpane.py:
    - only send size information signals if we actually have a model
      (LP: #564756)
  * softwarecenter/view/availablepane.py:
    - if we get a "search-terms-changed" signal while in the applicatin
      details page it got delivered asynchronously and must be discarded
      (LP: #563524)
 -- Michael Vogt <email address hidden> Fri, 16 Apr 2010 23:27:14 +0200

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers