software-center crashed with AttributeError in _get_installed_rdepends_by_type()

Bug #563030 reported by ftoperso on 2010-04-14
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: software-center

I was removing evolution packages when the bug occured.
software-center did not completely crash, after the event.

software-center:
  Installé : 1.1.26
  Candidat : 1.1.26
 Table de version :
 *** 1.1.26 0
        500 http://fr.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
Description: Ubuntu lucid (development branch)
Release: 10.04

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: software-center 1.1.26
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic i686
Architecture: i386
Date: Wed Apr 14 15:28:33 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/sousernameware-center
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/sousernameware-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in _get_installed_rdepends_by_type()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

ftoperso (ftoperso) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I tried to reproduce this without success, the backtrace is a bit odd, a package (self.pkg) should always be defined when there is a remove button. So any hints how to trigger the bug would be welcome.

Thanks,
 Michael

Changed in software-center (Ubuntu):
status: New → Incomplete
ShadowDeath (shadowerwtas) wrote :

Happened to me on both my desktop and my laptop after the last Dist Upgrade...
After the upgrade the first thing i done was to remove some programs that i don't use at all... like games, evolution etc... while removing software occurred twice... First time canceled the report but happened again on the next package too... so there i am.

ftoperso (ftoperso) wrote :

when it happened to me I was removing evolution (as ShadowDeath)
on next reboot,ubuntu-desktop simply refused to load after logon window.
I do not know if it is linked to the bug or my removing evolution
the only solution I found was: sudo apt-get install ubuntu-desktop

don't know if this will help, I am not a linux expert...

Omer Akram (om26er) wrote :

Thanks for the bug report. could you please try to reproduce the issue with latest release?

Omer Akram (om26er) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Kiwinote (kiwinote) wrote :

Hi!

Thanks for your bug report and sorry for the delayed response.
As you may be aware, during each cycle a lot of work goes into
software-center. However, over time we build up a long list of
bugs which are most likely no longer present in recent versions
of software-center.

In an attempt to clean up the bug list for software-center I am
expiring this bug because it meets one or more of the following
criteria:
- it would seem quite likely that this bug is no longer present
  in recent versions of software-center,
- the bug report does not contain sufficient information for us
  to reproduce and/or fix the bug,
- the issue is most likely in an external piece of code and has
  most likely been fixed since the bug was reported.

If you experience any problems in recent development versions
of software-center, please do continue to report new bugs.
Thanks again for your help!

Changed in software-center (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers