software center allows removal of "essential" and "required" without extra prompt

Bug #561018 reported by Thomas Orgis on 2010-04-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
software-center (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: software-center

This is an excerpt out of https://lists.ubuntu.com/archives/ubuntu-studio-users/2010-April/006109.html (trying to get ubuntu (plus studio packages) lucid running)... so sorry for the prose, I had a hard night then. The information bits in it should still be important:

<quote>
Now... the crashing plymouth kept nagging me (would a system update really fix this now? -- I need to see if my next visit at the box is long enough for the downloads). It's main function seems to be nagging (and irritate newbies), so I decided to rip plymouth out. Due to a dangerous fling, I clicked on the Software Center menu entry.
Searched for "plymouth" ... removed the daemon... seen that there still is a package for plymouth shared libs... wondered how much stuff might depend on it... figured that one will get warnings about removing dependent stuff (like synaptic does it)... deleted it.
B-O-O-M! X11 is killed ... I manage to activate a plain console ... and see that I unwittingly entered a major system fubar.
Tried to restart gdm ... there is no gdm ... tried to look after the binary... there is no /bin/ls! Wow. There even is no halt, reboot or shutdown. This system is really ripped apart for good.

This is something one really would like to avoid happening to new users, old users ... anyone. This Software Center thingie is supposed to be the bubbly-touchy-feely admin interface for Linux newbies / notcarealots, right? I consider it a serious bug that it hoses the whole install beyond repair for any average ubuntu user (well, except for reinstall). Is this something known? Shall I make a flaming report on launchpad?
</quote?

I don't think the system information is very important here (I'm on a different box now and on the box I have a new install of ubuntu). It should be easily reproducible by installing ubuntu lucid beta1 from the CD image on amd64 and trying to remove plymouth shared libs in software center. It should try to stop me at least once before accidentally hosing the whole system.

Related branches

tags: added: lucid
Michael Vogt (mvo) on 2010-04-12
summary: - software center destroys system without warning
+ software center allows removal of "essential" and "required" without
+ extra prompt
Changed in software-center (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → High
Thomas Orgis (thomas-forum) wrote :

I am wondering: The main issue is that it left the system in a unreparable state (out of itself) ... so "essential" packages should be protected. But, is it generally desired behaviour to silently delete dependent packages? Would a message with "This would remove these apps, you really want it?" not be a good idea, generally?
But then, I might miss the supposed difference the Software Center should have compared to synaptic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.26

---------------
software-center (1.1.26) lucid; urgency=low

  [ Gary Lasker ]
  * softwarecenter/app.py,
    softwarecenter/view/softwarepane.py:
    - correctly refresh the availablepane view on a
      change to software sources (LP: #559539)
  * softwarecenter/app.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/navhistory.py:
    - clear navigation history on a software channel refresh
      because packages in the history stack might no longer
      be available

  [ Michael Vogt ]
  * softwarecenter/view/appdetailsview.py:
    - fix displaying removal warning when listview interface buttons
      are used (LP: #561018)
 -- Michael Vogt <email address hidden> Tue, 13 Apr 2010 22:57:30 +0200

Changed in software-center (Ubuntu Lucid):
status: Confirmed → Fix Released
Michael Vogt (mvo) wrote :

@Thomas the fix is to display the dependencies

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.11+bzr345-0ubuntu4

---------------
aptdaemon (0.11+bzr345-0ubuntu4) lucid; urgency=low

  * debian/patches/04_caution_is_good.patch
      - cherry pick fix from trunk to prevent removal of essenial
        or required packages (LP: #561018)
  * debian/patches/05_conffile_not_exists.patch:
    - Do not fail on not available files (LP: #563504)
 -- Michael Vogt <email address hidden> Fri, 16 Apr 2010 22:09:03 +0200

Changed in aptdaemon (Ubuntu Lucid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers