Response too slow when clicking "Provided by Ubuntu" subitem of "Installed Software"

Bug #556375 reported by Xhacker Liu on 2010-04-06
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker
Declined for Lucid by Sebastien Bacher

Bug Description

Binary package hint: software-center

When clicking the "Provided by Ubuntu" subitem of "Installed Software", it takes many seconds before the items are displayed.

Note that this problem has been fixed for the case of "Provided by Ubuntu" subitem of "Get Software".

Xhacker Liu (xhacker) wrote :
Gary Lasker (gary-lasker) wrote :

Hi Xhacker Liu. The issue that you describe has been much improved in the latest development release of software-center, version 1.1.25. It still takes a short time before the software item list is displayed, but now the UI remains responsive (no freezing) and a "busy" cursor is displayed. Thanks for your report, and please continue to report any other problems you may encounter.

Changed in software-center (Ubuntu):
status: New → Fix Released
Xhacker Liu (xhacker) wrote :

Thanks a lot!
And there are another small problem, when I scroll in a huge software list, I feel too slow.

Incredibly slow still with software-center 2.0 package, just upgraded.

Sorry to say, but it is really unusable...

 Would be great if some of the developers test it with not very powerful machines. I'm running a Celeron, and actually the software center is the only package I cannot use due to this reason. Luckily, at least me I know how to use apt-get, but I am more worried about any new person coming to Ubuntu and trying to browse what can be installed using the software-center. If they really find it so slow, their first impression will be horrible...

I'm re-opening it...

Changed in software-center (Ubuntu):
status: Fix Released → New
Xhacker Liu (xhacker) wrote :

My computer is a powerful machine, but I feel TOO slow too. When I scroll the software list, too obtuse. I scroll my mouse wheel several times, after a few seconds, it stop. Drag the scroll bar has the same problem too.

Omer Akram (om26er) wrote :

Yes. This bug was certainly fixed a few days ago but now its back again. I guess a 5-7 days ago when I clicked on 'provided by ubuntu' the cursor spinned for 2seconds and then I was shown with the list of packages but now It takes much of a time like 15secs on my netbook.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Omer Akram (om26er) wrote :

To be exact 23seconds on My acer aspire one.

tags: added: regression-update
tags: added: regression-potential
removed: regression-update

Took 13 seconds for me with 2.0.1 version, really too much...

Omer Akram (om26er) on 2010-04-23
tags: removed: regression-potential
Xhacker Liu (xhacker) wrote :

The issue seems improved in 2.1.3, thanks a lot.

Gary Lasker (gary-lasker) wrote :

As Xhacker Liu points out, the responsiveness of the "Provided by Ubuntu" view is much improved since Maverick development version 2.1.2, when we added the "hide non-application packages by default" feature. Based on that, I will mark this bug as fix released.

Thanks Xhacker Liu!

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Xhacker Liu (xhacker) wrote :

In "Installed Software", click "Provided by Ubuntu", there are just 1535 items, but the cursor spinned 4 seconds. I'm using an iMac, a powerful machine!
In "Get Software" -> "Provided by Ubuntu", Click "32101 other technical items" took 6 seconds, synaptic only took about 1 second.
Please have a look again, thanks a lot.

Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Xhacker Liu (xhacker) wrote :

Forgot to say, I'm using 2.1.4 now.

summary: - Too slow when click "provided by Ubuntu"
+ Response too slow when clicking "Provided by Ubuntu" subitem of
+ "Installed Software"
description: updated
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
status: Confirmed → Triaged
Gary Lasker (gary-lasker) wrote :

A fix for this bug has been released in version 2.1.17 of Software Center. We now hide "technical items" by default as we do in the "Get Software" views. This gives us a much quicker load time for the "Provided by Ubuntu" subitem of "Installed Software".

In addition, we recently added a spinner to provide improved feedback during list view loading.

Changed in software-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments