Icons not displayed when using certain icon themes

Bug #556335 reported by David Stansby on 2010-04-06
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Kiwinote

Bug Description

s-c 1.1.26

When using certain icon themes, software-center displays empty boxes instead of icons when an icon is only available in the humanity-icon theme. Vish describes how icon themes can solve this in #6 and #7. Please open bug tasks for each icon theme affected.

Kiwinote (kiwinote) wrote :

Hi David. Can you please see if installing the 'humanity-icon-theme' package solves this issue? If so, we are probably missing a dependency on this package. Thanks.

Changed in software-center (Ubuntu):
status: New → Incomplete

I have humanity-icon-theme installed and up to date.

I think the problem is the theme I'm using (shiki-colours) If I change to the default theme (radiance) this problem disappears.

Changed in software-center (Ubuntu):
status: Incomplete → New
Kiwinote (kiwinote) on 2010-04-06
Changed in software-center (Ubuntu):
status: New → Confirmed
Hilton Gibson (hgibson) wrote :

Same bug. See screenshot.

Jennie Petoumenou (jennie) wrote :

What needs to be done is to copy the humanity/categories/XX/application-fonts icon to the hicolor (or gnome) icon set.
Because hicolor is the default fallback theme for all iconsets. So, older themes (any theme on gnome-look, really) that do not have an application-fonts icon, should be able to find it in hicolor.
Actually, this must be done with all new icons added to the humanity/categories folder.

Vish (vish) wrote :

The issue here is that the icons are present in the Humanity-icon-theme

Usually what is done always for the icon themes is to set the default icon theme in the depends for the theme
Inherits=Humanity

In the icon themes .theme will fix this.
Not sure we want to install all the icons by default in software store

Changed in software-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Vish (vish) wrote :

Note themes usually set
Inherits=gnome,hicolor

Adding Humanity in the /favoriteicontheme/index.theme as:
Inherits=Humanity,gnome,hicolor

will solve the bug.

Kiwinote (kiwinote) on 2010-04-14
description: updated
summary: - Fonts is missing an icon
+ Icons not displayed when using certain icon themes
Jennie Petoumenou (jennie) wrote :

"Adding Humanity in the /favoriteicontheme/index.theme as:
Inherits=Humanity,gnome,hicolor"
Consider this, though: Right now, if someone decides to use the original gnome theme (installed by default in ubuntu), they still get a missing icon. Plus, most users now enough to drag&drop a new theme from gnome-look, but definitely not enough to modify index.theme.

On second thoughts, the really correct way to deal with this would be for the developers of software-center to include copies of all the icons software center uses inside the software-center package.

I proposed the first solution because I thought it might be an easy workaround, but now I realize that it would not eliminate the bug completely (e.g. if someone installs software-center on a non-ubuntu machine). Unless, of course, you add the icon upstream to gnome.

fredrik (fredrik-pipemore) wrote :

Using icon theme GNOME

Kiwinote (kiwinote) on 2010-07-19
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Kiwinote (kiwinote)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.6

---------------
software-center (2.1.6) maverick; urgency=low

  [ Kiwinote ]
  * data/software-center.menu.in:
    - update query for fonts category (LP: #531570, #605459)
  * debian/control:
    - depend on humanity-icon-theme, rather than gnome-icon-theme
  * softwarecenter/app.py:
    - always append the humanity-icon-theme to the iconpath (LP: #436310, #466271, #527503, #556335, #594795)
  * softwarecenter/view/availablepane.py:
    - capitalize 'install n items' button label for mpt (LP: #605052)
  * softwarecenter/view/catview_gtk.py:
    - speed up carousel transition (thanks nuthinking) (LP: #604627)
  * softwarecenter/view/catview.py:
    - allow 'OR' tag inside an 'AND' tag

  [ Michael Vogt ]
  * softwarecenter/db/database.py:
    - parse axi values file for cataloged_time support
  * merged lp:~mvo/software-center/new-apps-test1 that adds support
    for a proper a "Whats new" category based on the xapian
    cataloged_time information
  * debian/control:
    - recommend aptdaemon (>= 0.38ubuntu1) to get catalogued_time
      support
    - recommend sessioninstaller for PK compatible session API
  * merged lp:~hellium/software-center/logging, thanks to
    Geliy Sokolov
  * merged lp:~mmcg069/software-center/bigger-icons, the icon size
    is actually the same, name is a bit misleading. It contains a new
    actionbar, but that is not yet enabled as its not feature complete
    yet
  * merged lp:~didrocks/software-center/fix-running-standalone-pane,
    many thanks
  * Support "pkgname/long appname with spaces" on the commandline when
    a single argument is passed. Without "/" its just considered a
    pkgname

  [ Gary Lasker ]
  * merge lp:~mmcg069/software-center/appdetailsview-gtk-mpt, many nice
    UI tweaks and improvements from Matthew McGowan, thanks!
  * softwarecenter/view/widgets/navigationbar.py,
    softwarecenter/view/softwarepane.py:
    - remove the old navigation bar as we won't be going back to it
  * softwarecenter/view/availablepane.py:
    - don't call set_category if viewing details or searching to
      reduce unnecessary applist refreshes
  * softwarecenter/view/appview.py;
    - fix app row reselect in the applist view for sorted lists and also
      for channels when the model is regenerated rather than replaced
      (LP: #609945)
  * test/test_appview.py:
      add tests for correct sorting for app insert case and for
      index map updating
  * merge lp:~didrocks/software-center/add-remove-multiple to add a
    remove_multiple method to aptd.py, thanks to Didier Roche!
 -- Michael Vogt <email address hidden> Tue, 27 Jul 2010 19:45:53 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers