software-center crashed with SIGSEGV in PyEval_EvalFrameEx()

Bug #556120 reported by firehost on 2010-04-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

Tried to install prism for Gmail

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: software-center 1.1.23
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Tue Apr 6 09:46:52 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100304)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f98aef91748: movzbl (%rdi),%ecx
 PC (0x7f98aef91748) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: software-center
StacktraceTop:
 ?? () from /lib/libc.so.6
 ?? ()
 ?? ()
 PyEval_EvalFrameEx ()
 PyEval_EvalFrameEx ()
Title: software-center crashed with SIGSEGV in PyEval_EvalFrameEx()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

firehost (ivan-grynenko) wrote :

StacktraceTop:
 __strstr_sse42 (s1=0x0, s2=0x7f98a5baa174 "_sorted")
 gtkDrawFlatBox (style=0x19adb00,
 ?? ()
 ?? ()

Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Omer Akram (om26er) on 2010-04-23
visibility: private → public
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in software-center (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Kiwinote (kiwinote) wrote :

Hi!

Thanks for your bug report and sorry for the delayed response.
As you may be aware, during each cycle a lot of work goes into
software-center. However, over time we build up a long list of
bugs which are most likely no longer present in recent versions
of software-center.

In an attempt to clean up the bug list for software-center I am
expiring this bug because it meets one or more of the following
criteria:
- it would seem quite likely that this bug is no longer present
  in recent versions of software-center,
- the bug report does not contain sufficient information for us
  to reproduce and/or fix the bug,
- the issue is most likely in an external piece of code and has
  most likely been fixed since the bug was reported.

If you experience any problems in recent development versions
of software-center, please do continue to report new bugs.
Thanks again for your help!

Changed in software-center (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers