ubuntu software center unknown error

Bug #551305 reported by aquasync on 2010-03-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-center

Upon trying to enable the lucid-partner source (while trying to install the flash plugin), in the latest lucid beta, I get a dialog saying:

"An unknown error occurred

This should not happen"

Doesn't really look good!

The text from the details window:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 101, in _process_transaction
    self.update_cache()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 404, in update_cache
    self._cache.update(progress, raiseOnError=True)
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 285, in update
    raise LockFailedException("Failed to lock %s" % lockfile)
LockFailedException: Failed to lock /var/lib/apt/lists/lock

Victor Vargas (kamus) wrote :

Please could you upgrade your software-center to latest (1.1.26) version and check if this issue is still affecting you? Thanks

summary: - ubuntu software centre unknown error
+ ubuntu software center unknown error
Changed in software-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
aquasync (aquasync) wrote :

I get the same kind of error trying to install packages from the command line. It appears jockey backend is holding the lock. This likely a manifestation of bug #373795 as I'm behind a proxy, though I think software center should be changed to report a less ominous error message for LockFailedException. jockey-backend should be fixed to not make the system unusable if it can't find the package sources, and preferably also fixed to obey system proxy settings (eg bug #373795).

$ sudo aptitude install pidgin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
No candidate version found for pidgin
No candidate version found for pidgin
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Couldn't lock list directory..are you root?

$ sudo lsof /var/lib/apt/lists/lock
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/clowe/.gvfs
      Output information may be incomplete.
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
jockey-ba 1355 root 13uW REG 8,1 0 131189 /var/lib/apt/lists/lock

$ ps aux | grep [j]ockey
root 1355 0.1 2.0 15920 10420 ? S 14:54 0:02 /usr/bin/python /usr/share/jockey/jockey-backend --debug -l /var/log/jockey.log

$ sudo jockey-gtk
ERROR:dbus.proxies:Introspect error on :1.55:/DeviceDriver: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Omer Akram (om26er) wrote :

please type the following in terminal and press enter so that we could have all the required info for this bug.

$ apport-collect 551305

aquasync (aquasync) wrote :

That doesn't work on the affected machine for some reason:

$ apport-collect 551305
Error connecting to Launchpad: 'NoneType' object has no attribute 'makefile'
You can reset the credentials by removing the file "/home/clowe/.cache/apport/launchpad.credentials"
$ ls /home/clowe/.cache/apport/launchpad.credentialsls: cannot access /home/clowe/.cache/apport/launchpad.credentials: No such file or directory

Which is strange because that command worked on my home install of lucid.

Architecture: i386
CheckboxSubmission: 6d7c838d0486b4767cd5486a2a69b23f
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: software-center 1.0.2
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1353): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1388): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1397): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Changed in software-center (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
Omer Akram (om26er) wrote :

chanka111, can you please try the latest version of Ubuntu and see if the problem is still there. thanks

Changed in software-center (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Kiwinote (kiwinote) wrote :

Hi!

Thanks for your bug report and sorry for the delayed response.
As you may be aware, during each cycle a lot of work goes into
software-center. However, over time we build up a long list of
bugs which are most likely no longer present in recent versions
of software-center.

In an attempt to clean up the bug list for software-center I am
expiring this bug because it meets one or more of the following
criteria:
- it would seem quite likely that this bug is no longer present
  in recent versions of software-center,
- the bug report does not contain sufficient information for us
  to reproduce and/or fix the bug,
- the issue is most likely in an external piece of code and has
  most likely been fixed since the bug was reported.

If you experience any problems in recent development versions
of software-center, please do continue to report new bugs.
Thanks again for your help!

Changed in software-center (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers