About window is modal and doesn't look like it

Bug #550955 reported by Matthew Paul Thomas on 2010-03-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Bilal Akhtar
Ubuntu Software Center
Invalid
Undecided
Unassigned
software-center (Ubuntu)
Low
Bilal Akhtar

Bug Description

Binary package hint: software-center

Ubuntu Software Center 1.1.21, Ubuntu Lucid

1. Choose "Help" > "About".
2. In the main window, click anything.

What happens: Nothing.
What should happen: USC should respond as normal.

<https://wiki.ubuntu.com/SoftwareCenter#About%20window>: "The About window should be a standard window (not a dialog)..."

Related branches

Changed in software-center (Ubuntu):
importance: Undecided → Low
Tim McNamara (tim-clicks) wrote :

Well spotted.

Changed in software-center (Ubuntu):
status: New → Confirmed
Vish (vish) wrote :

Still present in Ubuntu Software Center 1.1.26

Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Bilal Akhtar (bilalakhtar) wrote :

IMHO, should become a papercut.

Changed in hundredpapercuts:
status: New → Confirmed
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in software-center (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in hundredpapercuts:
assignee: Bilal Akhtar (bilalakhtar) → nobody
status: Confirmed → In Progress
Changed in software-center (Ubuntu):
status: Triaged → In Progress
Changed in hundredpapercuts:
assignee: nobody → Bilal Akhtar (bilalakhtar)
Omer Akram (om26er) on 2010-07-19
Changed in software-center:
status: New → Invalid
Changed in hundredpapercuts:
importance: Undecided → Low
Changed in hundredpapercuts:
milestone: none → maverick-round-7-notifications+gtk
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Changed in software-center:
status: Invalid → Fix Committed
Vish (vish) wrote :

Fix committed and merged to main

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Vish (vish) wrote :

@Bilal: Since Omer Akram is too busy to comment on the change to invalid earlier ;-)
The bug was marked invalid since "software center bugs are only tracked in Ubuntu" .
Marking upstream task as invalid.

@Omer: Kindly comment on bugs when making changes , so that everyone knows why and dont re-open bugs like this.

Changed in software-center:
status: Fix Committed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.7

---------------
software-center (2.1.7) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/availablepane.py:
    - restore missing busy cursor when loading applist
      views (LP: #610688)
    - fix visual glitch when navigating back to a subcategory
      list view from a details view (LP: #611108)
  * debian/control:
    - add depends python-debian (>= 0.1.15)
  * softwarecenter/backend/channel.py:
    - add an "App Expo" item in the left navigation pane for
      display of the contents of the (for now) app review
      board PPA
  * test/test_database.py:
    - update test for parse_axi_values_file change, fix
      test_update_from_var_lib_apt_lists
  * softwarecenter/backend/channel.py:
    - add a new "Other" item in the left navigation pane
      for display of software items for which a corresponding
      repository is not available (LP: #524379, LP: #596409)

  [ Michael Vogt ]
  * softwarecenter/view/widgets/actionbar.py:
    - fix crash in action buttons
  * softwarecenter/db/update.py:
    - support additional metadata from Packages file for the
      "Whats new" repository (and possible others)
    - add axi catalogedtime information to the app-install-data
      DB
  * softwarecenter/db/database.py:
    - export parse_axi_values_file()

  [ Bilal Akhtar ]
  * softwarecenter/app.py:
    - Prevent About dialog from being set as modal. (LP: #550955)

  [ Michael Bienia ]
  * softwarecenter/apt/apthistory.py,
    softwarecenter/view/historypane.py:
    - fix DeprecationWarning at startup (LP: #602310)
 -- Michael Vogt <email address hidden> Fri, 30 Jul 2010 21:35:56 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

Fixed!

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers