If a software source is disabled while viewing the details view for a package and that package is no longer available, the statement "software catalogue needs updating" is displayed

Bug #542892 reported by Matthew Paul Thomas on 2010-03-20
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Michael Vogt
Lucid
Medium
Michael Vogt

Bug Description

Binary package hint: software-center

(description updated per changes in software-center 1.1.23, see comment #3)

Ubuntu Software Center 1.1.23, Ubuntu Lucid

1. Open Software Center and choose menu item "Edit->Software Sources..." to open the Software Sources dialog.
2. Make sure that the checkbox for "Software restricted by copyright or legal issues (multiverse)" is checked.
3. Close the Software Sources dialog.
4. In "Get Software" view, navigate to "Fonts" and select the package "ttf-mscorefonts-installer".
5. Click "More Info" to view the details for this package.
6. Observe that the package is available to be installed, as indicated by the presence of the "Install - Free" button.
7. Again, open the Software Sources dialog using menu item "Edit->Software Sources...".
8. In the Software Sources dialog, uncheck the "Software restricted by copyright or legal issues (multiverse)" item.
9. Close the Software Sources dialog, and observe the "In Progress" node appears for a short time in the left pane.
8. After the "In Progress" node disappears, the details view for "ttf-mscorefonts-installer" is refreshed.

What happens:
After the details view for "ttf-mscorefonts-installer" is refreshed, the message "To show information about this item, the software catalogue needs updating." is displayed (see attached screenshot).

What should happen:
I'm not completely sure about what we should do about the details view display. The item is in fact no longer available in the software sources, so it is correctly not installable. However, the message is misleading since there's no way to "update the catalog". Maybe all we'd need to do is change the text to read something like "This software item is no longer available in your sources sources." or such (though, of course we are way past string freeze so this really isn't an option for Lucid).

Kiwinote (kiwinote) wrote :

The 'Microsoft core fonts' package seems to illustrate this behaviour.

Changed in software-center (Ubuntu):
status: New → Confirmed
Kiwinote (kiwinote) wrote :

This also seems to affect uninstalled java packages in 'partners' when the partners repo is disabled.

Michael Vogt (mvo) on 2010-03-31
Changed in software-center (Ubuntu Lucid):
importance: Undecided → Medium
Changed in software-center (Ubuntu Lucid):
assignee: nobody → Gary Lasker (gary-lasker)
description: updated
Gary Lasker (gary-lasker) wrote :

Testing with the current release of software-center, 1.1.23, the result when executing the steps in the description above has changed a bit. Specifically, the "Update Now" button is now hidden, but the "To show information about this item, the software catalogue needs updating." message still remains. So, the issue with pressing "Update Now" is no longer relevant, however, the user is still faced with a somewhat perplexing experience since it's not obvious what should be done.

Note, however, that after navigating back to the "Fonts" list view the "ttf-mscorefonts-installer" package is no longer included in the list, and so the details page for "ttf-mscorefonts-installer" is no longer reachable via the UI from that point.

Changed in software-center (Ubuntu Lucid):
milestone: none → ubuntu-10.04
summary: - Still says "software catalogue needs updating" after updating it
+ If a software source is disabled while viewing the details view for a
+ package and that package is no longer available, the statement "software
+ catalogue needs updating" is displayed
description: updated
Gary Lasker (gary-lasker) wrote :

Michael Vogt has checked in a fix for this one and the fix will be available in the next release of software-center.

With the fix, the message "Sorry, 'ttf-mscorefonts-installer' is not available for this type of computer" is displayed, rather than the previous (cryptic) message "To show information about this item, the software catalogue needs updating."

I opened a new bug to track the issue that I describe at the end of the description above, please see bug 559539 to track that issue.

Changed in software-center (Ubuntu Lucid):
assignee: Gary Lasker (gary-lasker) → Michael Vogt (mvo)
status: Confirmed → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.25

---------------
software-center (1.1.25) lucid; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/viewswitcher.py:
    - fix intermittent AttributeError if a model doesn't
      exist when checking node expanded state (LP: #554388)
  * softwarecenter/view/viewswitcher.py:
    - fix nasty list view errors when disabling partner
      repository (LP: #556995)
  * softwarecenter/view/appview.py:
    - fix intermittent AttributeError in row selection
      (LP: #552224)
  * softwarecenter/view/availablepane.py:
    - fix double call to set_category method
  * softwarecenter/view/channelpane.py,
    softwarecenter/view/installedpane.py:
    - fix bug where clicking the "Search Results" navigation
      button in the "Installed View" or in a PPA/channel
      view has no effect (LP: #559732)
  * softwarecenter/view/channelpane.py:
    - fix bug where selecting a new PPA/channel while
      a search is in effect in the current PPA/channel
      does not display the new PPA/channel (LP: #559742)

  [ Michael Vogt ]
  * softwarecenter/apt/aptcache.py:
    - add file monitor to detect changes in the dpkg status
      when apt is run outside of software-center (LP: #432555)
  * softwarecenter/view/appdetailsview.py:
    - only show "needs updating" message if we have a component
      associated with the software-item (LP: #542892)
  * softwarecenter/db/database.py:
    - when we have no package and no information no how to get it,
      display unavailable message instead of a empty summary line
  * merged lp:~mmcg069/software-center/pathbar-atk
    - this makes the pathbar on top fully accessible with e.g.
      orca (LP: #526384). Also fixes intermittent TypeError bug
      (LP: #558895) and nav button visual artifact when selecting
      a channel (LP: #531724). Many thanks!
  * softwarecenter/view/appview.py:
    - avoid blocking if a operation takes long

  [ Zygmunt Krynicki ]
  * softwarecenter/view/appdetailsview.py:
    - use package name when application name is not available (LP: #549011)
 -- Michael Vogt <email address hidden> Sat, 10 Apr 2010 16:29:10 +0200

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
simone (urform) on 2010-05-13
Changed in software-center (Ubuntu Lucid):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers