When installing from software list the install button doesn't become insensitive in the App/Item view

Bug #541844 reported by zp on 2010-03-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

Binary package hint: software-center

Lucid
USC 1.1.17

Go to some department and click the Install button. Then click on the More Info button (the Install button next to the More Info button becomes insensitive as it should).
You will see that the button isn't insensitive. It should be insensitive.

This applies to both installing and removing. In fact on further investigation it happen even if you start installing it from the app view, move to the software list view and then go back to the app view.

description: updated
Victor Vargas (kamus) on 2010-03-19
Changed in software-center (Ubuntu):
importance: Undecided → Low
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
status: New → In Progress
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.24

---------------
software-center (1.1.24) lucid; urgency=low

  [ Michael Vogt ]
  * softwarecenter/view/appview.py:
    - make the applist better accessible by providing a text only
      description of the selected item (LP: #455307)
  * data/templates/AppDetailsView.html:
    - make the app details view better accessible with orca/accersier

  [ Gary Lasker ]
  * softwarecenter/app.py,
    softwarecenter/view/softwarepane.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/appdetailsview.py,
    softwarecenter/backend/aptd.py:
    - maintain install/remove button sensitivity based on
      status of individual rows to restore the ability
      to do multiple simultaneous install/removes (LP: #529529)
    - keep all install/remove menu items and buttons in
      sync (LP: #551417)
    - set "Install" button in details view insensitive when
      switching to it from the list view during an install
      (LP: #541844)
    - use correct color for the list view "Install" button
      when it is insensitive (LP: #550915)
  * softwarecenter/view/appdetailsview.py:
    - don't try to execute enable_action_button() if the
      details view page has not yet been loaded (LP: #551419)
 -- Michael Vogt <email address hidden> Thu, 01 Apr 2010 11:22:00 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers