software-center crashed with SIGSEGV in g_mount_spec_match_with_path()

Bug #540635 reported by Alexey Degtyarev on 2010-03-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

I was browsing through software categories. Firewall settings application (ufw) was being installed in the background at that time. Then, software centre crashed. Ufw is marked as installed, but doesn't seem to work.
Ubuntu lucid (dev branch)/ 10.04
software-center / 1.1.17

ProblemType: Crash
Architecture: i386
Date: Thu Mar 18 03:55:38 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: software-center 1.1.17
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 PATH=(custom, user)
 LANG=ru_RU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SegvAnalysis:
 Segfault happened at: 0x8878639: mov 0x4(%eax),%ecx
 PC (0x08878639) ok
 source "0x4(%eax)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: software-center
StacktraceTop:
 ?? () from /usr/lib/libgvfscommon.so.0
 g_mount_spec_match_with_path ()
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
Title: software-center crashed with SIGSEGV in g_mount_spec_match_with_path()
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 g_mount_spec_get (spec=0x921c2ec,
 g_mount_spec_to_string (spec=0xbfdbbf8) at gmountspec.c:487
 g_daemon_vfs_get_file_for_uri (vfs=0xc,
 lookup_mount_info_in_cache (spec=<value optimized out>,
 ?? () at gdaemonfile.c:3118

Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Omer Akram (om26er) on 2010-04-23
visibility: private → public
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in software-center (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Kiwinote (kiwinote) wrote :

Hi!

Thanks for your bug report and sorry for the delayed response.
As you may be aware, during each cycle a lot of work goes into
software-center. However, over time we build up a long list of
bugs which are most likely no longer present in recent versions
of software-center.

In an attempt to clean up the bug list for software-center I am
expiring this bug because it meets one or more of the following
criteria:
- it would seem quite likely that this bug is no longer present
  in recent versions of software-center,
- the bug report does not contain sufficient information for us
  to reproduce and/or fix the bug,
- the issue is most likely in an external piece of code and has
  most likely been fixed since the bug was reported.

If you experience any problems in recent development versions
of software-center, please do continue to report new bugs.
Thanks again for your help!

Changed in software-center (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers