"Developer Tools" > "Debugging" has no items

Bug #538911 reported by Matthew Paul Thomas on 2010-03-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Matthew Paul Thomas

Bug Description

Ubuntu Software Center 1.1.17, Ubuntu Lucid
Ubuntu Software Center 2.1.14.1, Ubuntu Maverick

1. Choose "View" > "All Software".
2. Navigate to "Get Software" > "Developer Tools" > "Debugging".

What happens: "0 items available".
What should happen: At least Winpdb, KXSLDbg, KDbg, Nemiver, and D-Feet should be there.

This might be just because I messed up with the XML, or it might be because all those applications actually don't have Category set to "Debugger" when they should.

arky (arky) on 2010-07-09
Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
description: updated
Matthew Paul Thomas (mpt) wrote :

And the answer was ... I'd messed up with the XML.

This patch should fix it. Unfortunately I have forgotten how to test the fix. I thought it was "sudo PYTHONPATH=. python utils/update-software-center", but that does not seem to make a difference.

Gary Lasker (gary-lasker) wrote :

Hey mpt, this indeed fixes it (see attached screenshot). Thanks a lot for your patch! Uploaded to trunk.

Gary Lasker (gary-lasker) wrote :
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Matthew Paul Thomas (mpt)
tags: added: patch
Colin Watson (cjwatson) wrote :

software-center (2.1.19) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/mkit.py:
    - fix crash during action_bar refresh (LP: #635044)
  * softwarecenter/backend/channel.py:
    - always display the partner channel, even if its
      source is not enabled (LP: #635003)
  * softwarecenter/db/application.py,
    softwarecenter/db/database.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - make StoreDatabase.get_appname return None if the
      name is not defined in the xapian doc
    - consolidate code to generate application name and
      summary for display in the UI to a single place
    - wire applist, appdetails and the navigation bar
      to use it (LP: #636004)

  [ Kiwinote ]
  * data/software-center.menu.in:
    - fix typo to now use applications-ocaml icon, thanks mpt (LP: #635732)
  * softwarecenter/backend/channel.py:
    - allow 'for purchase' to have an icon in non-English locales (LP: #636242)
  * softwarecenter/db/application.py:
    - try to open deb file, except on any sort of error (LP: #633379)
    - simplify when we use which warnings for deb files (LP: #635015)
    - reload pkg cache object and xapian doc if it turns out that the pkgname
      of a deb file is different than what we guessed on basis of the file name
  * softwarecenter/utils.py:
    - fix crash when desktop_file is None (LP: #635596)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use the display name for app entry in 'where is it' (LP: #635464)
    - restore correct padding in addons status bar (LP: #625230)
  * minor tweaks to lp:~gary-lasker/software-center/title-summary-fixes
    - use installed state in status bar for reinstallable debs (LP: #635015)

  [ Matthew Paul Thomas ]
  * data/software-center.menu.in:
    - fix incorrect Category value in the xml for the Debugging
      subcategory of Developer Tools (LP: #538911)

  [ Colin Watson ]
  * Fix update-apt-xapian-index crashes when the Dir::Cache::pkgcache file
    doesn't exist (LP: #267330).

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix "reload()" in enable_channel() and only update the particular
      channel file
  * softwarecenter/distro/Ubuntu.py:
    - fix crash for icons loaded from extras.ubuntu.com
  * merged lp:~mmcg069/software-center/Bug635375 (LP: #635375)
  * merged lp:~mmcg069/software-center/tiny-pathbar-tweak
  * merged lp:~mmcg069/software-center/Bug625443 (LP: #625443)

 -- Michael Vogt <email address hidden> Tue, 14 Sep 2010 12:16:47 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches