Install button inaccessible

Bug #538404 reported by arky on 2010-03-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: software-center

Software-center (1.1.17) install button in application pages are not accessible. The screen reader speaks the install button simply as 'button' instead of install button in previous versions.

Event Monitor
--------------------
 source: [frame | Ubuntu Software Center]
 application: [application | software-center]
focus:(0, 0, None)
 source: [document frame | ]
 application: [application | software-center]
object:state-changed:focused(1, 0, None)
 source: [push button | ]
 application: [application | software-center]
object:property-change:accessible-parent(0, 0, [panel | ])
 source: [push button | ]
 application: [application | software-center]
object:property-change:accessible-parent(0, 0, [panel | ])
 source: [label | ]
 application: [application | software-center]
object:state-changed:focused(0, 0, None)
 source: [push button | ] <--------- Needs a accessible name?
 application: [application | software-center]
object:state-changed:focused(1, 0, None)
 source: [push button | Website]
 application: [application | software-center]
object:state-changed:focused(0, 0, None)
 source: [push button | Website]
 application: [application | software-center]
object:state-changed:focused(1, 0, None)
 source: [link | ]
 application: [application | software-center]
object:bounds-changed(0, 0, <Accessibility.BoundingBox object at 0xae0412c>)
 source: [panel | Window List]
 application: [application | wnck-applet]
object:bounds-changed(0, 0, <Accessibility.BoundingBox object at 0xae042cc>)
 source: [panel | ]
 application: [application | wnck-applet]
object:bounds-changed(0, 0, <Accessibility.BoundingBox object at 0xae0424c>)
 source: [panel | Bottom Expanded Edge Panel]
 application: [application | gnome-panel]
object:bounds-changed(0, 0, <Accessibility.BoundingBox object at 0xae0434c>)
 source: [frame | Bottom Expanded Edge Panel]
 application: [application | gnome-panel]

arky (arky) on 2010-03-13
tags: added: regression-release
Angel Abad (angelabad) wrote :

Related with bug #538384

Brian Murray (brian-murray) wrote :

The tag should be regression-potential since Lucid is not released yet.

tags: added: regression-potential
removed: regression-release
Changed in software-center (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Sajjad (sajjadkm) wrote :

This bug exists in Ubuntu Software Center 2.0.2.

Sajjad (sajjadkm) wrote :

Bug confirmed in Ubuntu Software Center 2.0.3debian1

arky (arky) wrote :

The problems seems to be that webkit doesn't expose the button properly.

<input type="button" id="button_install"
          class="action_button"
          alt="Install - Free"
          value="Install - Free"
          onclick='action_button_clicked()'
      />
      <label for="button_install" id="install_info">
        <img id="installed_icon" src="file:/usr/share/software-center/icons/software-center-installed.png"/>
      </label>

Changed in software-center (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Michael Vogt (mvo)
Michael Vogt (mvo) on 2010-06-21
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.4

---------------
software-center (2.1.4) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/availablepane.py:
    - fix error when using the login dialog and
      intermittently while searching (LP: #596443)
  * softwarecenter/app.py,
    softwarecenter/backend/channel.py,
    softwarecenter/view/channelpane.py,
    softwarecenter/view/viewswitcher.py:
    - implement channel views for installed items
  * softwarecenter/view/availablepane.py,
    softwarecenter/view/catview.py,
    softwarecenter/view/catview_gtk.py:
    - implement single-pane department screen
  * softwarecenter/view/catview_gtk.py:
    - use stock go-next icon for the show all button,
      small fix in CarouselPoster's draw method
  * merge lp:~mmcg069/software-center/catview-conform-w-spec:
    many nice improvements to the category view and a fix
    for the dept screen resize bug (LP: #598502), many thanks
    to Matthew McGowan!
  * merge lp:~mmcg069/software-center/catview-conform-w-spec:
    fixes subcategory screen bug (LP: #598498), thanks Matthew
    McGowan!
  * softwarecenter/view/catview_gtk.py:
    - use large icons in single-pane department screen per
      the spec

  [ Michael Vogt ]
  * mergedp:~arky/ubuntu/maverick/software-center/fixes-595500:
    - Fixes inaccessible install/remove buttons (LP: #538404)
    - Fixes inaccessible Screenshot image (LP: #595500)
    many thanks to Rakesh 'arky' Ambati
  * merged lp:~mmcg069/software-center/catview-conform-w-spec
    to make the categories look like the spec
  * add information about "upgraded" packages to the history pane
    (thanks to seb128 for the suggestion)
  * merged lp:~mvo/software-center/new-apps-test1 and
    lp:~mmcg069/software-center/catview-conform-w-spec, thanks
    to Matthew McGowan
  * merged lp:~mvo/software-center/update-from-var-lib-apt-lists
    to support meta-data in deb822 format in /var/lib/apt/lists
  * softwarecenter/view/catview_gtk.py:
    - append "all" to get pathbar when "all" button is clicked in
      a subcategory
  * support detecting a broken apt cache and repairing it
    (LP: #430200)
  * debian/control:
    - drop transitional gnome-app-install package, its no longer
      required for clean upgrades
 -- Michael Vogt <email address hidden> Tue, 29 Jun 2010 11:42:16 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers