UI freeze exception: Remove stars and reference to non-existent "reviews"

Bug #538129 reported by Matthew Paul Thomas on 2010-03-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Ubuntu Software Center 1.1.16.1, Ubuntu Lucid

1. Navigate to any software listing screen (e.g. "Fonts").

What happens: All the rows have stars. The selected row says "0 reviews", suggesting that it is possible to review software, when it is not.

What should happen: There should be no stars and no references to "reviews".

We expected that the ratings and reviews feature could be completed for 2.0. Because it could not be completed, we need a UI freeze exception to remove traces of it that ended up in trunk.

description: updated
Changed in software-center (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) wrote :

From the foundations team status reports, I understand that an attempt to implement ratings&reviews for lucid is still in progress, so deferring this UIFe request until the outcome of that is known. If ratings&reviews doesn't pan out, then this exception is granted.

Steve Langasek (vorlon) wrote :

Have gotten confirmation from Barry that R&R is deferred; UIFe granted.

Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2010-03-23
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
milestone: none → ubuntu-10.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.18

---------------
software-center (1.1.18) lucid; urgency=low

  [ Michael Vogt ]
  * data/templates/AppDetailsView.html:
    - cherry pick progress nice bar improvements from
      Michael Forrest (many thanks)
  * softwarecenter/view/appdetailsview.py:
    - show correct maintenance status for non applications
      (LP: #538172)
  * softwarecenter/view/appview.py:
    - use "ubuntu-almost-fixed-height-mode" when available
      to speed up the treeview drawing significantly
      (LP: #514879)
  * softwarecenter/view/softwarepane.py:
    - set show_ratings to "false" because ratings&reviews are
      cancelt for lucid (LP: #538129)
  * softwarecenter/view/appview.py:
    - only show active pane ratings if show_ratings is true

  [ Gary Lasker ]
  * data/ui/SoftwareCenter.ui:
    - don't translate available pane notebook labels
      (LP: #539371)
  * softwarecenter/view/viewswitcher.py:
    - when collapsing a node in the left pane (e.g. "Get Software"),
      select the node (LP: 532774)
  * softwarecenter/view/appview.py:
    - tweak padding in list view buttons (LP: #537524)
  * data/templates/AppDetailsView.html,
    data/templates/CategoriesView.html:
    - set following items as not draggable; screenshot thumbnail
      in details view, "Featured Applications" icon and general
      images in categories view (LP: #530163)
 -- Michael Vogt <email address hidden> Tue, 23 Mar 2010 10:13:26 +0100

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
Kiwinote (kiwinote) wrote :

This bug was not completely fixed by s-c 1.1.18. In the 'per source' views (the sections obtained by clicking the '+' to the left of 'get software') the stars are still present.

Changed in software-center (Ubuntu Lucid):
status: Fix Released → Confirmed
Gary Lasker (gary-lasker) wrote :

Woops, we missed one, the attached will take care of it. Thanks Kiwinote!

Changed in software-center (Ubuntu Lucid):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.19

---------------
software-center (1.1.19) lucid; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/channelpane.py:
    - hide ratings in channel pane also (LP: #538129)

  [ Michael Vogt ]
  * softwarecenter/view/catview.py:
    - fix i18n bug in category list (LP: #545102)
  * merge lp:~kiwinote/software-center/use_new_icons, many
    thanks!
  * fix i18n issue in featured application (LP: #545095)
  * merge lp:~kiwinote/software-center/bug530187, many thanks to
    "Kiwinote" (LP: #530187)
 -- Michael Vogt <email address hidden> Thu, 25 Mar 2010 09:48:54 +0100

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers