Categories icons are too generic

Bug #536627 reported by Daniel Planas Armangue on 2010-03-10
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Kenneth Wimer

Bug Description

Binary package hint: software-center

Icons still using the generic "applications-other" icon with no replacements are :

graphics > viewer
developer tools > subcategories excluding python,ruby,monodevelopment,java,localization,webdevelopment

---
Science&engineering > Biology , Physics - DONE
----
missing some icons in the sub-categories, I created some icons for games following the foundations of set humanity that comes by default in Ubuntu, I hope you like it

Related branches

game icons new

I assume this is in Lucid Lynx, correct?
Thank you for taking time to make Ubuntu better. We appreciate it

Changed in software-center (Ubuntu):
status: New → Incomplete

yes is in lucid lynx, if you like I can continue complete the other sub-categories?

pd:I bring things long ago, and is the first time someone thanks me, so thanks

a new revision of them

new puzzle icon
new card game icon

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Matthew Paul Thomas (mpt) wrote :

Wow, those look nice. Thanks daniplanas.a. Let's see if we can get these into Lucid as part of the overall USC UI freeze exception, bug 532136.

(software-center trunk deliberately does not have an "Arcade" subsection. We might add it in a future version when we've done more research.)

Changed in software-center (Ubuntu):
importance: Undecided → Medium

now im working on internet and graphic subcategories.

how much time do I have to freeze?

Vish (vish) wrote :

Attaching edited version of Dani's work. [the icons needed a bit of edit]

Not sure if SC wants to use them as a part of the humanity theme or icons for SC , hence I'm attaching them here.

But there is a problem. All the icons _wont_ be used.
stock_scores = is used for sports

Rest of the icons have bad icon names in the gnome-menus. ,
$ dpkg -L gnome-menus | grep directory
shows the list of .directory files ,

EX: Puzzles use the system-run icon and simulation uses the stock_person icon ,
It would need to be fixed in the gnome-menus as well.

For now , i'v named the icons using stock_* names

Kenneth Wimer (kwwii) wrote :

@<email address hidden>: keeping making them, I'll let you know before the final freeze for this. As these are just pixmaps which improve upon things we still have a week or more.

Changed in software-center (Ubuntu):
assignee: nobody → Kenneth Wimer (kwwii)

i add internet icons to package and vish corrections.
coments?

pd:i'm working on a tank methapor to simulation icon, and joystik it's preferible move on arcade in my opinion.

Vish (vish) wrote :

@daniplanas.a:
Nice work again, icons look good. As i mentioned in the mail:
1: The only problem still is that they _need_ to be pixel aligned. This is a must.
From view menu , select Grid.
Zoom to 800+% you'll notice the lines for every pixel.
Make sure that the strokes are within the lines. Else we will have the blurry icons. [Ex: the mail icon left line is aligned within the grid , but the top/bottom/right are not. ,similarly the sync icon arrows], We need to have the straight lines within the grid. This was the reason i was worried about the tank icon ;-)

The rest, you seem to have followed :)

2: Also what I forgot to mention is , Use colors from Humanity theme , the red for the sync is seems out of place.

Vish (vish) wrote :

Ah , just noticed a different style in the chat icon, The highlight[inner stroke] seems to be done differently only a little bit of the top part of the inner stroke seems visible.

Try to follow the tango guidelines :
http://tango.freedesktop.org/Tango_Icon_Theme_Guidelines

Vish (vish) wrote :

@daniplanas.a:
For the file sharing icon , use the emblem-sharing icon from humanity as the overlay [sideways arrows with the orange and green color]
Up-down arrow can be mistaken for bittorrent.

bugfixes:
-chat (acording to tango guidles)
-file sharing(arrows bugfixes)
-mail(blurring problem)

news:
preview to graphic subcategories.

hope you like ;)

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Vish (vish) wrote :

Attaching graphics icons , includes minor edit of Dani's drawing icon

i make all of them, and atach vish icons. hope you like.

now we need doing:
-stock_arcade
-science and enginering
-tools for developers

;)

keneth please you should select the category icons graphics that will be used and remove the versions you do not want. for while I upload a preview of the science and engineering icons.

hope you like

Vish (vish) wrote :

This is turning into a meta bug for all the SC icons. Updating the bug with the list of new icons we have already are :

  Humanity/categories/48/applications-3D.svg
  Humanity/categories/48/applications-boardgames.svg
  Humanity/categories/48/applications-cardgames.svg
  Humanity/categories/48/applications-chat.svg
  Humanity/categories/48/applications-drawing.svg
  Humanity/categories/48/applications-eletronics.svg
  Humanity/categories/48/applications-filesharing.svg
  Humanity/categories/48/applications-fonts.svg
  Humanity/categories/48/applications-geography.svg
  Humanity/categories/48/applications-geology.svg
  Humanity/categories/48/applications-java.svg
  Humanity/categories/48/applications-mail.svg
  Humanity/categories/48/applications-mathematics.svg
  Humanity/categories/48/applications-monodevelopment.svg
  Humanity/categories/48/applications-painting.svg
  Humanity/categories/48/applications-photography.svg
  Humanity/categories/48/applications-publishing.svg
  Humanity/categories/48/applications-puzzles.svg
  Humanity/categories/48/applications-python.svg
  Humanity/categories/48/applications-roleplaying.svg
  Humanity/categories/48/applications-ruby.svg
  Humanity/categories/48/applications-simulation.svg
  Humanity/categories/48/applications-sports.svg
  Humanity/categories/48/applications-webbrowsers.svg
  Humanity/categories/48/applications-engineering.svg

summary: - games icons wrong
+ Categories icons are too generic
Vish (vish) on 2010-03-19
description: updated
Vish (vish) on 2010-03-23
description: updated
Vish (vish) wrote :

Marking bug as fixed.
Most of the categories now have icons.

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers