disable drag and dropping of images

Bug #530163 reported by Kiwinote on 2010-03-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

Binary package hint: software-center

software-center 1.1.15

Drag and dropping of images from the Software Centre should be disabled. There are two issues which currently occur wrt the drag and dropping of images.

- Drag any category icon from any category view onto your desktop. Nautilus will try to copy the whole of your root filesystem onto your desktop.
- Drag any screenshot from the details view onto your desktop. You will get a link to the meaningless file:///#.

UPDATE 2010-03-22: Testing with software-center 1.1.7, I am unable to reproduce the first issue above. In my experience, dragging of a category icon to the desktop is not possible with this version. I was however able to reproduce the second issue, the drag of a screenshot thumbnail.

I found two additional issues in 1.1.17:

- Drag the "Featured Applications" button in the categories screen to the desktop and a bogus "Link to Featured Applications" icon is added to the desktop.
- The decorative software center icon at the upper right of the categories screen is draggable as well, and should not be.

Gary Lasker (gary-lasker) wrote :

Hi Kiwinote. First, I want to say that I was not able to reproduce the first issue that you describe above, that is, dragging of a category icon to the desktop. I tested using Software Center 1.1.17 and Ubuntu Beta 1 plus updates to today, and with this configuration, I am unable to drag the category icons to the desktop.

However, I can confirm the second issue you reported, that is, that dragging the screenshot thumbnail in details view to the desktop creates a link to a meaningless file just as you describe.

I've checked in a fix for this second problem by disabling dragging of the screenshot thumbnail image in the details view.

In addition, I disabled dragging the "Featured Applications" button in the categories view, as this would place a "Link to Featured Applications" icon on the desktop. I also disabled dragging images in the categories view in general so that the new Software Center logo at the upper right of the view is no longer draggable.

I'll update the description with these details.

Oh, and if you get a chance, please verify that indeed the category icon drag issue no longer occurs with Software Center 1.1.17.

Many thanks!

Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
importance: Undecided → Low
status: New → Fix Committed
description: updated
Kiwinote (kiwinote) wrote :

Hi Gary. I can also no longer reproduce the first issue, dragging category items to the desktop. This must have been fixed during the redesign. Thanks!

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.18

---------------
software-center (1.1.18) lucid; urgency=low

  [ Michael Vogt ]
  * data/templates/AppDetailsView.html:
    - cherry pick progress nice bar improvements from
      Michael Forrest (many thanks)
  * softwarecenter/view/appdetailsview.py:
    - show correct maintenance status for non applications
      (LP: #538172)
  * softwarecenter/view/appview.py:
    - use "ubuntu-almost-fixed-height-mode" when available
      to speed up the treeview drawing significantly
      (LP: #514879)
  * softwarecenter/view/softwarepane.py:
    - set show_ratings to "false" because ratings&reviews are
      cancelt for lucid (LP: #538129)
  * softwarecenter/view/appview.py:
    - only show active pane ratings if show_ratings is true

  [ Gary Lasker ]
  * data/ui/SoftwareCenter.ui:
    - don't translate available pane notebook labels
      (LP: #539371)
  * softwarecenter/view/viewswitcher.py:
    - when collapsing a node in the left pane (e.g. "Get Software"),
      select the node (LP: 532774)
  * softwarecenter/view/appview.py:
    - tweak padding in list view buttons (LP: #537524)
  * data/templates/AppDetailsView.html,
    data/templates/CategoriesView.html:
    - set following items as not draggable; screenshot thumbnail
      in details view, "Featured Applications" icon and general
      images in categories view (LP: #530163)
 -- Michael Vogt <email address hidden> Tue, 23 Mar 2010 10:13:26 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers