Software Center is missing several icons in KDE/Xubuntu

Bug #527503 reported by Jeremy Bicha on 2010-02-25
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Kiwinote
Nominated for Lucid by james r

Bug Description

Binary package hint: software-center

If Software Center is run in KDE instead of in GNOME, several icons are missing.

Featured
Games>Arcade, Board, Kids, Role playing, Sports
Also, I have the Google repository installed (for Google Chrome) but the icon doesn't look right.

ProblemType: Bug
Architecture: amd64
Date: Thu Feb 25 04:34:34 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100219.1)
Package: software-center 1.1.14
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: software-center
Uname: Linux 2.6.32-14-generic x86_64

Jeremy Bicha (jbicha) wrote :
Changed in software-center (Ubuntu):
status: New → Confirmed
Steve Beattie (sbeattie) wrote :

I'm seeing this also on Xubuntu after a karmic->lucid upgrade.

summary: - Software Center is missing several icons in KDE
+ Software Center is missing several icons in KDE/Xubuntu
Steve Beattie (sbeattie) wrote :
tags: added: iso-testing
Steve Langasek (vorlon) on 2010-04-12
Changed in software-center (Ubuntu):
importance: Undecided → High
HughDaniel (hugh-toad) wrote :

As of today (2010-04apr-25sun) this bug still exsists in Kubuntu installs of Lucid.

Rob Kirton (rob-kirton) wrote :

As of today (2010-04apr-30Fri) this bug exists in Ubuntu 10.04 LTS. Following over air upgrade from 9.10

coloradoz (ajsenol) wrote :

This bug still exists in Ubuntu 10.04 LTS, after clean install (after the over air upgrade hosed up my system). Using Radeon 8500, missing icons are:

Main Menu
   Fonts
   Developer Tools
Accessories
   XPad
Games
  Category Board Games
  Category Card Games
  Category Puzzles
  Category Role Playing
  Category Simulation
  Category Sports
Graphics
  Category 3D
  Category Drawing
  Category Painting and Editing
  Category Publishing
  Category Photography
Internet
  Category File Sharing
  Category Mail
  Category Web Browsers
  Category Chat
Science and Engineering
  Category Biology
  Category Astronomy
  Category Electronics
  Category Geography
  Category Geology
  Category Physics
  Category Mathematics
Developer Tools
  Category Debugging
  Category Graphic Design
  Category Haskell
  Category Java
  Category Mono/CLI
  Category Python
  Category Ruby

Jesse Palser (jessepalser) wrote :

Hi,

I have this issue on two different computers with Ubuntu 10.04 Final 32bit.
Many icons in Ubuntu Software Center are missing!
Hope this can be fixed soon...

Jesse

Daniel Kessler (hornord) wrote :

Reproduced on a new install of Lucid 10.04. Here's a couple of screenshots (swiss french locale).

Daniel Kessler (hornord) wrote :
Daniel Kessler (hornord) wrote :
malangaman (cahevia) wrote :

I have this bug in two different machines, both with NVIDIA cards and Lucid 10.04, both upgrades from 8.04

ggregorsch (ggregorsch) wrote :

I also tried many other sets of icons but than Software Center didn't start. It only works with Oxygen and Gnome icons but many icons are missing.

Andrew Yorke (andrew-yorke) wrote :

Clean install on two different computers of ubuntu 10.04. Computer with dual monitor nvidia card is missing icons from the software manager, other computer had no issues at all.

Alan Potter (alan-potter) wrote :

I have this problem on two computers both running 10.04 Final 64-bit and both upgraded from 9.10 Final 64-bit. One is a laptop with an NVIDIA GeForce 9300M, the other is a desktop with two linked NVIDIA 9500 GTs. Both systems are running the NVIDIA drivers, use the "NVIDIA X Server Settings" and have the locale set to UK. I hope this helps.

John Rash (johnrash) wrote :

I have seen this on multiple machines when switching themes in Lucid. In Ambiance the icons are all there, but if I switch to Clearlooks some icons will disappear from Software Center, kinda like the theme is missing the icon for the category.

Brandon (brandon-2i) wrote :

I can confirm that this appears to be related to the current theme. I am missing icons on multiple computers and I have never run KDE on these systems. I tested all the out of the box themes. Below is a list that appear to be missing icons in Ubuntu's Software Center. Oddly, while Clearlook is missing icons, Human-Clearlooks is not.

Clearlooks
High Contrast Inverse
High Contrast Large Print Inverse

Kiwinote (kiwinote) on 2010-07-19
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Kiwinote (kiwinote)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.6

---------------
software-center (2.1.6) maverick; urgency=low

  [ Kiwinote ]
  * data/software-center.menu.in:
    - update query for fonts category (LP: #531570, #605459)
  * debian/control:
    - depend on humanity-icon-theme, rather than gnome-icon-theme
  * softwarecenter/app.py:
    - always append the humanity-icon-theme to the iconpath (LP: #436310, #466271, #527503, #556335, #594795)
  * softwarecenter/view/availablepane.py:
    - capitalize 'install n items' button label for mpt (LP: #605052)
  * softwarecenter/view/catview_gtk.py:
    - speed up carousel transition (thanks nuthinking) (LP: #604627)
  * softwarecenter/view/catview.py:
    - allow 'OR' tag inside an 'AND' tag

  [ Michael Vogt ]
  * softwarecenter/db/database.py:
    - parse axi values file for cataloged_time support
  * merged lp:~mvo/software-center/new-apps-test1 that adds support
    for a proper a "Whats new" category based on the xapian
    cataloged_time information
  * debian/control:
    - recommend aptdaemon (>= 0.38ubuntu1) to get catalogued_time
      support
    - recommend sessioninstaller for PK compatible session API
  * merged lp:~hellium/software-center/logging, thanks to
    Geliy Sokolov
  * merged lp:~mmcg069/software-center/bigger-icons, the icon size
    is actually the same, name is a bit misleading. It contains a new
    actionbar, but that is not yet enabled as its not feature complete
    yet
  * merged lp:~didrocks/software-center/fix-running-standalone-pane,
    many thanks
  * Support "pkgname/long appname with spaces" on the commandline when
    a single argument is passed. Without "/" its just considered a
    pkgname

  [ Gary Lasker ]
  * merge lp:~mmcg069/software-center/appdetailsview-gtk-mpt, many nice
    UI tweaks and improvements from Matthew McGowan, thanks!
  * softwarecenter/view/widgets/navigationbar.py,
    softwarecenter/view/softwarepane.py:
    - remove the old navigation bar as we won't be going back to it
  * softwarecenter/view/availablepane.py:
    - don't call set_category if viewing details or searching to
      reduce unnecessary applist refreshes
  * softwarecenter/view/appview.py;
    - fix app row reselect in the applist view for sorted lists and also
      for channels when the model is regenerated rather than replaced
      (LP: #609945)
  * test/test_appview.py:
      add tests for correct sorting for app insert case and for
      index map updating
  * merge lp:~didrocks/software-center/add-remove-multiple to add a
    remove_multiple method to aptd.py, thanks to Didier Roche!
 -- Michael Vogt <email address hidden> Tue, 27 Jul 2010 19:45:53 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
james r (jars-u) wrote :

I still have the same missing icons in Ubuntu Software Center from a clean install and update of Ubuntu 10.04 32bit, using Gnome and Clearlooks but if I switch the theme to Ambiance the icons are restored.

Kiwinote (kiwinote) wrote :

Hi James. This issue has been resolved in the development version of Ubuntu 10.10, of which the final release will be available in October. Having said that, this may or may not be suitable to update in Ubuntu 10.04 as well, but I'll leave that to mvo or tremolux to decide.Thanks for your help.

Jonathan Siebott (jonsiebott) wrote :

Is it possible to install the package software-center-2.1.6 and replace bug ridden software-center-2.0.7 which came with Lucid? If so, how do I do it?

Andrew P. (japoth) wrote :

I'm seeing the same problem in Ubuntu 10.04.1 LTS with Gnome. The problem appeared after I removed OpenOffice and installed LibreOffice 3.4.5 in its place. I tried removing software-center and reinstalling it from the repository, but it didn't fix the problem.

There was an anomaly immediately after the OpenOffice-LibreOffice changeover. When I ran Update Manager it indicated that only a partial upgrade was possible due to a dependency mismatch, or something to that effect. I proceeded with the so-called "partial upgrade" and happened to notice that it removed cups-pdf in the process, along with several other items that should NOT have been removed, leaving me without a PDF printer driver. I subsequently reinstalled cups-pdf via a terminal window. When I ran Update Manager again it said my system was up-to-date and everything appeared to be in order. However, when I now open Software Center, it runs extremely slowly and the Fonts icon does not get populated. When I click on the various Get Software icons, the subsequent screens take a very long time to load and most of the second-level icons are missing, exactly as shown in the screen shot by Steve Beattie (sbeattie) on 2010-04-06. The animated "busy" cursor is displayed and the window doesn't get populated with icons at all sometimes.

Andrew P. (japoth) wrote :

After my 2012-02-10 post I discovered that the missing icons are simply due to them not being present in the desktop theme I selected after installing Ubuntu 10.04 LTS. I chose" Clearlooks", and that's when the icons disappeared. By going back to the "Ambiance" default theme, the icons reappear. See my post this date at http://ubuntuforums.org/showthread.php?t=1474552&page=2. I've also attached a tar.gz archive of my modified /usr/share/icons/gnome/scalable/categories directory there to make it easier to patch new 10.04 installations.

no longer affects: software-center
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers