details update very very slow

Bug #514879 reported by Kiwinote on 2010-01-30
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Wishlist
gtk+2.0 (Ubuntu)
Low
Sebastien Bacher
Lucid
Low
Sebastien Bacher
software-center (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: software-center

software-center 1.1.10

Steps to reproduce:
-open new software-center,
-browse to system packages > shells > dash > details,
-click on system packages on the path bar,
-browse to admin > 9mount > details,
-now the dash details view is displayed for about 5 seconds before reverting to the 9mount details.

As far as I can tell this only happens with system packages.

Michael Vogt (mvo) wrote :

This is a result of us not using fixed height mode anymore. The event processing that gtktreeview is doing is interfering with the events we use in the webkit widget. Once fixed_height mode is activated again it works fine again.

Changed in software-center (Ubuntu):
status: New → Confirmed
milestone: none → ubuntu-10.04
Michael Vogt (mvo) on 2010-02-01
summary: - details mismatch
+ details update very very slow
Michael Vogt (mvo) on 2010-03-16
Changed in software-center (Ubuntu):
importance: Undecided → High
Michael Vogt (mvo) wrote :

Runtime (from demo program in the bugzilla report):
normal mode: 4.75834488869
events fixed_height: 0.190175056458

Runtime with patched gtk and "ubuntu-almost-fixed-height" property set:
normal mode: 4.78250980377
events fixed_height: 0.126662015915

So no decrease (but no speedup either, the difference is just noise).

Row expand/collapse works fine with the code. Software-center is snappier and this
particular bug is fixed. But there are still some areas where we need to work to make
it faster in the code now that gtk does not hide this anymore.

tags: added: patch
Changed in software-center (Ubuntu Lucid):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

Thank you

Changed in gtk+2.0 (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Low
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.19.7-0ubuntu2

---------------
gtk+2.0 (2.19.7-0ubuntu2) lucid; urgency=low

  * debian/patches/063_treeview_almost_fixed.patch:
    - change by Michael Vogt to add an ubuntu-almost-fixed-height-mode property,
      the change is required for software-center, adding as an ubuntu specific
      change for now until somebody comment on the upstream bug (lp: #514879)
  * debian/patches/064_initial_fileselector_select.patch:
    - change by Cody Russell to fix the default action not working in the
      gtkfileselector until you selected a directory (lp: #80755, #181788)
 -- Sebastien Bacher <email address hidden> Mon, 22 Mar 2010 14:23:46 +0100

Changed in gtk+2.0 (Ubuntu Lucid):
status: Triaged → Fix Released
Michael Vogt (mvo) on 2010-03-23
Changed in software-center (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.18

---------------
software-center (1.1.18) lucid; urgency=low

  [ Michael Vogt ]
  * data/templates/AppDetailsView.html:
    - cherry pick progress nice bar improvements from
      Michael Forrest (many thanks)
  * softwarecenter/view/appdetailsview.py:
    - show correct maintenance status for non applications
      (LP: #538172)
  * softwarecenter/view/appview.py:
    - use "ubuntu-almost-fixed-height-mode" when available
      to speed up the treeview drawing significantly
      (LP: #514879)
  * softwarecenter/view/softwarepane.py:
    - set show_ratings to "false" because ratings&reviews are
      cancelt for lucid (LP: #538129)
  * softwarecenter/view/appview.py:
    - only show active pane ratings if show_ratings is true

  [ Gary Lasker ]
  * data/ui/SoftwareCenter.ui:
    - don't translate available pane notebook labels
      (LP: #539371)
  * softwarecenter/view/viewswitcher.py:
    - when collapsing a node in the left pane (e.g. "Get Software"),
      select the node (LP: 532774)
  * softwarecenter/view/appview.py:
    - tweak padding in list view buttons (LP: #537524)
  * data/templates/AppDetailsView.html,
    data/templates/CategoriesView.html:
    - set following items as not draggable; screenshot thumbnail
      in details view, "Featured Applications" icon and general
      images in categories view (LP: #530163)
 -- Michael Vogt <email address hidden> Tue, 23 Mar 2010 10:13:26 +0100

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in software-center:
importance: Unknown → Wishlist
status: Unknown → New
affects: software-center → gtk
Changed in gtk:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.