search for specific application does not return that application at top of results list

Bug #509318 reported by Andrew Marsh on 2010-01-18
80
This bug affects 11 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

A search for a specific application will often return results in which the application searched for is displayed quite far down the list.

For example a search for gnome do results in gnome do being the tenth item on the list.

http://img96.imageshack.us/img96/2330/screenshotubuntusoftwar.png

A better search would sort items by relevance to the search query, and when searching for a name of an application, always return that application as the first result.

ProblemType: Bug
Architecture: i386
Date: Mon Jan 18 20:06:49 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: software-center 1.0.2
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: software-center
Uname: Linux 2.6.31-17-generic i686

Andrew Marsh (andrewmarsh01) wrote :
Michael Vogt (mvo) on 2010-01-21
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
description: updated
tags: added: rhubarb
Changed in software-center (Ubuntu):
milestone: none → natty-alpha-3
Jean-Baptiste Lallement (jibel) wrote :

My report #688547 has been marked as duplicate of this one, but this used to work until somewhere around Dec. 10th where my automated test started to fail.
So this looks like a regression introduced by a recent change.

Jean-Baptiste Lallement (jibel) wrote :

Fixed in 3.1.7 uploaded this morning.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers