software-center crashed with TypeError in _animation_helper() if closed while installing

Bug #508044 reported by Dmitry Tantsur on 2010-01-15
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

Reproduce:
1. Begin installing some package
2. Close software-center before installation ends
3. It crashes

ProblemType: Crash
Architecture: i386
Date: Fri Jan 15 21:22:56 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
InterpreterPath: /usr/bin/python2.6
Package: software-center 1.1.8
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=ru_RU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Tags: lucid
Title: software-center crashed with TypeError in _animation_helper()
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/view/widgets/animatedimage.py", line 123, in _animation_helper
     cell_area = widget.get_cell_area(row.path, widget.get_column(0))
 TypeError: could not convert path to a GtkTreePath
Uname: Linux 2.6.32-10-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Dmitry Tantsur (divius) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Omer Akram (om26er) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Kiwinote (kiwinote) wrote :

Hi!

Thanks for your bug report and sorry for the delayed response.
As you may be aware, during each cycle a lot of work goes into
software-center. However, over time we build up a long list of
bugs which are most likely no longer present in recent versions
of software-center.

In an attempt to clean up the bug list for software-center I am
expiring this bug because it meets one or more of the following
criteria:
- it would seem quite likely that this bug is no longer present
  in recent versions of software-center,
- the bug report does not contain sufficient information for us
  to reproduce and/or fix the bug,
- the issue is most likely in an external piece of code and has
  most likely been fixed since the bug was reported.

If you experience any problems in recent development versions
of software-center, please do continue to report new bugs.
Thanks again for your help!

Changed in software-center (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers