Search greylist items aren't ignored sometimes

Bug #506419 reported by Matthew Paul Thomas on 2010-01-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: software-center

Ubuntu Software Center 1.1.7, Ubuntu 9.10

From <https://wiki.ubuntu.com/SoftwareCenter#get-software-searching>: 'Test case: From the lobby, search for “drawing”. Then search for “drawing program”. The Center should return exactly the same results for both searches, but in a different order.'

This nearly works, but not quite: "drawing" returns 175 matching items, but "drawing program" returns 174.

Similarly "font" returns 194 matching items, but "font package" returns 193.

Other searches work as expected, e.g. "icon editor" and "icon editor application" return exactly the same results.

Related branches

Changed in software-center (Ubuntu):
importance: Undecided → Low
Kiwinote (kiwinote) wrote :

Confirming on 'font' and 'font package'. 'drawing' and 'drawing program' both return 176 results here.

Changed in software-center (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) wrote :

I have tried to reproduce this, and I have observed the following:
a) when I search for 'font' I get 45(741) items (the second number is the number for technical items)
b) when I search for ' font' (notice the leading space) the result is the same as in a, as it is expected
c) when I search for 'font ' (notice the trailing space) the result is 32(464) items - this should not happen, as the search term should be stripped from trailing and leading spaces
d) when I search for 'font app'/'font package'/'font [GREYLIST_WORD]' the result is the same as in C, so the problem is not the greylist words being ignored, but the separator ' ' character influencing the search results.

Robert Roth (evfool) on 2011-05-24
Changed in software-center (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.3

---------------
software-center (4.1.3) oneiric; urgency=low

  [ Michael Vogt ]
  * merged lp:~mvo/software-center/refactor, no user visible
    changes, only code cleanup
  * merged lp:~mvo/software-center/pyflakes, no user visible
    changes, only code cleanup
  * enforce pyflakes cleaness on bzr-buildpackage
  * merged lp:~mvo/software-center/review-language-fallback
    to support fallback to other languages if there are no
    reviews in the native language
  * merged lp:~evfool/software-center/fix506419, many thanks!
    (LP: #506419)

  [ Gary Lasker ]
  * softwarecenter/app.py:
    - expand the "Get Software" item in the viewswitcher by default
      so that its subitems are always visible and available
      (LP: #774590)
  * merged lp:~aaronp/software-center/refactoring, many thanks
    to Aaron Peachey
  * softwarecenter/app.py,
    softwarecenter/backend/restfulclient.py,
    softwarecenter/backend/rnrclient.py,
    softwarecenter/db/update.py:
    - fix some root logger warnings, other cleanup
  * merged lp:~evfool/software-center/carouseltransition, very
    nice effect, many thanks Robert Roth (LP: #633193)
  * softwarecenter/ui/gtk/availablepane.py,
    softwarecenter/ui/gtk/catview_gtk.py:
    - jumpstart Featured and What's New carousel transitions
      on launch (LP: #786403)
 -- Michael Vogt <email address hidden> Tue, 24 May 2011 12:10:09 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers