xapian query doesn't handle the "-" chars correctly

Bug #497708 reported by Sebastien Bacher on 2009-12-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Kiwinote

Bug Description

Ubuntu Software Center 2.0.5, Ubuntu 10.04
software-center trunk r909, Ubuntu 10.04

Searching for "indicator-appli" doesn't find "indicator-application" for example, all the letters need to be typed to get the query working as expected.

Similarly searching for "python-eggtrayico" doesn't find "python-eggtrayicon".

<https://wiki.ubuntu.com/SoftwareCenter#Searching%20in%20general>: "When searching anywhere in the Center, any word in the search string that is followed by a space or punctuation should be treated as a complete word, while any word that is not should be treated as if it may be either a complete word or the beginning of a word."

Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → High
milestone: none → ubuntu-10.04
Michael Vogt (mvo) on 2009-12-17
Changed in software-center (Ubuntu):
importance: High → Medium
status: New → Confirmed
description: updated
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
description: updated
Kiwinote (kiwinote) on 2010-11-23
Changed in software-center (Ubuntu):
assignee: Michael Vogt (mvo) → Kiwinote (kiwinote)
milestone: ubuntu-10.04 → none
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.3

---------------
software-center (3.1.3) natty; urgency=low

  [ Michael Vogt ]
  * daily-build.recipe:
    - add daily build recipe
  * test/test_xapian.py:
    - add lowlevel test for "find more similar apps" DB query
  * softwarecenter/db/update.py:
    - generate spell checking data
  * softwarecenter/enums.py:
    - increase DB version (because we now have spell checking in the DB)
  * test/test_xapian.py:
    - add lowlevel test for spell checking feature
  * merged lp:~mvo/software-center/apthistory-pickle-cache to avoid
    (re)parsing most of the apthistory

  [ Kiwinote ]
  * apt-xapian-index-plugin/origin.py (tmp location),
    softwarecenter/db/database.py,
    softwarecenter/db/update.py:
    - make search queries containing '-' work (LP: #497708)
  * po/POTFILES.in:
    mark softwarecenter/view/softwarepane.py for translation (LP: #659955)

  [ Mohamed Amine IL Idrissi ]
  * softwarecenter/view/availablepane.py,
    softwarecenter/view/softwarepane.py:
    - use named arguments for translatable plural strings (LP: #630955)
  * softwarecenter/view/historypane.py:
    - use 'updated' instead of 'upgraded' (LP: #635196)

  [ Gary Lasker ]
  * softwarecenter/app.py:
    - remove unused code; we don't lazy-load entire history pane, rather
      we create the pane UI but then load/parse apthistory on demand
  * po/POTFILES.in:
    - mark login_sso.py, update.py, dependency_dialogs.py and
      purchasedialog.py for translation
 -- Michael Vogt <email address hidden> Tue, 30 Nov 2010 14:40:59 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released

Dear,

It's a beautiful day and i'am in a hurry to get in touch with you asap!

My name is Nataliya.
I really do believe in a destiny with a bright future for myself and that you could become a part of it become my true soulmate.
I do want to be next to a loving man.

I love traveling, movies, pop music, seafood, and doing crazy things, but i feel like loneliness is swallowing me intensely lonely sometimes.
I wish to find for my second half, who a man that will give me a real hope and true love!

Hope you're interested in becoming a part of my adventure and will reply back soon.
In the next letter, I'll send you my photo.

Please write me back using my personal email: <email address hidden>

--------------------------
Your true soul,
Nataliya.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers