software-center crashed with NoSectionError in set()

Bug #494899 reported by Geoffrey P. on 2009-12-10
552
This bug affects 109 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: software-center

Opened up Software Center to see what versions of some popular software are standard with Lucid. I looked up MySQL and Apache. I did not install anything. I closed out of Software Center and then was alerted to a crash by Apport.

ProblemType: Crash
Architecture: i386
Date: Thu Dec 10 07:42:10 2009
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
Package: software-center 1.1.3
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-7.10-generic
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Tags: lucid
Title: software-center crashed with NoSectionError in set()
Uname: Linux 2.6.32-7-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Geoffrey P. (geoffrey-p) wrote :
tags: removed: need-duplicate-check
Steve Beattie (sbeattie) on 2009-12-14
visibility: private → public
Erik B. Andersen (azendale) wrote :

This also happened to me on my 64 bit install. I install gtk-recordmydesktop and closed when it was done. Then apport came up.

tags: added: amd64
Don Forigua (ingforigua) wrote :

It also affect me after i just installed geda, and i close the software center

George Kontis (giormatsis) wrote :
Gerhard Lang (lang-gerhard) wrote :

install zynaddsubfx worked properly, independent from this alert

Philipp Meier (meier-philipp) wrote :

It is quite easy to reproduce the error. Just start Software Center and Close it again, after some seconds there will be the Apport message with the above error.

Setting bug to confirmed.

Changed in software-center (Ubuntu):
status: New → Confirmed
Philipp Meier (meier-philipp) wrote :

My Traceback.

Michael Vogt (mvo) on 2010-01-08
Changed in software-center (Ubuntu):
milestone: none → lucid-alpha-2
Changed in software-center (Ubuntu Lucid):
importance: Undecided → Medium
Michael Vogt (mvo) on 2010-01-08
Changed in software-center (Ubuntu Lucid):
status: Confirmed → In Progress
Tom Pino (metalsmith-rangeweb) wrote :

I was not doing any thing with the app at all (can't stand it really) I just got the notification.

I am on a 64bit version.

reyad (al-shorafa) on 2010-01-11
description: updated
IDWMaster (webadm) wrote :

I was also installing gtk-recordmydesktop when it crashed. How many people were also affected by the problem when installing this application?

Philipp Meier (meier-philipp) wrote :

Did gtk-recordmydesktop install fine? Because this bug seems not to be related with any special install / remove action but just with the software-center.

IDWMaster (webadm) wrote :

Yes. The software installed without any additional problems.

George Kontis (giormatsis) wrote :

It works like IDWMaster says .

George Kontis (giormatsis) wrote :

i just installed some more pakages and din't got the error again . is it fixed ?

Philipp Meier (meier-philipp) wrote :

Still has the same error with version 1.1.7.

Maxim Baskakov (ksaver) wrote :

Also caught this error on 32bit-system.

Charlie Kravetz (charlie-tca) wrote :

Xubuntu Lucid crashed after adding gedit with Software Center. Version used to install was lucid-alternate-i386.iso dated 2010-01-12.2.

tags: added: iso-testing
tags: added: bugpattern-needed
tags: added: bugpattern-written
removed: bugpattern-needed
Vish (vish) wrote :

mvo , The bug has been scheduled for alpha 2. Should it be pushed back?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.8

---------------
software-center (1.1.8) lucid; urgency=low

  * softwarecenter/view/appdetailsview.py:
    - replace thumbnail checking thread with (much nicer) gio
      code
  * softwarecenter/app.py:
    - simplify state save logic
    - save window size
    - fix crash in ConfigParser (LP: #494899)
  * softwarecenter/view/installedpane.py:
    - fix search in installed section (LP: #504380)
  * softwarecenter/apt/aptcache.py:
    - fix missing warning on removal for non-english systems
      (LP: #486474)
  * softwarecenter/view/widgets/imagedialog.py:
    - fix crash because of missing import
 -- Michael Vogt <email address hidden> Wed, 13 Jan 2010 14:39:35 +0100

Changed in software-center (Ubuntu Lucid):
status: In Progress → Fix Released
Charlie Kravetz (charlie-tca) wrote :

Just a quick note to say thank you. With the update today, this is now fixed in Xubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers