software-center doesn't alert when trying to delete important packages

Bug #486474 reported by Bartolomeo Luca Librera on 2009-11-22
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Critical
Michael Vogt
Karmic
Critical
Michael Vogt
Lucid
Critical
Michael Vogt

Bug Description

TEST CASE:
1. use karmic
2. open software-center
3. search for python2.6
4. go to the details and click on "remove"
5. verify that a password prompt comes up immediately without any warning

6. install the version of software-center in karmic-proposed
7. repeat steps 2-4
8. verify that there is a warning now

Binary package hint: software-center

On a fresh 9.10 install with latest updates, when a user opens Ubuntu Software Center and tries to delete a package who has dependencies on it, there isn't any alert. The software just requests the password without any other confirmation.

This behaviour doesn't follow the guidelines explained at https://wiki.ubuntu.com/SoftwareCenter#Removing%20an%20application
After the removal process is started, X shutdowns itself and the distribution becomes pretty broken.

After some digging I've found this bug can be replicated with Italian or French language, but doesn't happen with English language, so it seems related to localization. It still remains critical, for people who don't use Ubuntu in English.

Ubuntu version: 9.10
software-center version: 1.0.2

summary: - software-center doesn't alert when trying to delete python
+ software-center doesn't alert when trying to delete packages
description: updated
description: updated
summary: - software-center doesn't alert when trying to delete packages
+ software-center doesn't alert when trying to delete important packages
Andrew (and471) wrote :

Could you run software-center in a terminal and paste any output when you do this?

Changed in software-center (Ubuntu):
status: New → Incomplete

I'm attaching the terminal paste of software-center --debug run in italian and english environment.

I'm also attaching screenshots to explain the different visual behaviour.

Please consider raising importance to critical, since this bug lets the user delete packages like python, destroying the system (X shutdowns itself during the removal, and doesn't restart anymore).

Giuseppe D'Angelo (dangelo) wrote :

This is just horrible.

Please raise the severity to critical, since this is a major malfunction.

And please blame the translation teams or whatever causes this bug to depend on the localization.
Why the heck there's no "It's used by 5 pieces of installed software" in Italian?
HOW is it possible to miss a string freeze? And if it's untranslated, why doesn't it appear written in English?

Why does Ubuntu ship this kind of pre-alpha software in what should be the "stable" distro?

And why there's python in there, and not things like perl? (Just for having some more interesting fun)

Changed in software-center (Ubuntu):
status: Incomplete → New
Micah Gersten (micahg) wrote :

I was able to confirm that I was prompted to remove update-manager with python which seems like something we don't want to allow a user to do.

Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Triaged

I'd like to point out that if a user uses a language different from English (I've run tests with Italian and French) for the system, software-center does NOT even prompt to remove update-manager, it just starts deleting packages.
This wrong behaviour applies to ANY package who has dependencies on it.

Changed in software-center (Ubuntu):
importance: High → Critical
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can reproduce the problem with non-english locales. Attached is a fix for karmic that I intend to upload to karmic-updates.

For lucid this will be fixed differently (by fixing python-apt to provide a API that is not locale dependant).

Michael Vogt (mvo) wrote :
Changed in software-center (Ubuntu Karmic):
status: New → In Progress
Michael Vogt (mvo) on 2010-01-13
description: updated
Michael Vogt (mvo) on 2010-01-13
Changed in software-center (Ubuntu Karmic):
importance: Undecided → Critical
Changed in software-center (Ubuntu Lucid):
status: Triaged → In Progress
assignee: nobody → Michael Vogt (mvo)
Changed in software-center (Ubuntu Karmic):
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.8

---------------
software-center (1.1.8) lucid; urgency=low

  * softwarecenter/view/appdetailsview.py:
    - replace thumbnail checking thread with (much nicer) gio
      code
  * softwarecenter/app.py:
    - simplify state save logic
    - save window size
    - fix crash in ConfigParser (LP: #494899)
  * softwarecenter/view/installedpane.py:
    - fix search in installed section (LP: #504380)
  * softwarecenter/apt/aptcache.py:
    - fix missing warning on removal for non-english systems
      (LP: #486474)
  * softwarecenter/view/widgets/imagedialog.py:
    - fix crash because of missing import
 -- Michael Vogt <email address hidden> Wed, 13 Jan 2010 14:39:35 +0100

Changed in software-center (Ubuntu Lucid):
status: In Progress → Fix Released

Accepted software-center into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Mitch Towner (kermiac) wrote :

I can confirm this bug as per the Test Case when using French locale. No warning is displayed regarding uninstalling extra packages, only the password prompt is displayed.

$ uname -a
Linux ubuntu 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

$ apt-cache policy software-center
software-center:
  Installé : 1.0.2
  Candidat : 1.0.2
 Table de version :
 *** 1.0.2 0
        500 http://mirror.optus.net karmic/main Packages
        100 /var/lib/dpkg/status

$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

______________________________________

Enabled "proposed" to verify fix for SRU

$ uname -a
Linux ubuntu 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

$ apt-cache policy software-center
software-center:
  Installé : 1.0.3
  Candidat : 1.0.3
 Table de version :
 *** 1.0.3 0
        500 http://mirror.optus.net karmic-proposed/main Packages
        100 /var/lib/dpkg/status
     1.0.2 0
        500 http://mirror.optus.net karmic/main Packages

$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

After updating to proposed package, a warning message is displayed advising of other packages that would be uninstalled (See screenshot - http://imgbin.org/images/1174.png). All other behaviour appears to be working as expected apart from experiencing Bug #434601 (after changing my locale from French back to English all of the app summary descriptions were still in French - see http://imgbin.org/images/1175.png).

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.0.3

---------------
software-center (1.0.3) karmic-proposed; urgency=low

  * Fix warning when removing software that other software depends
    on for non-english locales (LP: #486474)
 -- Michael Vogt <email address hidden> Wed, 13 Jan 2010 10:27:20 +0100

Changed in software-center (Ubuntu Karmic):
status: Fix Committed → Fix Released
equiman (equiman) wrote :

I have the same problem... i'm remove the sound record... and automatically remove me gNome Media without any message. Additonally Ubuntu Software Center Freeze and don't response.

DP: Sorry my english isn't very good.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers