Can't copy text from software item descriptions

Bug #477285 reported by Subsanek on 2009-11-07
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Matthew McGowan
Ubuntu Software Center
Invalid
Undecided
Unassigned
software-center (Ubuntu)
Low
Unassigned

Bug Description

In the description of programs and budgets are often required to copy this information, but the copy - paste from the software-center is not working.
This is not very convenient.

<https://wiki.ubuntu.com/SoftwareCenter#software-item-screen-copying> (unscheduled feature): "Whenever text is selected in a software item screen, “Edit” > “Copy” should be sensitive. Choosing it should copy the selected text to the clipboard."

Subsanek (subsanek) wrote :
Changed in software-center:
status: New → Invalid
description: updated
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → Low
summary: - Not "copy-paste" in software-center
+ Can't copy text from software item descriptions

I'm also affected by this bug. Running 10.10.

Hi,

I am working to replace some of the webkit portions of s-c with gtk
implementations. When finished it should solve your issues.

Branch is at:
lp:~mmcg069/software-center/appdetailsview-gtk

At this point its a work in progress, hence ymmv.

On Tue, Jun 29, 2010 at 10:25 PM, devildante <email address hidden> wrote:
> I'm also affected by this bug. Running 10.10.
>
> ** Also affects: hundredpapercuts
>   Importance: Undecided
>       Status: New
>
> --
> Can't copy text from software item descriptions
> https://bugs.launchpad.net/bugs/477285
> You received this bug notification because you are a member of software-
> store-developers, which is the registrant for software-store.
>

--
From the mind of me!

Daniel Neel (dneelyep) on 2010-07-09
Changed in hundredpapercuts:
status: New → Confirmed
Matthew McGowan (mmcg069) wrote :

Hi,

My branch has been merged into trunk. I think it should solve this
issue. If someone could possibly test trunk to ensure this issue is
corrected, it would be much appreciated.

Cheers

On Fri, Jul 9, 2010 at 12:39 PM, Daniel Neel <email address hidden> wrote:
> ** Changed in: hundredpapercuts
>       Status: New => Confirmed
>
> --
> Can't copy text from software item descriptions
> https://bugs.launchpad.net/bugs/477285
> You received this bug notification because you are a member of software-
> store-developers, which is the registrant for software-store.
>

--
From the mind of me!

Matthew Paul Thomas (mpt) wrote :

This bug is now partly fixed. In software-center trunk r902, I can:
* select text from inside one paragraph of the description, and copy it by typing Ctrl C.

I cannot:
* select text from more than one paragraph of the description at once;
* select any text from the title or summary;
* copy any text using "Edit" > "Copy".

Matthew McGowan (mmcg069) wrote :

Hi, I can look into these issues. I have an idea in mind as to how i
can improve things but it might be a bit tricky.

On Tue, Jul 13, 2010 at 10:34 PM, Matthew Paul Thomas <email address hidden> wrote:
> This bug is now partly fixed. In software-center trunk r902, I can:
> * select text from inside one paragraph of the description, and copy it by typing Ctrl C.
>
> I cannot:
> * select text from more than one paragraph of the description at once;
> * select any text from the title or summary;
> * copy any text using "Edit" > "Copy".
>
> --
> Can't copy text from software item descriptions
> https://bugs.launchpad.net/bugs/477285
> You received this bug notification because you are a member of software-
> store-developers, which is the registrant for software-store.
>

--
From the mind of me!

Changed in hundredpapercuts:
status: Confirmed → Triaged
importance: Undecided → Low
Changed in hundredpapercuts:
milestone: none → nt10-sc-metadata
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Matthew McGowan (mmcg069) wrote :

Hi,

I am working on another solution, its in trunk, at the moment. play
around with that and let me know what issues you hit.

Cheers
Matthew

On Sun, Nov 28, 2010 at 2:35 AM, Sense Hofstede <email address hidden> wrote:
> ** Changed in: hundredpapercuts
>    Milestone: None => nt10-sc-metadata
>
> ** Changed in: hundredpapercuts
>     Assignee: (unassigned) => Papercuts Ninja (papercuts-ninja)
>
> --
> Can't copy text from software item descriptions
> https://bugs.launchpad.net/bugs/477285
> You received this bug notification because you are a member of software-
> store-developers, which is the registrant for software-store.
>

--
From the mind of me!

Vish (vish) on 2010-11-28
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Matthew McGowan (mmcg069)
status: Triaged → In Progress
Robert Sajdok (ris) wrote :

Maybe I miss something. I tested it on Maverick and it works. I attached screenshot.

Robert Sajdok (ris) wrote :

Robert, the problems are described in comment #5.

tags: added: a11y
Matthew McGowan (mmcg069) wrote :

I've pushed a branch that should cover the select-all and copy cases for the main description widget.

Vish (vish) wrote :

Woot!
Matthew , will this be released for Natty or is it scheduled for O.. ?

Changed in hundredpapercuts:
status: In Progress → Fix Committed
Matthew McGowan (mmcg069) wrote :

I think mvo merged this into trunk but i have not had a close look.

On Wed, Apr 6, 2011 at 11:04 PM, Vish <email address hidden> wrote:

> Woot!
> Matthew , will this be released for Natty or is it scheduled for O.. ?
>
> ** Changed in: hundredpapercuts
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/477285
>
> Title:
> Can't copy text from software item descriptions
>

--
From the mind of me!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.26

---------------
software-center (3.1.26) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/purchaseview.py:
    - block signal handlers rather than disconnect them when
      the purchase screen is not showing
    - handle case where the nav bar buttons are used to navigate
      back to the details view from the purchase screen
  * softwarecenter/view/availablepane.py,
    softwarecenter/view/softwarepane.py:
    - make custom package lists work consistently for all
      combinations of package names (LP: #748827)
  * softwarecenter/view/softwarepane.py,
    softwarecenter/view/appdetailsview_gtk.py:
    - fix ValueError crash that can occur when adding an
      app to the launcher (LP: #750144)
  * softwarecenter/test/test_appdetails_view.py:
    - update unit test for the localized date strings
      in the details view
  * refresh .pot file
  * softwarecenter/test/test_unity_launcher_integration.py:
    - fix broken unit test
  * softwarecenter/utils.py,
    softwarecenter/view/softwarepane.py,
    test/test_unity_launcher_integration.py:
    - make add to unity launcher feature work correctly for
      purchased apps, add unit test for this (LP: #752951)

  [ Robert Roth ]
  * softwarecenter/view/historypane.py:
    - expand most recent day in the history view (LP: #644438)
    - fix ellipsis of summary text in the list view on a
      window resize (LP: #678442)
  * softwarecenter/view/appdetailsview_gtk.py:
    - support localized date string for the installed date
      in the details view (LP: #751068)
  * softwarecenter/models/appstore.py:
    - correctly display half star ratings in listviews and
      the carousels (LP: #746173)

  [ Michael Vogt ]
  * merged lp:~mmcg069/software-center/Bug477285 (LP: #477285),
    many thanks!
  * merged lp:~weblive-dev/software-center/weblive-backend-fixes,
    many thanks!
  * test/test_gui_buy_something.py:
    - fix test
  * data/featured.menu.in:
    - tweaked for natty
 -- Michael Vogt <email address hidden> Thu, 07 Apr 2011 16:38:32 +0200

Changed in software-center (Ubuntu):
status: Triaged → Fix Released
Vish (vish) on 2011-04-07
Changed in hundredpapercuts:
status: Fix Committed → Fix Released

I'm still experiencing this in a fully updated Ubuntu 14.04.

I would like the ability to copy and paste package names from Software-Center.

Currently, you cannot highlight or copy text from the software center.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers