software-center crashed with SIGSEGV in pango_ot_info_get()

Bug #458629 reported by c2483 on 2009-10-22
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

Description: Ubuntu 9.10
Release: 9.10
software-center:
  Installed: 1.0.1
  Candidate: 1.0.1
  Version table:
 *** 1.0.1 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

I was browsing through the software center

ProblemType: Crash
Architecture: amd64
Date: Thu Oct 22 14:44:34 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: software-center 1.0.1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SegvAnalysis:
 Segfault happened at: 0x7f7c18aef687: movb $0x0,0x6(%rax)
 PC (0x7f7c18aef687) ok
 source "$0x0" ok
 destination "0x6(%rax)" (0x7f7c019fed9a) in non-writable VMA region: 0x7f7c019fd000-0x7f7c01a47000 r--p /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf
SegvReason: writing VMA /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf
Signal: 11
SourcePackage: software-center
StacktraceTop:
 ?? () from /usr/lib/libpangoft2-1.0.so.0
 ?? () from /usr/lib/libpangoft2-1.0.so.0
 ?? () from /usr/lib/libpangoft2-1.0.so.0
 ?? () from /usr/lib/libpangoft2-1.0.so.0
 pango_ot_info_get ()
Title: software-center crashed with SIGSEGV in pango_ot_info_get()
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

c2483 (charleswatson) wrote :

StacktraceTop:GSUBGPOS::sanitize (this=<value optimized out>,
GSUB::sanitize (this=0x41a54a0, context=0x0)
_hb_ot_layout_init (face=0x41cef70)
hb_face_create_for_data (
pango_ot_info_get (face=0x3df82b0)

Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Omer Akram (om26er) on 2010-04-23
visibility: private → public
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. if this is still an issue please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in software-center (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in software-center (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers