Font sizes are hardcoded in CSS

Bug #456604 reported by Fabián Rodríguez on 2009-10-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-center

When one changes system fonts in System > Preferences > Appearance > Fonts, USC ignores such font preferences in its main "Get Free Software" dialog/menu. See attached.

ProblemType: Bug
Architecture: i386
Date: Tue Oct 20 15:24:54 2009
DistroRelease: Ubuntu 9.10
Package: software-center 1.0
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: software-center
Uname: Linux 2.6.31-14-generic i686

Fabián Rodríguez (magicfab) wrote :
Andrew (and471) wrote :

We need to find a way to find the gnome font sizes and update the css accordingly

summary: - System font preferences are ignored in Ubuntu Software Center "Get Free
- Software" section
+ Font sizes are hardcoded in CSS

Confirming, the Get Free Software section stays at the same size for the icon text and the Categories heading.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → Low
Andrew (and471) wrote :

fixed in my branch

Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Kiwinote (kiwinote) on 2010-02-25
Changed in software-center (Ubuntu):
status: Fix Committed → Confirmed
Olivier Tilloy (osomon) wrote :

What's the status of this bug?
The linked branch, supposed to fix it, was merged, but the issue is still reproducible.

Olivier Tilloy (osomon) wrote :

It looks like the branch and the merge request are unrelated with this bug report. Wrong linking?

Olivier Tilloy (osomon) wrote :

Note for whoever wants to tackle this issue: the gnome font settings are stored in the following gconf keys:

Application font: /desktop/gnome/interface/font_name
Document font: /desktop/gnome/interface/document_font_name
Desktop font: /apps/nautilus/preferences/desktop_font

Retrieving those values is as simple as:

    import gconf
    gconf.client_get_default().get_string('/desktop/gnome/interface/font_name')

A complete patch should monitor those values to refresh the templates in Software Center upon changes.

Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. Due to a transition from webkit to gtk based views, the bug you describe is no longer present in the latest development version of software-center. Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers