Xapian cache prevents app-install-data translations from showing on new karmic installations

Bug #456459 reported by Timo Jyrinki on 2009-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
software-center (Ubuntu)
High
Michael Vogt
Karmic
High
Michael Vogt

Bug Description

Binary package hint: software-center

It seems the short descriptions aren't correctly shown as translated on new karmic installations. On older (but up-to-date) installations, the translations work. The difference looks about like this: http://users.tkk.fi/~tajyrink/softwarecenter/

I have two computers with karmic installed, and I straced software-center on both. app-install-data.mo seems not to be opened, so translations aren't checked from there. However, grepping in /var/cache/software-center/xapian shows there are translated strings in postlist.DB/value.DB on the working computer, but no translated strings on the fresh karmic installation.

The problem is probably caused by the fact that software-center xapian cache is generated during installation, but before any language packs are installed.

Workaround is to run sudo /usr/sbin/update-software-center manually, but should it be called somehow else as well?

description: updated
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The problem seems to be that all the inline translations are stripped from the app-install-data-ubuntu and moved into the language packs. That means that when update-software-center runs and no translations are installed yet it will just put all the english strings into the DB.

Michael Vogt (mvo) on 2009-10-22
Changed in software-center (Ubuntu Karmic):
status: New → In Progress
importance: Undecided → High
Michael Vogt (mvo) on 2009-10-22
Changed in software-center (Ubuntu Karmic):
assignee: nobody → Michael Vogt (mvo)
Michael Vogt (mvo) on 2009-10-22
Changed in software-center (Ubuntu Karmic):
status: In Progress → Fix Committed
Michael Vogt (mvo) wrote :

I now added a trigger that activates update-software-center when language packs are added or updated. The update-software-center will check if its running from a dpkg trigger and if that is the case updates the cache if there is a new app-install-data.mo available (it will do nothing if the app-install-data.mo is not there or has not changed).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.0.2

---------------
software-center (1.0.2) karmic; urgency=low

  * debian/triggers:
    - trigger on language-pack updates to ensure we get updated
      translations on app-install-data-ubuntu into the xapian
      database (LP: #456459)
  * utils/update-software-center:
    - when triggered from a langpack update compare mo file
      time in order to prevent unneeded updates

 -- Michael Vogt <email address hidden> Fri, 23 Oct 2009 11:24:07 +0200

Changed in software-center (Ubuntu Karmic):
status: Fix Committed → Fix Released
Adi Roiban (adiroiban) on 2009-10-26
Changed in ubuntu-translations:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers