Package information page not accessible

Bug #455320 reported by arky on 2009-10-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: software-center

Orca reads package information page content as just 'text'.

ProblemType: Bug
Architecture: i386
Date: Mon Oct 19 15:35:24 2009
DistroRelease: Ubuntu 9.10
Package: software-center 1.0
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: software-center
Uname: Linux 2.6.31-11-generic i686

arky (arky) wrote :
Andrew (and471) on 2009-10-19
Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2009-10-20
Changed in software-center (Ubuntu):
importance: Undecided → High
WaywardGeek (waywardgeek) wrote :

I believe this is caused by the use of webkit, rather than gecko. It seems webkit remains non-accessible. I would recommend switching to gecko until webkit improves.

Michael Vogt (mvo) wrote :

I commited a initial patch that improves it. Now switching into the description with tab will make it possible to read most of the descriptions. Its not perfect yet, the html that gets generated is a not ideal yet, a better generator is in lp:~mvo/software-html/improve-html

Thanks for this work. Do you know if it will get included in Ubuntu
Lucid? Also, how could I get access to your latest work? I'm not
familiar with what "lp:~mvo/software-html/improve-html" means.

Bill

On Thu, Apr 1, 2010 at 11:13 AM, Michael Vogt <email address hidden> wrote:
> I commited a initial patch that improves it. Now switching into the
> description with tab will make it possible to read most of the
> descriptions. Its not perfect yet, the html that gets generated is a not
> ideal yet, a better generator is in lp:~mvo/software-html/improve-html
>
> --
> Package information page not accessible
> https://bugs.launchpad.net/bugs/455320
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “software-center” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: software-center
>
> Orca reads package information page content as just 'text'.
>
> ProblemType: Bug
> Architecture: i386
> Date: Mon Oct 19 15:35:24 2009
> DistroRelease: Ubuntu 9.10
> Package: software-center 1.0
> PackageArchitecture: all
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=en_US.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
> SourcePackage: software-center
> Uname: Linux 2.6.31-11-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/455320/+subscribe
>

Michael Vogt (mvo) wrote :

Thanks Bill, a improved version is now in lucid and will be part of beta-2. Its not perfect yet and sometimes does not read paragraphs after the first in my tests. But its much improved and I hope to land a full fix in lucid after beta2.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.0

---------------
software-center (2.0) lucid; urgency=low

  [ Michael Vogt ]
  * softwarecenter/view/channelpane.py:
    - fix crash when gdk window is not (yet) available (LP: #560320)
  * softwarecenter/view/appdetailsview.py,
    softwarecenter/distro/__init__.py,
    softwarecenter/distro/Ubuntu.py:
    - do not show "Free" for packages from the partner repository, we
      don't know the status of the freeness there (LP: #552830)
  * merged lp:~vish.../software-center/avoidmonochromeicon, many thanks
  * re-enable action button if confirm dialog got canceled (LP: #562810)
  * merged lp:~zkrynicki/software-center/improve-html, many thanks
    (final bits for LP: #455320), add simple test

  [ Matthew McGowan ]
  * softwarecenter/view/availablepane.py:
    - ensure we have a model before sending changed signal (LP: #560967)
  * softwarecenter/view/dialogs.py:
    - ensure image size does not grow out of proportion (LP: #560021)
  * softwarecenter/view/appview.py:
    - make rows more dynamic (LP: #557798)
  * softwarecenter/view/widgets/pathbar_gtk_atk.py:
    - fix resizing bugs in style-set events

  [ Gary Lasker ]
  * softwarecenter/view/navhistory.py:
    - clear forward navigation history items from the
      stack on an direct navigation, fixes regression
      (LP: #563128)
  * softwarecenter/view/channelpane.py:
    - ensure we have a model before sending app-list-changed
      signal (LP: #560716)
 -- Michael Vogt <email address hidden> Thu, 15 Apr 2010 01:25:12 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers