Software listing inaccessible

Bug #455307 reported by arky on 2009-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Lucid
High
Michael Vogt

Bug Description

1. Launch Orca.
2. If you are using a laptop, open Orca Preferences and set it to "Keyboard Layout" > "Laptop".
3. In Ubuntu Software Center, navigate to "Get Software" > "Universal Access".
4. Arrow down to "Easystroke Gesture Recognition".
5. If on a laptop, press Caps Lock + Enter; otherwise press Enter on the numeric keypad twice.

What you should hear:
4. "Cellwriter. Charmap. Dasher. Easystroke Gesture Recognition."
5. "Easystroke Gesture Recognition. Control your desktop using mouse gestures (2 stars from 3 reviews)."

What you actually hear:
4. "Icon column header. Image. Image. Image. Image."
5. "Table. Apps. Column. Cell. Image. Column 2 of 2 row 4 of 14."

<https://wiki.ubuntu.com/SoftwareCenter#software-list-view>: "In a list view ... The row’s accessible name should be the item’s title, and its accessible description should be the item’s summary."

<https://wiki.ubuntu.com/SoftwareCenter#get-software-list-view>: "In addition, text of the form “ (X stars from Y reviews)” should be present at the end of the item’s accessible description — for example, “An application for managing botanical collections (4 stars from 3 reviews)”."

http://accessibility.freestandards.org/~gk4/a11y/atkguide/atkguide.html#htmlcat_ibmgapguidegtkatk.html__Toc412398981

arky (arky) wrote :
Andrew (and471) on 2009-10-19
Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2009-10-20
Changed in software-center (Ubuntu):
importance: Undecided → High
Matthew Paul Thomas (mpt) wrote :

I thought this might be because the icon was the only element in the first column for each row, and Orca was reading just that first cell when a row was selected. But Orca Preferences has a "Table Rows" option that is set to "Speak row" by default. And *regardless* of that setting, Orca reads both the checkbox and the title+summary for each listed update in Update Manager. So there must be something else that's preventing the title, summary, and buttons from bubbling up to ATK in USC in particular.

description: updated
description: updated
WaywardGeek (waywardgeek) wrote :

This bug is caused by using Webkit, rather than gecko. Webkit is not accessible. Until it is, please be sure to continue writing new applications using gecko. We have been waiting years for webkit to become accessible, and given the total lack of activity on their mailing list about accessibilty, it clearly will be years more.

For Vinux, I am going to switch back to gnome-app-install, even if I have to fix it myself.

Matthew Paul Thomas (mpt) wrote :

(Disregard WaywardGeek's comment. The software list view does not use WebKit at all.)

Matthew Paul Thomas (mpt) wrote :

I just discussed this bug with Willie Walker. ATK is probably being flummoxed by the custom renderer (the text doesn't show up at all in Accerciser, either). He suggests getting around it by setting the cell's accessible name to the title of the item, and accessible description to the summary plus the ratings+reviews stuff in brackets. I'll update the spec for this.

description: updated
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
description: updated
Michael Vogt (mvo) on 2010-04-01
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
Michael Vogt (mvo) wrote :

I commited a fix for this now, in my tests it now reads the rows (name and description) correctly. It also shows up in the on-screen braile monitor. Its still a bit on the slow side, not sure if that is a problem with s-c or orca.

Changed in software-center (Ubuntu Lucid):
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.24

---------------
software-center (1.1.24) lucid; urgency=low

  [ Michael Vogt ]
  * softwarecenter/view/appview.py:
    - make the applist better accessible by providing a text only
      description of the selected item (LP: #455307)
  * data/templates/AppDetailsView.html:
    - make the app details view better accessible with orca/accersier

  [ Gary Lasker ]
  * softwarecenter/app.py,
    softwarecenter/view/softwarepane.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/appdetailsview.py,
    softwarecenter/backend/aptd.py:
    - maintain install/remove button sensitivity based on
      status of individual rows to restore the ability
      to do multiple simultaneous install/removes (LP: #529529)
    - keep all install/remove menu items and buttons in
      sync (LP: #551417)
    - set "Install" button in details view insensitive when
      switching to it from the list view during an install
      (LP: #541844)
    - use correct color for the list view "Install" button
      when it is insensitive (LP: #550915)
  * softwarecenter/view/appdetailsview.py:
    - don't try to execute enable_action_button() if the
      details view page has not yet been loaded (LP: #551419)
 -- Michael Vogt <email address hidden> Thu, 01 Apr 2010 11:22:00 +0200

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers