[GTK3] Don't display a status bar

Bug #445558 reported by Wouter Stomp on 2009-10-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Kiwinote

Bug Description

The only thing the status bar displays is a number of items. I don't think many people care if there are 100 or 200 items available when you are looking for a program to install. Software-center could easily do without the status bar.

<https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=541&rev1=540>

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I will subscribe the design team for input.

Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Matthew Paul Thomas (mpt) wrote :

Thanks for the suggestion. In future, though, the bottom bar will contain other items, including a resize grippy, buttons for adding and modifying software sources, and possibly buttons for switching between icon/list/gallery views. So, we're going to keep it for now.

Changed in software-center (Ubuntu):
status: Confirmed → Invalid

Except for the resize handle it seems a bad idea to me to put all those things in a status bar, a toolbar on top of the window would be more appropriate. Right now it isn't useful so I would suggest removing it for now, it is a minor change to add it back in the future when needed.

Changed in software-center (Ubuntu):
status: Invalid → New
Matthew Paul Thomas (mpt) wrote :

The count text that is currently in the bottom bar often shows the number of matching items for a search. Therefore, it should not be in the opposite direction from the search field as the results are, i.e. it should not be above the field when the results are below the field, so putting it in a toolbar at the top would be inappropriate. One possible alternative was to show the count text in a dedicated bar inside the main pane, immediately below the location bar, but that would have clashed with the position of search scope controls in version 2 (and would have been gratuitously inconsistent with the placement of count text in F-Spot and Nautilus).

A similar consideration applies to the future buttons for adding and modifying software sources; they will operate on the items shown in the navigation pane, and therefore should be below the navigation pane, not above it.

As for removing the bar temporarily, if we moved the count text to a different place in version 1 only to move it back when the bar reappeared in version 2, all that would achieve would be to make us look -- to users of version 2 -- as if we hadn't been planning ahead when we actually were.

My suggestion would be to not show an item count at all; it doesn't serve any purpose.

I also attached a quick mockup of what would be a better location for the results count im my opinion. A button next to the get free software and categories buttons, this seems a more logical location and this allows for easy navigation between the search results and complete category views.

Michael Vogt (mvo) wrote :

I like the idea of having a search results navigation button.

Matthew Paul Thomas (mpt) wrote :

Do you think the item counts in Nautilus and F-Spot serve any purpose either? If so, what's the difference?

Well that is not what is under discussion here, but yes I do think it serves a purpose in those two programs: it is very useful to know how many items you have there because you can do a lot of actions on many files/photos and often the item count will be how many you have selected. E.g. when you are going to print photos it is useful to know how many will be printed.

For installing a program this does not apply, you will always end up at one program which best suits you and it doesn't matter if that comes from a list of 10 or 100.

Anyway I am not completely opposed against displaying the item count, but keeping the status bar only for that seems to be a waste of screenspace to me.

Omer Akram (om26er) wrote :

this bug is a wishlist IMO so marking it as such

Changed in software-center (Ubuntu):
importance: Low → Wishlist
Matthew Paul Thomas (mpt) wrote :

Wouter, I'm sure you'll be delighted to know that we're removing the status bar in the GTK3 UI. :-) Instead we're showing counts at the bottom of the main pane when appropriate.

summary: - Don't display a status bar
+ [GTK3] Don't display a status bar
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Wishlist → Medium
description: updated
Kiwinote (kiwinote) on 2011-08-18
Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.17

---------------
software-center (4.1.17) oneiric; urgency=low

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/gtk3fix:
    - description.py, do not connect to the viewport size-allocate signal,
      i think this should prevent the wierd spazz out when resize evetns
      occur

  [ Michael Vogt ]
  * softwarecenter/utils.py:
    - really remove old gmenusearcher code that uses the static gmenu
      bindings (LP: #828535)
  * softwarecenter/ui/{gtk,gtk3}/gmenusearch.py:
    - split gmenusearch into gtk2 (static bindings) and gtk3 (gi bindings)
    - update usage
  * softwarecenter/db/history_impl/apthistory.py:
    - add conditional use of gio.File() vs Gio.File.new_for_path()
  * softwarecenter/utils.py, softwarecenter/backend/reviews.py:
    - fixes in subtle API changes for Gio vs gio
  * softwarecenter/ui/gtk3/widgets/description.py:
    - prepare for upcomming Gdk pygi changes in 2.90.x
  * debian/control:
    - add python-gmenu back to the dependencies, the dynamic bindings
      can not be used with the gtk2 version os software-center
  * utils/piston-helpers/piston_get_useful_votes_helper.py,
    utils/piston-helpers/piston_get_reviews_helper.py:
    - fix exception type now that json is used (instead of simplejson)
      LP: #828324

  [ Kiwinote ]
  * data/ui/gtk3/css/softwarecenter.css:
    - theme GtkViewports not to have a padding or a border - looks quite nice
      around the banners now
  * many:
    - transition from a status bar to internal status labels (LP: #445558)
  * softwarecenter/ui/gtk3/session/viewmanager.py:
    - show/hide search entry when needed (LP: #828790)
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - use a Gtk.IconSize rather than an int for Gtk.Image.new_from_icon_name
  * softwarecenter/ui/gtk3/widgets/buttons.py:
    - ellipsize category text in tile to avoid warnings
    - show channel selector on button-press-event instead of
      button-release-event for consistent menu behaviour (LP: #828317)

  [ Martin Pitt ]
  * Fix some more places which need to conditionally import gobject or
    GObject. (LP: #829186)
 -- Michael Vogt <email address hidden> Fri, 19 Aug 2011 11:59:02 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments