Ubuntu

software-center crashed with NoSectionError in get()

Reported by Anand Kumria on 2009-10-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-menus (Ubuntu)
Wishlist
Unassigned
software-center (Ubuntu)
Undecided
Unassigned
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: software-center

1)

eve[~]% lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

2)

eve[~]% apt-cache policy software-centre
W: Unable to locate package software-centre
eve[~]% apt-cache policy software-center
software-center:
  Installed: 0.4.4
  Candidate: 0.4.4
  Version table:
 *** 0.4.4 0
        500 http://uk.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

3)

The software centre to launch

4)

A crash dialog appeared.

ProblemType: Crash
Architecture: i386
Date: Sat Oct 3 09:26:37 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.6
Package: software-center 0.4.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=C
 PATH=(custom, no user)
 LANG=C
 SHELL=/usr/bin/zsh
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with NoSectionError in get()
Uname: Linux 2.6.31-11-generic i686
UserGroups: admin audio camera cdrom dialout dip disk fax floppy fuse libvirtd lpadmin netdev plugdev powerdev sambashare scanner tape vboxusers video

Anand Kumria (wildfire) wrote :
tags: removed: need-duplicate-check
Michael Vogt (mvo) on 2009-10-05
Changed in software-center (Ubuntu):
status: New → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 0.4.5

---------------
software-center (0.4.5) karmic; urgency=low

  * softwarecenter/view/appdetailsview.py:
    - avoid blocking if the authentication dialog comes up
      (LP: #436413)
  * softwarecenter/view/appdetailsview.py:
    - switch to use urls that return 404 if a package has no
      screenshot
  * softwarecenter/view/widgets/imagedialog.py,
    softwarecenter/view/appdetailsview.py:
    - merge lp:~mvo/software-center/ubuntu-404 that implements 404
      handling and show ubuntu branded dummy image (LP: #425874)
  * softwarecenter/view/appview.py:
    - support environment to switch sorting for searches:
      SOFTWARE_CENTER_SEARCHES_SORT_MODE={popcon,alphabetic,xapian}
      (to be able to test the different mode quickly)
  * softwarecenter/view/appdetailsview.py:
    - fix crash when no icon can be found (LP: #442040, LP: #440306)
  * softwarecenter/view/catview.py:
    - do not crash if no icon can be found (LP: #441171)
  * data/templates/CategoriesView.html:
    - disable drag-n-drop (LP: #440446)

 -- Michael Vogt <email address hidden> Mon, 05 Oct 2009 18:23:27 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Anand Kumria (wildfire) wrote :

Thans for this fix -- this has got me further. Here the three files which do not have Icons.

eve[/usr/share/desktop-directories]% grep -l "Icon" * | xargs echo
ActionGames.directory ArcadeGames.directory AudioVideo.directory BlocksGames.directory BoardGames.directory CardGames.directory Debian.directory Development.directory Education.directory Game.directory GnomeScience.directory Graphics.directory Hardware.directory InternetAndNetwork.directory KidsGames.directory LogicGames.directory LookAndFeel.directory Network.directory Office.directory Personal.directory RolePlayingGames.directory Settings-System.directory Settings.directory SportsGames.directory System-Tools.directory System.directory Utility-Accessibility.directory Utility.directory X-GNOME-Menu-Applications.directory X-GNOME-Menu-System.directory X-GNOME-Other.directory ggz-games.directory ggz.directory gnome-screensaver.directory gnomecc.directory

eve[/usr/share/desktop-directories]% grep -l "Desktop Entry" * | xargs echo
ActionGames.directory AdventureGames.directory ArcadeGames.directory AudioVideo.directory BlocksGames.directory BoardGames.directory CardGames.directory Debian.directory Development.directory Education.directory Game.directory GnomeScience.directory Graphics.directory Hardware.directory InternetAndNetwork.directory KidsGames.directory LogicGames.directory LookAndFeel.directory Network.directory Office.directory Personal.directory RolePlayingGames.directory Settings-System.directory Settings.directory SimulationGames.directory SportsGames.directory StrategyGames.directory System-Tools.directory System.directory Utility-Accessibility.directory Utility.directory X-GNOME-Menu-Applications.directory X-GNOME-Menu-System.directory X-GNOME-Other.directory ggz-games.directory ggz.directory gnome-screensaver.directory gnomecc.directory

eve[/usr/share/desktop-directories]% cat AdventureGames.directory
[Desktop Entry]
Name=Adventure
Comment=Adventure style games
Type=Directory
X-Ubuntu-Gettext-Domain=gnome-menus

eve[/usr/share/desktop-directories]% cat SimulationGames.directory
[Desktop Entry]
Name=Simulation
Comment=Simulation games
Type=Directory
X-Ubuntu-Gettext-Domain=gnome-menus

eve[/usr/share/desktop-directories]% cat StrategyGames.directory
[Desktop Entry]
Name=Strategy
Comment=Strategy games
Type=Directory
X-Ubuntu-Gettext-Domain=gnome-menus
eve[/usr/share/desktop-directories]%

Anand Kumria (wildfire) wrote :

Hi,

Not all "directory" files in the directory /usr/share/desktop-directories/ have an Icon= line in them.

This was causing software-center to crash (and burn).

The affected files, on my system, were:

AdventureGames.directory, SimulationGames.directory, StrategyGames.directory

which are all part of gnome-menus. It may be useful to put in an Icon= line so that they show with the appropriate icon.

Regards,
Anand

visibility: private → public
Sebastien Bacher (seb128) wrote :

do you have suggestion for icons to use for those?

Changed in gnome-menus (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete

Hi Sebastien,

Adventure: labyrinth?

Strategy: isometric projection of a city (like simcity, wesnoth, etc.)

Simulation: view out of a cockpit?

The icon for Games is two cards and for Logic is it gears, so I think those
would be OK.

Cheers,
Anand

On Wed, Oct 14, 2009 at 9:32 AM, Sebastien Bacher <email address hidden> wrote:

> do you have suggestion for icons to use for those?
>
> ** Changed in: gnome-menus (Ubuntu)
> Importance: Undecided => Wishlist
>
> ** Changed in: gnome-menus (Ubuntu)
> Status: New => Incomplete
>
> --
> software-center crashed with NoSectionError in get()
> https://bugs.launchpad.net/bugs/441171
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

Changed in gnome-menus (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

the question is about actual icon names which are available in themes

Changed in gnome-menus (Ubuntu):
status: New → Incomplete
Anand Kumria (wildfire) wrote :

Adding the ubuntu-artwork team, because they can likely help in driving the creation of these icons (would have been useful if Sebastien had done this but it was a useful learning exercise in finding the right group to add in).

Pedro Villavicencio (pedro) wrote :

Thanks for the report Anand Kumria , It has been a long time without any comment or a duplicate in this bug report and It is possible that the bug has been fixed. May you please try to reproduce it with the latest Stable Release of Ubuntu the Natty Narwhal and add the respective comments to the report? You can learn how to get that release at http://www.ubuntu.com/download . Thanks again and we appreciate your help.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubuntu-artwork → ubuntu-themes (Ubuntu)
Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers