Ubuntu

Package descriptions etc display only in the language of whoever installed the OS

Reported by Michael Vogt on 2009-09-22
128
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
apt (Ubuntu)
High
mokbel
software-center (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: software-store

if the cache was geneated with a english locale and then is used by a user with german locale, the cache will be english only. this needs to be fixed by storting a language attribute in the cache and forcing a re-generation (or a generation of a new one) if they don't match.

Michael Vogt (mvo) on 2009-09-22
Changed in software-store (Ubuntu):
status: New → Triaged
importance: Undecided → High
Matthew Paul Thomas (mpt) wrote :

Would it make sense to keep separate caches for each language that is used? That way if a machine is frequently used by two or more administrators that use different languages, they won't constantly be waiting for regeneration of the cache that was generated by the other.

(I guess if the other administrator actually installed or removed anything, the cache in your language would still need regenerating, but at least it would save having to regenerate it if they just browsed.)

Olivier Tilloy (osomon) wrote :

I'm taking a go at the solution proposed by mpt.

Changed in software-center (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: Triaged → In Progress
Pavel Verba (pavel.s.verba) wrote :

I also run into this after installing system and after changing system locales.

Matthew Paul Thomas (mpt) wrote :

This bug and bug 121878 seem to be the same.

Changed in ddtp-ubuntu:
status: New → Confirmed
Changed in ubuntu-translations:
status: New → Confirmed
tags: added: i18n

I know it is only a cosmetic bug, but it annoys me. It would be great if Ubuntu Software Center respected locale settings...

Is there any real progress on fixing this bug? :)

I found that running the following command fixed the problem:

sudo /usr/share/software-center/update-software-center

Filip Nohe (filipnohe) wrote :

Thanks Darius, that worked for me :)

Hendrik Knackstedt (hennekn) wrote :

This bug has been around now for a very long time and there hasn't been any activity on this in the recent past so I'd like to get your attention on this issue again.

It's very confusing to new users who might NOT know how to display the translated package descriptions and it also destroys all the effort the translation teams put into translating package descriptions.

Please fix this bug asap. It would be really nice to actually be able to see translated package descriptions on a fresh install of Ubuntu, at least in Oneiric.

Changed in ubuntu-translations:
status: Confirmed → Invalid
Changed in ddtp-ubuntu:
status: Confirmed → Invalid
tags: added: software-center
Hendrik Knackstedt (hennekn) wrote :

By the way: The workaround above doesn't work in Natty anymore. I tried on two fresh installs and even after running the command I don't see the translated package descriptions although translations exist. The short descriptions appear translated though. Maybe a different bug?

Kyle Nitzsche (knitzsche) wrote :

I tried this workaround also on natty and it did not fix the problem.

Note that this bug 777990 may be a dup of this one.

summary: - needs to store the language of the cache
+ Software Center needs to store the language of the cache
Changed in ubuntu-translations:
status: Invalid → New
Changed in ddtp-ubuntu:
status: Invalid → Confirmed
status: Confirmed → New

Hi, the original bug discussed here is about systems with multiple user who use multiple languages. This is currently not supported.

On a fresh install in e.g. german or chinese all apps that have translations should be supported of course. Having multiple database will not help with that problem, that is a different issue.

I did a fresh install with ubiquity of natty now to test the problem.

= Fresh install without network =
 * all apps are translated (everything from app-install-data-ubuntu)
 * no translated package descriptions (no Translations-$lang files in /var/lib/apt/lists)
 * no universe package lists (but s-c will offer to download them)

= Fresh install with network =
 * all apps are translated
 * translated package descriptions are available in /var/lib/apt/lists
 * translated packages descriptions are *not* displayed until the first "apt-get update" *or* "rm -f /var/cache/apt/*.bin" (the binary package cache is generated/copied with LANG=C for some reason?) - this appears to be a more general problem with apt/the way we install, I investigate further

Michael Vogt (mvo) wrote :

It turns out that the problem with the missing translations in the apt cache is actually triggered by aptdaemon. It gets loaded on demand by dbus activation but its not getting any language environment from there. It rebuilds the apt cache but without language information this will lead to a english language only cache.

Michael Vogt (mvo) wrote :

I filed bug #794907 about this problem now as its a seperate issue from this bugreport here.

David Planella (dpm) on 2011-06-09
Changed in ubuntu-translations:
importance: Undecided → High
status: New → Triaged
Gary Lasker (gary-lasker) wrote :

Per Michael's comment #13, I've moved the duplicates that correspond to the separate issue to the new bug 794907.

Matthew Paul Thomas (mpt) wrote :

Olivier, are you still interested in working on this?

summary: - Software Center needs to store the language of the cache
+ Package descriptions etc display only in the language of whoever
+ installed the OS

mpt, I’d be interested for sure, but I don’t realistically have enough spare time to commit to fixing/implementing it in a timely manner. If anyone feels like giving it a shot, be my guest.

I’ll keep it on my radar though and if I happen to have spare cycles in the near future I’ll ping you/Michael/Gary.

Matthew Paul Thomas (mpt) wrote :

Ok, thanks Olivier.

Changed in software-center (Ubuntu):
assignee: Olivier Tilloy (osomon) → nobody
status: In Progress → Triaged
Kiwinote (kiwinote) on 2011-09-27
tags: added: db
Siarhei Novik (snovik) wrote :

I never changed locale but changed regional settings. And I also have the same problem. The problem also applies to Update manager and even authorization windows once in a while pulls out a message in the regional settings language rather than GUI language

Michael Vogt (mvo) wrote :

Some thoughts about this:
- we could do build a language specific db only o demand, this would require a aptdaemon call to do that
- we could build multple dbs for each langauge at install time of app-install-data-ubuntu
- we would need to add a dpkg trigger somehow to add/remove DBs when languages gets added/removed

Matthew Paul Thomas (mpt) wrote :

For building the language-specific DB on demand, I've sketched a progress window. <https://wiki.ubuntu.com/SoftwareCenter#Launching> I'm not sure of this presentation, though. Embedding the progress display in the USC window (basically replacing the usual launch spinner with a determinate progress bar) would be more elegant, because it would involve fewer windows. But it might lead people to be more frustrated with USC itself.

In any case, generating the DB on launch would be the last resort, used only if the app-install-data-ubuntu and language pack triggers haven't already produced a database in your current language.

Dave Morley (davmor2) on 2012-04-17
tags: added: ca-escalate
tags: added: ca-escalated
removed: ca-escalate
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ddtp-ubuntu → ubuntu
Changed in ubuntu:
status: New → Confirmed
David Pitkin (dpitkin) on 2012-05-21
tags: removed: ca-escalated
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-translations:
status: Triaged → Fix Committed
Changed in ubuntu-translations:
status: Fix Committed → Triaged
Changed in software-center (Ubuntu):
status: Fix Committed → Triaged
Michael Vogt (mvo) wrote :

I sketched out how this could work in lp:~mvo/software-center/build-i18n-for-all

If there are multiple languages supported s-c buids a xapian index for each of them (that takes some time of course).
That works with the branch and if you run:
$ rm -rf ./data/xapian
$ PYTHONPATH=. utils/update-software-center --local
$ ./software-center

it will build multiple databases, e.g. for me:
$ ls data/xapian
ca de en es fr he hu it pt ru

What is missing is:
- cleanup when languages get removed
- ensuring that there is always a default fallback DB
- ensure to not rebuild if there are no changes in the app-install-data
- robustness

But the biggest problem is that the package descriptions are only availalbe in the system default language. That is a problem
with "apt" and not software-center. It download only that. I add a apt task to allow it having a option to download all supported
languages.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2012-07-03
affects: ubuntu → apt (Ubuntu)
Changed in apt (Ubuntu):
status: New → Triaged
importance: Undecided → High
Michael Vogt (mvo) wrote :

apt already supports this, we just need to set the environment or apt.conf correctly.

E.g.
$ LANGUAGES=de:fr:en apt-get update
will work.

skspy (493g-almc5-d18p) on 2012-09-08
Changed in software-center (Ubuntu):
assignee: nobody → skspy (493g-almc5-d18p)
Changed in apt (Ubuntu):
assignee: nobody → skspy (493g-almc5-d18p)
Changed in ubuntu-translations:
assignee: nobody → skspy (493g-almc5-d18p)
rduke15 (rduke15) wrote :

I had this problem in 12.04 LTS Precise.

System installed in English, but later played with locale and/or GUI regional settings. After a while, I reverted everything to English, but software-center still used French for the short descriptions of packages (and English for the full descriptions).

I deleted "/var/cache/software-center/" and "/var/cache/apt-xapian-index/", which made software-center crash.

Running

    sudo apt-get --reinstall install software-center

fixed it, and everything is in the correct language.

yanglifu90 (yanglifu90) wrote :

It is reported in 2009 September?!! Anyway Daily Build fix this for now. How'd this bug all of a sudden revealed?

Changed in ubuntu-translations:
status: Triaged → Fix Committed
Changed in apt (Ubuntu):
status: Triaged → Fix Committed
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-translations:
status: Fix Committed → Fix Released
Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Matthew Paul Thomas (mpt) wrote :

skspy, please don't assign a bug to yourself unless you plan to work on it. And sakis giochalas, please don't mark a bug as fixed when it isn't.

Changed in ubuntu-translations:
status: Fix Released → Confirmed
Changed in apt (Ubuntu):
status: Fix Released → Confirmed
Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Changed in apt (Ubuntu):
assignee: skspy (493g-almc5-d18p) → nobody
Changed in ubuntu-translations:
assignee: skspy (493g-almc5-d18p) → nobody
Changed in software-center (Ubuntu):
assignee: skspy (493g-almc5-d18p) → nobody
Changed in ubuntu-translations:
status: Confirmed → Fix Committed
Changed in apt (Ubuntu):
status: Confirmed → Fix Committed
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-translations:
status: Fix Committed → Confirmed
Changed in apt (Ubuntu):
status: Fix Committed → Confirmed
Changed in software-center (Ubuntu):
status: Fix Committed → Confirmed
Changed in ubuntu-translations:
status: Confirmed → In Progress
assignee: nobody → Hongsheng Cao (caohongsheng)
Changed in apt (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → Hongsheng Cao (caohongsheng)
Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → Hongsheng Cao (caohongsheng)
Hendrik Knackstedt (hennekn) wrote :

Changing back to confirmed since I don't see any reason why this should have been changed to incomplete. Seems to be spam.

Changed in apt (Ubuntu):
status: Incomplete → Confirmed
Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Changed in apt (Ubuntu):
assignee: Hongsheng Cao (caohongsheng) → nobody
Changed in software-center (Ubuntu):
assignee: Hongsheng Cao (caohongsheng) → nobody
Changed in ubuntu-translations:
assignee: Hongsheng Cao (caohongsheng) → nobody
status: In Progress → Confirmed
summary: - Package descriptions etc display only in the language of whoever
- installed the OS
+ USC/apt: Package descriptions etc display only in the installation
+ language
summary: - USC/apt: Package descriptions etc display only in the installation
- language
+ Package descriptions etc display only in the language of whoever
+ installed the OS
mokbel (mrmokbel) on 2014-02-01
Changed in apt (Ubuntu):
assignee: nobody → mokbel (mrmokbel)
Mélodie (meets) wrote :

Hi,

I just met with the same issue in an Ubuntu custom built on top of Ubuntu LTS : Edition Precise, 12.04.4. (an LTS perfectly up to date). I was about to make a screen shot when I met with the bug. Here is a pic:
http://meets.free.fr/images/USC-en-fr.png

I will add an attachement to present the environment variables and the locales. Then there is also:
$ echo $LANG
en_US.UTF-8
$

It would be nice if two languages or more can be installed in the system without USC confusing which language to pick when displaying descriptions.

Thanks for trying to fix it!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers