Main pane and its scrollbar produce doubled border

Bug #433917 reported by David Prieto on 2009-09-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu Software Center 1.0, Ubuntu 9.10
Ubuntu Software Center 2.1.19, Ubuntu Maverick

The main pane's scrollbar is inside it, and they have separate borders, which are inelegant when they touch.

One way to avoid the effect of the doubled border would be to place the scrollbar next to the pane instead of inside, as Transmission and Banshee do.

A more space-efficient way would be to eliminate the extra border itself.

[Originally reported in <http://ubuntuforums.org/showpost.php?p=7978219&postcount=59>]

Michael Vogt (mvo) on 2009-09-21
Changed in software-store (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Matthew Paul Thomas (mpt) wrote :

David, please do continue to report visual problems as bugs, but please report the actual problems, not assumed solutions. Most problems have more than one possible solution, and reporting assumed solutions leads to confusion and more duplicates.

description: updated
summary: - Put the scrollbar next to the pane, not inside.
+ Main pane and its scrollbar produce doubled border

You're totally right Matt, I will try to do that in the future.

Anyway in response to your comment in the forum, I was observing other gnome apps today and I noticed a lot of them use this method:

-Transmission
-Tomboy
-Banshee
-Empathy
-Totem
-Gedit
-F-spot
-Klavaro
-Baobab

The list goes on... actually, I think pretty much every gnome app I can think of (some don't e.g. nautilus) follows this method. There must be a reason for that, surely.

Matthew Paul Thomas (mpt) wrote :

Other exceptions include Epiphany, Geany, and Gnome Terminal.

The reason so many applications add space on both sides of the scrollbar is partly that there is a low standard for elegance across Gnome (though not just Gnome), so developers don't care about the extra weight and space consumed. But it's also partly that the rounded corners of scrollbar buttons in Clearlooks (and, to a lesser extent, in Human) subtly discourage developers from putting scrollbars inside things with square corners. But putting something with a rounded corner right next to something with a square corner still looks bad even when they have space between them, and so does putting a button with a rounded corner right next to the edge of the screen when the window is minimized (e.g. bug 16045, one of the first Ubuntu bugs I ever reported). So I think the right solution here is to fix the themes to give scrollbar buttons square corners, and to fix the apps to stop wasting so much space.

Matthew Paul Thomas (mpt) wrote :

(I meant "maximized", obviously, not "minimized".)

Matthew McGowan (mmcg069) wrote :

Is this now fixed in software-center?

Matthew Paul Thomas (mpt) wrote :

No, it's still a problem in 2.1.19 -- tested in Ambiance, Radiance, Clearlooks, Elementary, and Human. It seems to be slightly worse now, because the gap makes visible an odd border to the left of the up arrow button. This screenshot is from Ambiance.

description: updated
Matthew Paul Thomas (mpt) wrote :

(The odd horizontal border is now reported as bug 638852.)

Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. As you may be aware, the upcoming release of Ubuntu 11.10 will feature a redesigned software-center. The bug you describe is no longer present in recent development versions of software-center, so I'll close this bug report. Please continue to report any bugs you may find. Thanks again for your help!

(With overlay-scrollbars this isn't an issue - without them the scrollbar is now completely against the window edge)

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers