Use an icon in the location bar

Bug #433838 reported by David Prieto on 2009-09-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Matthew Paul Thomas

Bug Description

Binary package hint: software-store

Previous versions of the Store used to show a "home" icon in the first button of the location bar, but now that icon has been replaced with text ("get free software" and "installed software" respectively). I like the fact that we can now discern in which section we are, but the text just takes too much space.

I think a better approach would be to use the icon for that specific section (that is, the icon for ("get free software" or "installed software"). Please see the attached mockup.

István Nyitrai (sianis) wrote :

This will be fixed by a new location bar. It is under development. So I think this bug is Invalid.

István Nyitrai (sianis) on 2009-09-21
Changed in software-store (Ubuntu):
status: New → Invalid
Matthew Paul Thomas (mpt) wrote :

This suggestion is not invalid. The new path button code is about changing the outside appearance and connection of the elements, not about changing the actual contents of the elements. It would be just as reasonable to use an icon for the first element in the new path button as it would be with the current code.

I like the idea of using an icon for the first element, because while it would still be redundant with the icon in the navigation pane, repeating one icon would be less redundant than repeating ~20 characters of text.

However, to do this we would need to be confident that the increase in elegance outweighs any decrease in elegance and in obviousness.

I see two potential reductions in elegance:

1. The size of the icon relative to the button. In the current mockup the top and bottom edges of the icon are scraping the edges of the button. Either the icon needs to be smaller, or the button needs to be taller. Probably the former, because the icons look a bit cramped in the navigation pane, too.

2. The small appearance of the button as a whole on the top-level "Get Free Software" and "Installed Software" screens.

Measuring any decrease in obviousness would require user testing, and I hope to do that early next cycle. But for now, I suggest tweaking the mockup to address the spacing issue, and expanding it so that it shows what the whole location bar (including search field) would look like at the top-level screens as well as on a department or application screen. Thanks!

Changed in software-store (Ubuntu):
status: Invalid → New
István Nyitrai (sianis) on 2009-09-21
Changed in software-store (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → István Nyitrai (sianis)
István Nyitrai (sianis) wrote :

Trivial patch

Andrew (and471) wrote :

Do we want this patch applied Matthew?

Changed in software-store (Ubuntu):
assignee: István Nyitrai (sianis) → Matthew Paul Thomas (mpt)
Matthew Paul Thomas (mpt) wrote :

As I said, "Measuring any decrease in obviousness would require user testing, and I hope to do that early next cycle." Thanks for preparing the patch for us to test.

Matthew Paul Thomas (mpt) wrote :

Now, individual software sources have path buttons where the first element is the name of the source (e.g. "Emerillon PPA") vs. the aggregate "Get Software".

That makes it a bit less likely that using only an icon for "Get Software" is a good idea. If we were use only an icon there, for consistency probably we should use only an icon for individual sources too. But it would be less helpful in the latter case, since (for example) all PPAs have the same icon.

Changed in software-center (Ubuntu):
status: In Progress → New
Philip Muškovac (yofel) on 2010-04-14
tags: added: patch
Matthew Paul Thomas (mpt) wrote :

I am marking this as patch-needsdesign to get the patch out of the glare of the Patch Reviewers Team until we finalize a design for this issue.

It doesn't have to be me who does the design work here. Basically someone needs to work out how, if at all, it would be possible to distinguish the first segment of the pathbutton in all screens that use the pathbutton if that first segment is only an icon. Draw up some sketches of the various possibilities.

tags: added: patch-needsdesign
removed: patch
Michael Vogt (mvo) on 2010-09-20
Changed in software-center (Ubuntu):
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

Fixed in USC5 by replacing the location bar with a navigation bar. The navigation bar does use icons for "All Software" and "Installed", and will eventually use icons for individual software sources too.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments