[UIF exception] apt:package-name isn't handled by the Store when appropriate

Bug #426215 reported by Matthew Paul Thomas on 2009-09-08
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Wishlist
Unassigned
software-center (Ubuntu)
Wishlist
Kiwinote

Bug Description

User Interface Freeze Exception Justification:
What this does: apt: URIs will open with Software Center instead of with apturl. This is part of the Software Center specifications.

I have tested this change and it works.

Benefits of this change: When installing software from an apt link, users will be able to see a screenshot, ratings and reviews (file size, version number, etc.) as opposed to only seeing a small installer window with the software description. Ubuntu Software Center is a much better looking and more useful interface than the simple apturl window.

Caveat: This still won't affect apt: URIs typed into Firefox (LP: #634915) as ubufox calls apturl directly. This will however benefit apt: links in yelp.

https://lists.ubuntu.com/archives/ubuntu-doc/2011-April/015534.html
https://lists.ubuntu.com/archives/ubuntu-translators/2011-April/004623.html
---
software-store 0.2.2, Ubuntu Karmic; Ubuntu Software Center 1.1.12, Ubuntu Lucid

1. Copy and paste "apt:abiword" (without quotes) into Firefox's address field. (If you already have AbiWord installed, substitute the name of a package that isn't installed.)
2. Press Enter.
3. Choose "OK".

What happens:
2. An "Install additional software?" alert appears, asking "Do you want to install package 'abiword'?".

What should happen:
2. From <https://wiki.ubuntu.com/SoftwareCenter#apturl>: "Opening an apt: URL should launch the Ubuntu Software Center directly to the appropriate screen; or if it is already open, focus it, wait until any currently-open alerts or dialogs have been dismissed, and then switch to the appropriate screen."

Michael Vogt (mvo) on 2009-09-09
affects: gdebi (Ubuntu) → apturl (Ubuntu)
Michael Vogt (mvo) on 2009-09-10
Changed in software-store (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
description: updated
Changed in software-center (Ubuntu):
importance: Medium → Wishlist
Changed in apturl (Ubuntu):
importance: Undecided → Wishlist
description: updated
Kiwinote (kiwinote) on 2010-07-19
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Kiwinote (kiwinote)
Rory McCann (rorymcc) wrote :

I recently had a problem which could have been solved if there was some way to 'link' to ubuntu software screens.

I had to walk someone through searching on the Ubuntu Software Centre (https://lists.ubuntu.com/archives/ubuntu-ie/2010-August/000749.html). If I could have said "Click this link xxxxxxxxxx." then it would have been much easier to help this person.

Kiwinote (kiwinote) on 2010-08-12
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

It would be very nice if apturl could open the Software Center instead of the little installer it does now. The little installer does not have a screenshot or reviews or any of the other details (file size, version number, etc.). Since this is different from the specification and results in the user being quite a bit more blind as to what the installation will do, I think this should be a higher priority than just Wishlist.

Changed in apturl (Ubuntu):
status: New → Confirmed
Aaron Peachey (aaronp) wrote :

Hi Jeremy,
This bug is marked as wishlist but the good news is a fix was released on 12 August 2010, as per the update from Kiwinote above. I just tested this in the latest version (in Natty) by typing 'apt:abiword' in the Firefox address bar and Software Centre opened with AbiWord read to install. I believe you will need Software Centre from Maverick or Natty to experience this fix though - are you running an earlier version of Ubuntu?

Jeremy Bicha (jbicha) wrote :

Aaron, I just tested on a Natty live CD and apt:abiword opens in a small installer window, not in Software Center like it should. The bug is not that software cannot be installed with apt: shortcuts but that it doesn't happen in Software Center.

If apturl is uninstalled, apturl apt:abiword still works from the command line (but not in Firefox) and opens in Software Center so it is correct that SC has this feature working but apturl does not.

Kiwinote (kiwinote) wrote :

Hi! In natty apturls are dealt with slightly differently to maverick. I *think* what remains to happen here is to set s-c as the default apturl handler by appending "x-scheme-handler/apt=ubuntu-software-center.desktop" to the defaults.list in the desktop-file-utils package.

Jeremy Bicha (jbicha) on 2011-04-10
description: updated
summary: - apt:package-name isn't handled by the Store when appropriate
+ [UIF exception] apt:package-name isn't handled by the Store when
+ appropriate
Jeremy Bicha (jbicha) wrote :

I have proposed a branch that fixes this bug. Thanks Kiwinote for the tip!

description: updated
Jim Campbell (jwcampbell) wrote :

This works fine from within yelp in natty (apt urls open the Software Center, presenting the user with information about the appropriate application), but within firefox, the apt:[app name] feature doesn't seem to work correctly.

Per the attached screenshot, it just opens up a window asking which application should open the URI. If I select "Choose," it gives me a file-selector window. This assumes that I'll know where to go to have this open in the Software Center.

dpkg -l apturl
||/ Name Version Description
+++-==============-==============-====================
ii apturl 0.4.2ubuntu5 install packages using the apt protocol

dpkg -l ubufox
+++-==============-=============================
ii ubufox 0.9-0ubuntu1 transitional dummy package

Jim Campbell (jwcampbell) wrote :

Image of an apt-url from Firefox.

Jeremy Bicha (jbicha) on 2011-04-10
Changed in apturl (Ubuntu):
status: Confirmed → New
Jeremy Bicha (jbicha) wrote :

Jim, I don't know why the apt: urls works for you because they do not from a Natty live CD. And this is important because we're writing the Ubuntu Help to assume that Software Center will open apt: links.

Firefox integration is a separate issue (LP: #634915).

Jeremy Bicha (jbicha) wrote :

I'm still looking for someone to sponsor this as it would make the Ubuntu documentation better.

Ill help!
On Apr 19, 2011 10:56 AM, "Jeremy Bicha" <email address hidden> wrote:
> I'm still looking for someone to sponsor this as it would make the
> Ubuntu documentation better.
>
> --
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a direct subscriber.
> https://bugs.launchpad.net/bugs/426215
>
> Title:
> [UIF exception] apt:package-name isn't handled by the Store when
> appropriate
>
> Status in “apturl” package in Ubuntu:
> New
> Status in “software-center” package in Ubuntu:
> Fix Released
>
> Bug description:
> User Interface Freeze Exception Justification:
> What this does: apt: URIs will open with Software Center instead of with
apturl. This is part of the Software Center specifications.
>
> I have tested this change and it works.
>
> Benefits of this change: When installing software from an apt link,
> users will be able to see a screenshot, ratings and reviews (file
> size, version number, etc.) as opposed to only seeing a small
> installer window with the software description. Ubuntu Software Center
> is a much better looking and more useful interface than the simple
> apturl window.
>
> Caveat: This still won't affect apt: URIs typed into Firefox (LP:
> #634915) as ubufox calls apturl directly. This will however benefit
> apt: links in yelp.
>
> https://lists.ubuntu.com/archives/ubuntu-doc/2011-April/015534.html
>
https://lists.ubuntu.com/archives/ubuntu-translators/2011-April/004623.html
> ---
> software-store 0.2.2, Ubuntu Karmic; Ubuntu Software Center 1.1.12, Ubuntu
Lucid
>
> 1. Copy and paste "apt:abiword" (without quotes) into Firefox's address
field. (If you already have AbiWord installed, substitute the name of a
package that isn't installed.)
> 2. Press Enter.
> 3. Choose "OK".
>
> What happens:
> 2. An "Install additional software?" alert appears, asking "Do you want to
install package 'abiword'?".
>
> What should happen:
> 2. From <https://wiki.ubuntu.com/SoftwareCenter#apturl>: "Opening an apt:
URL should launch the Ubuntu Software Center directly to the appropriate
screen; or if it is already open, focus it, wait until any currently-open
alerts or dialogs have been dismissed, and then switch to the appropriate
screen."

Michael Vogt (mvo) wrote :

Uploaded the desktop-file-utils change now to natty.

affects: apturl (Ubuntu) → desktop-file-utils (Ubuntu)
Changed in desktop-file-utils (Ubuntu):
status: New → Fix Committed
Scott Kitterman (kitterman) wrote :

Will this change affect systems that do not have Software Center installed?

Jeremy Bicha (jbicha) wrote :

Scott, what systems do you mean? ubuntu-desktop & xubuntu-desktop depend on desktop-file-utils and software-center. kubuntu-desktop does not. I've contacted the Lubuntu community as this may affect them.

Any third-party derivatives ought to pay attention to the desktop-file-utils package for changes to defaults like this one.

Scott Kitterman (kitterman) wrote :

I think it's reasonable to check with them. I agree it's unlikely to affect
Kubuntu.

Piggy Blotch (wise-1) wrote :

Would you like me to contact the xubuntu team???
On Apr 21, 2011 9:36 AM, "Jeremy Bicha" <email address hidden> wrote:
> Scott, what systems do you mean? ubuntu-desktop & xubuntu-desktop depend
> on desktop-file-utils and software-center. kubuntu-desktop does not.
> I've contacted the Lubuntu community as this may affect them.
>
> Any third-party derivatives ought to pay attention to the desktop-file-
> utils package for changes to defaults like this one.
>
> --
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a direct subscriber.
> https://bugs.launchpad.net/bugs/426215
>
> Title:
> [UIF exception] apt:package-name isn't handled by the Store when
> appropriate
>
> Status in “desktop-file-utils” package in Ubuntu:
> Fix Committed
> Status in “software-center” package in Ubuntu:
> Fix Released
>
> Bug description:
> User Interface Freeze Exception Justification:
> What this does: apt: URIs will open with Software Center instead of with
apturl. This is part of the Software Center specifications.
>
> I have tested this change and it works.
>
> Benefits of this change: When installing software from an apt link,
> users will be able to see a screenshot, ratings and reviews (file
> size, version number, etc.) as opposed to only seeing a small
> installer window with the software description. Ubuntu Software Center
> is a much better looking and more useful interface than the simple
> apturl window.
>
> Caveat: This still won't affect apt: URIs typed into Firefox (LP:
> #634915) as ubufox calls apturl directly. This will however benefit
> apt: links in yelp.
>
> https://lists.ubuntu.com/archives/ubuntu-doc/2011-April/015534.html
>
https://lists.ubuntu.com/archives/ubuntu-translators/2011-April/004623.html
> ---
> software-store 0.2.2, Ubuntu Karmic; Ubuntu Software Center 1.1.12, Ubuntu
Lucid
>
> 1. Copy and paste "apt:abiword" (without quotes) into Firefox's address
field. (If you already have AbiWord installed, substitute the name of a
package that isn't installed.)
> 2. Press Enter.
> 3. Choose "OK".
>
> What happens:
> 2. An "Install additional software?" alert appears, asking "Do you want to
install package 'abiword'?".
>
> What should happen:
> 2. From <https://wiki.ubuntu.com/SoftwareCenter#apturl>: "Opening an apt:
URL should launch the Ubuntu Software Center directly to the appropriate
screen; or if it is already open, focus it, wait until any currently-open
alerts or dialogs have been dismissed, and then switch to the appropriate
screen."

Jeremy Bicha (jbicha) wrote :

Piggy, thanks for the offer. Since Xubuntu ships both software-center and desktop-file-utils, I don't think any action is needed on Xubuntu's part.

Piggy Blotch (wise-1) wrote :

Oh ok what about zorin ostensibly or the other derivatives at
https://wiki.ubuntu.com/DerivativeTeam/Derivatives
On Apr 21, 2011 6:06 PM, "Jeremy Bicha" <email address hidden> wrote:
> Piggy, thanks for the offer. Since Xubuntu ships both software-center
> and desktop-file-utils, I don't think any action is needed on Xubuntu's
> part.
>
> --
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a direct subscriber.
> https://bugs.launchpad.net/bugs/426215
>
> Title:
> [UIF exception] apt:package-name isn't handled by the Store when
> appropriate
>
> Status in “desktop-file-utils” package in Ubuntu:
> Fix Committed
> Status in “software-center” package in Ubuntu:
> Fix Released
>
> Bug description:
> User Interface Freeze Exception Justification:
> What this does: apt: URIs will open with Software Center instead of with
apturl. This is part of the Software Center specifications.
>
> I have tested this change and it works.
>
> Benefits of this change: When installing software from an apt link,
> users will be able to see a screenshot, ratings and reviews (file
> size, version number, etc.) as opposed to only seeing a small
> installer window with the software description. Ubuntu Software Center
> is a much better looking and more useful interface than the simple
> apturl window.
>
> Caveat: This still won't affect apt: URIs typed into Firefox (LP:
> #634915) as ubufox calls apturl directly. This will however benefit
> apt: links in yelp.
>
> https://lists.ubuntu.com/archives/ubuntu-doc/2011-April/015534.html
>
https://lists.ubuntu.com/archives/ubuntu-translators/2011-April/004623.html
> ---
> software-store 0.2.2, Ubuntu Karmic; Ubuntu Software Center 1.1.12, Ubuntu
Lucid
>
> 1. Copy and paste "apt:abiword" (without quotes) into Firefox's address
field. (If you already have AbiWord installed, substitute the name of a
package that isn't installed.)
> 2. Press Enter.
> 3. Choose "OK".
>
> What happens:
> 2. An "Install additional software?" alert appears, asking "Do you want to
install package 'abiword'?".
>
> What should happen:
> 2. From <https://wiki.ubuntu.com/SoftwareCenter#apturl>: "Opening an apt:
URL should launch the Ubuntu Software Center directly to the appropriate
screen; or if it is already open, focus it, wait until any currently-open
alerts or dialogs have been dismissed, and then switch to the appropriate
screen."

Marc Deslauriers (mdeslaur) wrote :

Nothing left to do. Unsubscribing ubuntu-sponsors.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.18-0ubuntu4

---------------
desktop-file-utils (0.18-0ubuntu4) natty; urgency=low

  * Set Software Center as the default handler for apt URI's
    (LP: #426215)
 -- Jeremy Bicha <email address hidden> Sun, 21 Apr 2011 12:02:27 -0400

Changed in desktop-file-utils (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments