Ubuntu

Installed apps: "where-to" and open button

Reported by David Prieto on 2009-08-28
82
This bug affects 12 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-store

It would be really handy for software-store to indicate where installed programs can be found (apps → images → cheese) as well as an "open" button.

I am attaching a mockup.

Yotam Benshalom (benshalom) wrote :

This is a very good idea.

Michael Vogt (mvo) wrote :

I subscribed Matthew to have a look

Changed in software-store (Ubuntu):
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

David, I had already specified a "Where is it?" button, though this won't be implemented for 1.0. <https://wiki.ubuntu.com/SoftwareStore#%E2%80%9CWhere%20Is%20It?%E2%80%9D%20button> Does that design look good to you?

I think it's important that people aren't misled into thinking that the Store is an application launcher (because it would be horribly slow at that task), so we shouldn't offer an "Open" button, but just show people how to launch the program themselves.

When text in an interface refers directly to other items in the interface, the design can usually be improved. Here we can show rather than tell; instead of naming the menu, submenu, and menu item, we can open the actual menus and point to the actual items.

Vish (vish) wrote :

David , the idea is good , but a more suitable label would be "Launch"

Mpt , the "Where is it?" button and its specs of having a secondary pointer show the way , though a nice idea , is an unnecessary complication of the whole process.

- the idea of a second pointer popping up in the system sounds kinda creepy [IMO] and seems like something is overriding the system...
- I think we are under-estimating the capacity of the users to locate the app and trying to spoon feed them too much :(

The solution can be done either :
After install , either:
1> only show the present idea ,of the pointer showing the directions, within the SS window as modal window, ie: user clicks the "Where is it" button and the modal window appears within the SS showing a gnome menu and the view follows the pointer to the location of the app. [almost like a screencast ]

2> once the view changes to the installed app , pop-up a dialogue which says where the app is installed and an option to launch the app from the window
- the "Where is it" button , will show the Applications > ... > .... and the "Launch" option only on the first try... on the second time onwards the launch option is not shown and instead the text alone is shown.

I also like the idea , you mentioned on the irc,of drawing rings around menu,submenu and waiting for the user to open the app.
But this is a little similar to the Windows method...

Vish (vish) wrote :

correction *

The solution can be done either :
1> only show the present idea ,of the pointer showing the directions, within the SS window as modal window, ie: user clicks the "Where is it" button and the modal window appears within the SS showing a gnome menu and the view follows the pointer to the location of the app. [almost like a screencast ]

2> After install , once the view changes to the installed app , pop-up a dialogue which says where the app is installed and an option to launch the app from the window
- the "Where is it" button , will show the Applications > ... > .... and the "Launch" option only on the first try... on the second time onwards the launch option is not shown and instead the text alone is shown.

Changed in software-store (Ubuntu):
status: Incomplete → Confirmed

"David, I had already specified a "Where is it?" button"

I'm not sure Matt... it all seems tremendously over the top to me. I mean, having a fake pointer appear and open your menus for you? I really don't know, it really seems too much to me.

Considering that the "installed to" approach shown in the mockup is simpler, what advantages does your method offer?

"we shouldn't offer an "Open" button, but just show people how to launch the program themselves."

Yes, that makes sense when you think about it.

Matthew Paul Thomas (mpt) wrote :

You're thinking like a programmer. :-) To a user, showing them something is *much* simpler than telling them. Yes, it's harder to implement, but better interfaces usually are.

mac_v has a good point that a second pointer could seem creepy, so on IRC I suggested an alternative approach: animatedly drawing a ring around the relevant menu, waiting for you to open it, drawing a ring around the relevant submenu, waiting for you to open that, and then drawing a ring around the application itself.

Eikka (jeti) wrote :

For an absolute beginner, holding their hand and waiting them to move the cursor to open the menus one by one would seem nice, but it will start to annoy you after the third program you've installed, and it will seem like the system thinks you're dumb.

Instead, just open the menu tree and flash a big red "here it is" circle around the application icon for a few seconds, or until the user moves the cursor over the circle.

Matthew Paul Thomas (mpt) wrote :

Ok, spec updated to use rings instead of a dummy pointer. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=216&rev1=215>

Michael Vogt (mvo) on 2009-10-26
Changed in software-center (Ubuntu):
importance: Undecided → Wishlist
RomanIvanov (ivanov-jr) wrote :

the idea behind this issue is really reasonable. Finding a location of installed software is real quest some time.

At least button "Launch/open" will be easy to add(I hope) and extremely useful - as there is one reason to install application is to Launch/Run/Open it.

But location even in text form will be really helpful.

Vish (vish) wrote :

Changing priority since the "where-is-it" is part of the specs

Changed in software-center (Ubuntu):
importance: Wishlist → Low
status: Confirmed → Triaged

A "Where is it?" widget has been added to 3.0, fixing this bug.

Changed in software-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments