ubuntu-desktop is removed while applying security upgrade

Bug #1754274 reported by Nico T on 2018-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

I use to apply only security upgrade using the update-manager popup (therefore there are always remaining a bunch of minor upgrades that are not critical and I choose not to apply).

This morning I applied the security updates. Unfortunately it ended up removing ubuntu-desktop:amd64 package leaving the ubuntu installation broken.

Here is the extract of the apt log :

```
Start-Date: 2018-03-08 07:04:43
Commandline: aptdaemon role='role-commit-packages' sender=':1.1271'
Upgrade: unity-schemas:amd64 (7.4.5+16.04.20171201.3, 7.4.5+16.04.20180221-0ubuntu1), compiz-plugins-default:amd64 (1:0.9.12.3+16.04.20171116-0ub
untu1, 1:0.9.12.3+16.04.20180221-0ubuntu1), libdecoration0:amd64 (1:0.9.12.3+16.04.20171116-0ubuntu1, 1:0.9.12.3+16.04.20180221-0ubuntu1), compiz
config-settings-manager:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1, 1:0.9.12.3+16.04.20180221-0ubuntu1), python:amd64 (2.7.11-1, 2.7.12-1~16.04),
libpq5:amd64 (9.5.11-0ubuntu0.16.04, 9.5.12-0ubuntu0.16.04), libpython-stdlib:amd64 (2.7.11-1, 2.7.12-1~16.04), unity-services:amd64 (7.4.5+16.04
.20171201.3, 7.4.5+16.04.20180221-0ubuntu1), compiz-gnome:amd64 (1:0.9.12.3+16.04.20171116-0ubuntu1, 1:0.9.12.3+16.04.20180221-0ubuntu1), libcomp
izconfig0:amd64 (1:0.9.12.3+16.04.20171116-0ubuntu1, 1:0.9.12.3+16.04.20180221-0ubuntu1), code:amd64 (1.20.1-1518535978, 1.21.0-1520420608), pyth
on-compizconfig:amd64 (1:0.9.12.2+16.04.20160823-0ubuntu1, 1:0.9.12.3+16.04.20180221-0ubuntu1), compiz-core:amd64 (1:0.9.12.3+16.04.20171116-0ubu
ntu1, 1:0.9.12.3+16.04.20180221-0ubuntu1), python-minimal:amd64 (2.7.11-1, 2.7.12-1~16.04)
Remove: ubuntu-desktop:amd64 (1.361.1), unity:amd64 (7.4.5+16.04.20171201.3), session-shortcuts:amd64 (1.2ubuntu0.16.04.1), libunity-core-6.0-9:a
md64 (7.4.5+16.04.20171201.3), unity-tweak-tool:amd64 (0.0.7ubuntu2)
End-Date: 2018-03-08 07:05:20
```

To repair it I had to manually install the package :

```
Start-Date: 2018-03-08 09:30:05
Commandline: apt install ubuntu-desktop
Requested-By: thm (1000)
Install: unity-schemas:amd64 (7.4.5+16.04.20180221-0ubuntu1, automatic), ubuntu-desktop:amd64 (1.361.1), unity:amd64 (7.4.5+16.04.20180221-0ubuntu1, automatic), deja-dup:amd64 (34.2-0ubuntu1.1, automatic), session-shortcuts:amd64 (1.2ubuntu0.16.04.1, automatic), libunity-core-6.0-9:amd64 (7.4.5+16.04.20180221-0ubuntu1, automatic), gnome-screensaver:amd64 (3.6.1-7ubuntu4, automatic)
End-Date: 2018-03-08 09:30:17

```

Maybe there is a package dependency problem here ?

Nico T (nlko) wrote :
Nico T (nlko) wrote :

apt history

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers