pesky "ubuntu-sso-login internal error" followed cross upgrade

Bug #1700705 reported by jzacsh on 2017-06-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

tl;dr will I regret uninstalling ubuntu-sso-login? software-center? do you want my help debugging this?[1] I see last release was over a year ago, so I'm guessing uninstalling is fine, but please advise.

I've been getting these continuous "internal error" pop-ups in ubuntu from 14.04 LTS, and now (through my upgrade to 16.04) they still popup: python traceback that ubuntu-sso-login line 39 (of twisted/__init__.py) raised the ImportError "Twisted requires zope.interface 3.6.0 or later: no module named zope.interface"

apt-cache rdepends seems to suggest the only thing worth keeping 'ubuntu-sso-login' installed for is software-center package. is software-center critical to ubuntu-desktop's operation (eg: if I never open it anyway?). I've guess not, and uninstalled it (it was at 16.01+16.04.20160420 -- ie: over a year old). But please correct me if I'm wrong and I should re-install before I experience some mysterious pains later.

I figure better to discuss this here than in stackexchange, or other places I see this error discussed.

[1]: I mean: if you really want to fix this exception, I'm happy to walk through any debugging steps you need -- but if it's a bug that's hopeless, that's okay too.

This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers