package software-center 16.01+16.04.20160420 failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

Bug #1660032 reported by Malcolm Boura on 2017-01-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

New installation of 16_04 LTS. Almost nothing extra installed. From memory just gimp, gdebi and meld.
software-center would start but could not find or install anything because just got a spinner.
Reinstalled - did not fix it.
Tried changing language as suggested on forum.
Deleted /var/cache and reinstalled - hung the computer, GUI completely unresponsive.
Power cycled.
software-center now working and I was able to install dropbox successfully.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: software-center 16.01+16.04.20160420
ProcVersionSignature: Ubuntu 4.4.0-59.80-generic 4.4.35
Uname: Linux 4.4.0-59-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
AptOrdering:
 software-center: Purge
 NULL: ConfigurePending
Architecture: amd64
Date: Sat Jan 28 11:33:51 2017
DpkgTerminalLog:
 Removing software-center (16.01+16.04.20160420) ...
 Purging configuration files for software-center (16.01+16.04.20160420) ...
 rmdir: failed to remove '/var/cache/software-center/xapian/': No such file or directory
 dpkg: error processing package software-center (--purge):
  subprocess installed post-removal script returned error exit status 1
DuplicateSignature:
 package:software-center:16.01+16.04.20160420
 Purging configuration files for software-center (16.01+16.04.20160420) ...
 rmdir: failed to remove '/var/cache/software-center/xapian/': No such file or directory
 dpkg: error processing package software-center (--purge):
  subprocess installed post-removal script returned error exit status 1
ErrorMessage: subprocess installed post-removal script returned error exit status 1
InstallationDate: Installed on 2017-01-27 (1 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: software-center
Title: package software-center 16.01+16.04.20160420 failed to install/upgrade: subprocess installed post-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Malcolm Boura (malcolm-boura) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers