Software Center does not launch in Ubuntu 16.10 through X2Go in Xfce

Bug #1654182 reported by Kalle Tuulos on 2017-01-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Background information:
Software Center works properly, if launched from computer's own display, but if it is launched through X2Go's remote connection, it fails to launch. Xfce4 is used as windowing environment.

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
Description: Ubuntu 16.10
Release: 16.10

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
software-center:
  Installed: 16.01+16.04.20160420
  Candidate: 16.01+16.04.20160420
  Version table:
 *** 16.01+16.04.20160420 500
        500 http://fi.archive.ubuntu.com/ubuntu yakkety/universe amd64 Packages
        500 http://fi.archive.ubuntu.com/ubuntu yakkety/universe i386 Packages
        100 /var/lib/dpkg/status

x2goserver:
  Installed: 4.0.1.20-0~1125~ubuntu16.10.1
  Candidate: 4.0.1.20-0~1125~ubuntu16.10.1
  Version table:
 *** 4.0.1.20-0~1125~ubuntu16.10.1 500
        500 http://ppa.launchpad.net/x2go/stable/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status

xfce4:
  Installed: (none)
  Candidate: 4.12.3
  Version table:
     4.12.3 500
        500 http://fi.archive.ubuntu.com/ubuntu yakkety/universe amd64 Packages
        500 http://fi.archive.ubuntu.com/ubuntu yakkety/universe i386 Packages

3) What you expected to happen
Software Center is launched either from menu or from command line, using command "software-center". It is expected to launch succesfully.

4) What happened instead
If launched from menu, only visible is the cursor changing to running clock for a while.
If launched from command line, following text is printed to screen:
---8<---8<---
kalle@doghouse:~/Desktop$ software-center

/usr/bin/software-center:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject
/usr/share/software-center/softwarecenter/ui/gtk3/views/purchaseview.py:29: PyGIWarning: WebKit2 was imported without specifying a version first. Use gi.require_version('WebKit2', '4.0') before import to ensure that the right version gets loaded.
  from gi.repository import WebKit2 as webkit
2017-01-05 10:12:36,322 - softwarecenter.backend.zeitgeist_logger - WARNING - Support for Zeitgeist disabled
/usr/share/software-center/softwarecenter/ui/gtk3/widgets/symbolic_icons.py:23: PyGIWarning: PangoCairo was imported without specifying a version first. Use gi.require_version('PangoCairo', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, Gdk, GLib, PangoCairo
2017-01-05 10:12:36,487 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
    self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 143, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 74, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
kalle@doghouse:~/Desktop$
---8<---8<---

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: software-center 16.01+16.04.20160420
ProcVersionSignature: Ubuntu 4.8.0-27.29-generic 4.8.1
Uname: Linux 4.8.0-27-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
Date: Thu Jan 5 10:32:02 2017
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Kalle Tuulos (kalle-tuulos) wrote :
dino99 (9d9) wrote :

This is an unsupported release now. Please think to install the next LTS 'Bionic 18.04'

http://cdimage.ubuntu.com/ubuntu-next/daily-live/current/
https://www.omgubuntu.co.uk/2018/02/ubuntu-18-04-minimal-install-option

Changed in software-center (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers