Unable to launch software-center

Bug #1627354 reported by raghy on 2016-09-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

I'm unable to launch software-center, and this is the error I get:

-----------------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/software-center", line 25, in <module>
    from gi.repository import Gtk, GObject
ImportError: No module named repository
-----------------------------------------------------------

It's the same issue with ubuntu-tweak as well:

-----------------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/ubuntu-tweak", line 30, in <module>
    from gi.repository import GObject, Gdk, Gtk, Gio
ImportError: No module named repository
-----------------------------------------------------------

I've googled on this, and have tried every solution, but nothing has worked yet. Here are the modules I have installed / reinstalled / upgraded.

- python-gobject
- gir1.2-gtk-3.0
- PyGObject (via pip)

Please help. Thank you!

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: software-center 13.10-0ubuntu4.1
ProcVersionSignature: Ubuntu 3.13.0-97.144-generic 3.13.11-ckt39
Uname: Linux 3.13.0-97-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Sep 24 23:08:14 2016
InstallationDate: Installed on 2015-12-24 (275 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

raghy (vrraghy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
aradhya (aradhya-mathur95) wrote :

yes i too am facing this issue

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers