package software-center 16.01+16.04.20160420 [origin: Ubuntu] failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

Bug #1624652 reported by nestlord on 2016-09-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

$ software-center
/usr/bin/software-center:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject
ERROR:root:DebFileApplication import
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/__init__.py", line 6, in <module>
    from .debfile import DebFileApplication, DebFileOpenError
  File "/usr/share/software-center/softwarecenter/db/debfile.py", line 25, in <module>
    from softwarecenter.db.application import Application, AppDetails
  File "/usr/share/software-center/softwarecenter/db/application.py", line 28, in <module>
    import softwarecenter.distro
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 201, in <module>
    distro_instance = _get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 176, in _get_distro
    module = __import__(distro_module_name, globals(), locals(), [], level)
ImportError: No module named "elementary"
Traceback (most recent call last):
  File "/usr/bin/software-center", line 128, in <module>
    from softwarecenter.ui.gtk3.app import SoftwareCenterAppGtk3
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 54, in <module>
    from softwarecenter.db.application import Application
  File "/usr/share/software-center/softwarecenter/db/application.py", line 28, in <module>
    import softwarecenter.distro
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 201, in <module>
    distro_instance = _get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 176, in _get_distro
    module = __import__(distro_module_name, globals(), locals(), [], level)
ImportError: No module named "elementary"

ProblemType: Package
DistroRelease: elementary 0.4
Package: software-center 16.01+16.04.20160420 [origin: Ubuntu]
ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
Uname: Linux 4.4.0-36-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
AptOrdering:
 software-center: Purge
 NULL: ConfigurePending
Architecture: amd64
Date: Sat Sep 17 15:40:14 2016
DpkgTerminalLog:
 Removing software-center (16.01+16.04.20160420) ...
 Purging configuration files for software-center (16.01+16.04.20160420) ...
 rmdir: failed to remove '/var/cache/software-center/xapian/': No such file or directory
 dpkg: error processing package software-center (--purge):
  subprocess installed post-removal script returned error exit status 1
DuplicateSignature:
 package:software-center:16.01+16.04.20160420 [origin: Ubuntu]
 Purging configuration files for software-center (16.01+16.04.20160420) ...
 rmdir: failed to remove '/var/cache/software-center/xapian/': No such file or directory
 dpkg: error processing package software-center (--purge):
  subprocess installed post-removal script returned error exit status 1
ErrorMessage: subprocess installed post-removal script returned error exit status 1
InstallationDate: Installed on 2016-09-14 (2 days ago)
InstallationMedia: elementary OS 0.4 "Loki" - Stable amd64 (20160909)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: software-center
Title: package software-center 16.01+16.04.20160420 [origin: Ubuntu] failed to install/upgrade: subprocess installed post-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

nestlord (as-data09) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers