Software Center doesn't start on systems in Esperanto

Bug #1510237 reported by Robin van der Vliet on 2015-10-26
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

When I start the Software Center it immediately gives me a fatal error on my fresh 15.10 installation in Esperanto.

I got the following traceback when I tried to start the software-center from the terminal: http://paste.ubuntu.com/12972133/

I looked at the traceback and I noticed the error occurred in the file region.py.
In the method _get_region_dumb we try to split the variable loc with the delimeter "_", but the input string does not contain an underscore in the first place. The variable loc only contains "eo" at this point, since Esperanto is not connected to a certain country there is no country code.

I managed to fix the method _get_region_dumb by adding a try/except statement, but I am not able to do a pull request myself as I am not really an expert in Bazaar and branches.

Could somebody update the method _get_region_dumb in region.py and replace it with the following or an other similar method: http://paste.ubuntu.com/12972109/
I only added the last try/except statement.

robin@robin-pc:~$ lsb_release -rd
Description: Ubuntu 15.10
Release: 15.10

robin@robin-pc:~$ apt-cache policy software-center
software-center:
  Instalita: 13.10-0ubuntu12
  Kandidato: 13.10-0ubuntu12
  Version table:
 *** 13.10-0ubuntu12 0
        500 http://nl.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status

[Impact]
This bug will prevent the starting of the Ubuntu Software Center on systems installed in the language Esperanto. The fix is so trivial that backporting would be justified.

[Test Case]
1) Download an Ubuntu flavour.
2) Choose the language Esperanto in the installation wizard.
3) After instalation is complete, start the Ubuntu Software Center (EO: Ubuntu-programarejo).
4) Nothing happens.
5) Open the Terminal (EO: Terminalo).
6) Type "software-center" and press enter.
7) You will see a traceback, similiar to the one in the bug description.
8) Apply the patch provided with the bug report.
9) Now you can start it normally and with the terminal.

[Regression Potential]
I do not think there is any way my fix could go wrong, but maybe other people have different opinions about that here.

Related branches

Robin van der Vliet (robinvdv) wrote :
Robie Basak (racb) wrote :

Thank you for the bug report and fix! The fix is so trivial that I don't think it's necessary to make you learn how to make debdiffs, patches, bzr branches and so on, and we appreciate your contribution. I'm adding the upstream software-center project as I think this is likely to be a bug upstream too, and subscribing ~ubuntu-sponsors for consideration to patch this in Xenial.

If you'd like this fixed in 15.10 or earlier releases, please follow the instructions at https://wiki.ubuntu.com/StableReleaseUpdates#Procedure - in particular although I think a sponsor will be happy to create a debdiff for you, we do still need the "paperwork" done in terms of test case, etc, in order to make sure we minimise regression risk to existing users.

Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Robie Basak (racb) wrote :

Looks like upstream track bugs right here?

Robie Basak (racb) wrote :

@Michael,

Do you mind taking a look please? This looks like a valid bug with a particularly trivial fix/workaround to me.

description: updated
Robin van der Vliet (robinvdv) wrote :

I added a test case and regression analysis to the description of this bug and I also managed to make a patch file with the solution I described before.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 16.01+16.04.20160119

---------------
software-center (16.01+16.04.20160119) xenial; urgency=medium

  * Patch from Robin van der Vilet to not crash on locales with no
    country. (LP: #1510237)

 -- Iain Lane <email address hidden> Tue, 19 Jan 2016 17:06:39 +0000

Changed in software-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers