No longer displays most application icons

Bug #1464722 reported by Marc Deslauriers on 2015-06-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned
Vivid
Undecided
Unassigned

Bug Description

* Impact:
Since Ubuntu 15.04, software-center no longer displays the icons for most applications. See attached screenshot.

* Test case:
look at icons on the main screen, they should be software specific ones, not the default package icon

* Regression potentiel
watch for icons issues

Related branches

Marc Deslauriers (mdeslaur) wrote :
Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu7

---------------
software-center (13.10-0ubuntu7) wily; urgency=medium

  * softwarecenter/ui/gtk3/models/appstore2.py:
    - GtkIcon has_icon doesn't work in standard directories, use lookup_icon
      instead, should fix invalid icons being displayed in the packages list
      (lp: #1464722)
  * data/ui/gtk3/submit_review.ui:
    - don't use the gtkbox n_row property, it's deprecated in the newer gtk
      version, which leads to runtime errors and a non working reviews dialog
      (lp: #1445745)

 -- Sebastien Bacher <email address hidden> Fri, 12 Jun 2015 18:18:05 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released

Hello Marc, or anyone else affected,

Accepted software-center into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-center/13.10-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed
Bart Willemsen (b-willemsen8) wrote :

I installed the proposed version on Ubuntu 15.04 in a virtual machine. I can verify that the application icons on the start screen of the software centre, do appear. But, when you click on an application, the default package icon is still shown on the detailed page of the app.

I am not sure if this is intentional, but it feels like that the normal app icons should also be shown on this page.

Sebastien Bacher (seb128) wrote :

@Bart, thanks, it means the fix works but there is still an issue, setting as verified so the current update can be validated since it's a good improvement

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu6.1

---------------
software-center (13.10-0ubuntu6.1) vivid; urgency=medium

  * softwarecenter/ui/gtk3/models/appstore2.py:
    - GtkIcon has_icon doesn't work in standard directories, use lookup_icon
      instead, should fix invalid icons being displayed in the packages list
      (lp: #1464722)
  * data/ui/gtk3/submit_review.ui:
    - don't use the gtkbox n_row property, it's deprecated in the newer gtk
      version, which leads to runtime errors and a non working reviews dialog
      (lp: #1445745)

 -- Sebastien Bacher <email address hidden> Fri, 12 Jun 2015 18:18:05 +0200

Changed in software-center (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for software-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers