Not able to write a review (Unable to show 'none')

Bug #1445745 reported by Enrico on 2015-04-18
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Sebastien Bacher
Vivid
Undecided
Unassigned

Bug Description

* Impact
reviews can't be added anymore

* Test case
try to write a review for a software

* Impact
the change is in the review dialog ui, make sure it looks correct

------------------------

I can't write a new review on the Software Center. Xubuntu 15.04

When I click on "Write a new review", nothing happens. Launching software-center from the terminal, the attached error appears when I press the "Write a new review" button.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: software-center 13.10-0ubuntu6
Uname: Linux 4.0.0-040000-generic x86_64
ApportVersion: 2.17.1-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Apr 18 11:27:14 2015
InstallationDate: Installed on 2015-03-27 (21 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Enrico (enricobe) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
brimlar (brimlar) wrote :

Upgrade to 15.04, using Unity as my default DE, can confirm -- clicking the "write a review" link does nothing.

I am happy to provide more information or files if someone can direct me as to what is desired.

brimlar (brimlar) wrote :

I resolved or worked around the issue after reading a comment on a Red Hat bug page: https://bugzilla.redhat.com/show_bug.cgi?id=1164449#c4 It appears that the Glade utility uses an "n_rows" property field on GtkGrids that is no longer good and the UI for the Software Center has a line that has that defunct property in it.

Commenting out line 409 in /usr/share/software-center/ui/gtk3/submit_review.ui so that it looks like:

<!-- <property name="n_rows">4</property> -->

allowed me to then submit a review to software in the Software Center, with no discernible defects or errors.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
Changed in software-center (Ubuntu):
importance: Medium → High
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Sebastien Bacher (seb128)
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu7

---------------
software-center (13.10-0ubuntu7) wily; urgency=medium

  * softwarecenter/ui/gtk3/models/appstore2.py:
    - GtkIcon has_icon doesn't work in standard directories, use lookup_icon
      instead, should fix invalid icons being displayed in the packages list
      (lp: #1464722)
  * data/ui/gtk3/submit_review.ui:
    - don't use the gtkbox n_row property, it's deprecated in the newer gtk
      version, which leads to runtime errors and a non working reviews dialog
      (lp: #1445745)

 -- Sebastien Bacher <email address hidden> Fri, 12 Jun 2015 18:18:05 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released

Hello Enrico, or anyone else affected,

Accepted software-center into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-center/13.10-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Vivid):
status: New → Fix Committed
tags: added: verification-needed
Enrico (enricobe) wrote :

Hello Brian. Thanks for your work.

I can't find the new software-center update in the purposed repository. I already have the version 13.10 but I didn't update it via the purposed repository because it was not enabled on my PC. How is it possible?

With the version 13.10, when I press the "Write a review" button a new window opens but it shows a non-stop "Login..." (Accesso,,, in italian)... Anyway, this could be a problem related to my PC and not a software-center bug

Enrico (enricobe) wrote :

I forgot to say that I'm now running 15.10 (Xubuntu development) and this could be why I already have Software Center 13.10

Erik Zoltan (erikzoltan) wrote :

I have tested this and ***IT WORKS****. I can click on the link and create a review.

Note to other testers. I used the instructions at the following link to enable the vivid-proposed updates.

https://wiki.ubuntu.com/Testing/EnableProposed

It's important to use vivid-proposed instead of trusty-proposed shown in the above instructions.

$ sudo apt-get update
$ sudo apt-get install software-center/vivid-proposed

I then ran Software Center and it gave me the ability to create a review. I created one, and was able to see it in Software Center.

Problem solved. This is a 64 bit Vivid system.

Enrico (enricobe) on 2015-06-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu6.1

---------------
software-center (13.10-0ubuntu6.1) vivid; urgency=medium

  * softwarecenter/ui/gtk3/models/appstore2.py:
    - GtkIcon has_icon doesn't work in standard directories, use lookup_icon
      instead, should fix invalid icons being displayed in the packages list
      (lp: #1464722)
  * data/ui/gtk3/submit_review.ui:
    - don't use the gtkbox n_row property, it's deprecated in the newer gtk
      version, which leads to runtime errors and a non working reviews dialog
      (lp: #1445745)

 -- Sebastien Bacher <email address hidden> Fri, 12 Jun 2015 18:18:05 +0200

Changed in software-center (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for software-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.