After update to 14.10, update-software-center crashed with AttributeError in __getattr__(): When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".

Bug #1367017 reported by Benjamin Geese on 2014-09-08
260
This bug affects 34 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

See: https://bugzilla.gnome.org/show_bug.cgi?id=709183

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: software-center 13.10-0ubuntu4.1
ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
Uname: Linux 3.16.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
Date: Mon Sep 8 23:53:27 2014
ExecutablePath: /usr/share/software-center/update-software-center
InstallationDate: Installed on 2014-05-20 (111 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/update-software-center --triggered /usr/share/locale-langpack
PythonArgs: ['/usr/sbin/update-software-center', '--triggered', '/usr/share/locale-langpack']
SourcePackage: software-center
Title: update-software-center crashed with AttributeError in __getattr__(): When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject". See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
UpgradeStatus: Upgraded to utopic on 2014-09-08 (0 days ago)
UserGroups:

Benjamin Geese (ben-8409) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
information type: Private → Public
Changed in software-center (Ubuntu):
importance: Medium → High

Any news on this one old ticket??

My whole system has stopped working due to power supply issue that I'm
unable to resolve just yet.

Thanks for the followup.

On Mon, Jun 29, 2015 at 7:12 AM, Michael Heuberger <
<email address hidden>> wrote:

> Any news on this one old ticket??
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1385582).
> https://bugs.launchpad.net/bugs/1367017
>
> Title:
> After update to 14.10, update-software-center crashed with
> AttributeError in __getattr__(): When using gi.repository you must not
> import static modules like "gobject". Please change all occurrences of
> "import gobject" to "from gi.repository import GObject".
>
> Status in software-center package in Ubuntu:
> Confirmed
>
> Bug description:
> See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: software-center 13.10-0ubuntu4.1
> ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
> Uname: Linux 3.16.0-14-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.7-0ubuntu2
> Architecture: amd64
> Date: Mon Sep 8 23:53:27 2014
> ExecutablePath: /usr/share/software-center/update-software-center
> InstallationDate: Installed on 2014-05-20 (111 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140417)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/update-software-center
> --triggered /usr/share/locale-langpack
> PythonArgs: ['/usr/sbin/update-software-center', '--triggered',
> '/usr/share/locale-langpack']
> SourcePackage: software-center
> Title: update-software-center crashed with AttributeError in
> __getattr__(): When using gi.repository you must not import static modules
> like "gobject". Please change all occurrences of "import gobject" to "from
> gi.repository import GObject". See:
> https://bugzilla.gnome.org/show_bug.cgi?id=709183
> UpgradeStatus: Upgraded to utopic on 2014-09-08 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1367017/+subscriptions
>

Marco Gittoi (marco-gittoi) wrote :
Download full text (4.4 KiB)

it's OK

Il giorno lun 29 giu 2015 alle ore 08:50 GN <email address hidden> ha scritto:

> My whole system has stopped working due to power supply issue that I'm
> unable to resolve just yet.
>
> Thanks for the followup.
>
> On Mon, Jun 29, 2015 at 7:12 AM, Michael Heuberger <
> <email address hidden>> wrote:
>
> > Any news on this one old ticket??
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1385582).
> > https://bugs.launchpad.net/bugs/1367017
> >
> > Title:
> > After update to 14.10, update-software-center crashed with
> > AttributeError in __getattr__(): When using gi.repository you must not
> > import static modules like "gobject". Please change all occurrences of
> > "import gobject" to "from gi.repository import GObject".
> >
> > Status in software-center package in Ubuntu:
> > Confirmed
> >
> > Bug description:
> > See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
> >
> > ProblemType: Crash
> > DistroRelease: Ubuntu 14.10
> > Package: software-center 13.10-0ubuntu4.1
> > ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
> > Uname: Linux 3.16.0-14-generic x86_64
> > NonfreeKernelModules: nvidia
> > ApportVersion: 2.14.7-0ubuntu2
> > Architecture: amd64
> > Date: Mon Sep 8 23:53:27 2014
> > ExecutablePath: /usr/share/software-center/update-software-center
> > InstallationDate: Installed on 2014-05-20 (111 days ago)
> > InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> > (20140417)
> > InterpreterPath: /usr/bin/python2.7
> > PackageArchitecture: all
> > ProcCmdline: /usr/bin/python /usr/sbin/update-software-center
> > --triggered /usr/share/locale-langpack
> > PythonArgs: ['/usr/sbin/update-software-center', '--triggered',
> > '/usr/share/locale-langpack']
> > SourcePackage: software-center
> > Title: update-software-center crashed with AttributeError in
> > __getattr__(): When using gi.repository you must not import static
> modules
> > like "gobject". Please change all occurrences of "import gobject" to
> "from
> > gi.repository import GObject". See:
> > https://bugzilla.gnome.org/show_bug.cgi?id=709183
> > UpgradeStatus: Upgraded to utopic on 2014-09-08 (0 days ago)
> > UserGroups:
> >
> > To manage notifications about this bug go to:
> >
> >
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1367017/+subscriptions
> >
>
>
> ** Bug watch added: GNOME Bug Tracker #709183
> https://bugzilla.gnome.org/show_bug.cgi?id=709183
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1372055).
> https://bugs.launchpad.net/bugs/1367017
>
> Title:
> After update to 14.10, update-software-center crashed with
> AttributeError in __getattr__(): When using gi.repository you must not
> import static modules like "gobject". Please change all occurrences of
> "import gobject" to "from gi.repository import GObject".
>
> Status in software-center package in Ubuntu:
> Confirmed
>
> Bug description:
> See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: softwa...

Read more...

Alex Petralia (alex-petralia) wrote :

Has this ever been resolved? Is there any workaround?

Marco Gittoi (marco-gittoi) wrote :

I don't know

Il gio 2 giu 2016, 21:51 Alex Petralia <email address hidden> ha scritto:

> Has this ever been resolved? Is there any workaround?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1372055).
> https://bugs.launchpad.net/bugs/1367017
>
> Title:
> After update to 14.10, update-software-center crashed with
> AttributeError in __getattr__(): When using gi.repository you must not
> import static modules like "gobject". Please change all occurrences of
> "import gobject" to "from gi.repository import GObject".
>
> Status in software-center package in Ubuntu:
> Confirmed
>
> Bug description:
> See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: software-center 13.10-0ubuntu4.1
> ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
> Uname: Linux 3.16.0-14-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.7-0ubuntu2
> Architecture: amd64
> Date: Mon Sep 8 23:53:27 2014
> ExecutablePath: /usr/share/software-center/update-software-center
> InstallationDate: Installed on 2014-05-20 (111 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140417)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/update-software-center
> --triggered /usr/share/locale-langpack
> PythonArgs: ['/usr/sbin/update-software-center', '--triggered',
> '/usr/share/locale-langpack']
> SourcePackage: software-center
> Title: update-software-center crashed with AttributeError in
> __getattr__(): When using gi.repository you must not import static modules
> like "gobject". Please change all occurrences of "import gobject" to "from
> gi.repository import GObject". See:
> https://bugzilla.gnome.org/show_bug.cgi?id=709183
> UpgradeStatus: Upgraded to utopic on 2014-09-08 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1367017/+subscriptions
>
--
Dr. Marco Gittoi
Via Giotto, 11/A
09010 Uta (CA)
Cell.: 3282629723

Waldemar Osuch (osuchw) wrote :

Done.

On Thu, Jun 2, 2016 at 2:50 PM Marco Gittoi <email address hidden> wrote:

> I don't know
>
> Il gio 2 giu 2016, 21:51 Alex Petralia <email address hidden> ha
> scritto:
>
> > Has this ever been resolved? Is there any workaround?
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1372055).
> > https://bugs.launchpad.net/bugs/1367017
> >
> > Title:
> > After update to 14.10, update-software-center crashed with
> > AttributeError in __getattr__(): When using gi.repository you must not
> > import static modules like "gobject". Please change all occurrences of
> > "import gobject" to "from gi.repository import GObject".
> >
> > Status in software-center package in Ubuntu:
> > Confirmed
> >
> > Bug description:
> > See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
> >
> > ProblemType: Crash
> > DistroRelease: Ubuntu 14.10
> > Package: software-center 13.10-0ubuntu4.1
> > ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
> > Uname: Linux 3.16.0-14-generic x86_64
> > NonfreeKernelModules: nvidia
> > ApportVersion: 2.14.7-0ubuntu2
> > Architecture: amd64
> > Date: Mon Sep 8 23:53:27 2014
> > ExecutablePath: /usr/share/software-center/update-software-center
> > InstallationDate: Installed on 2014-05-20 (111 days ago)
> > InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> > (20140417)
> > InterpreterPath: /usr/bin/python2.7
> > PackageArchitecture: all
> > ProcCmdline: /usr/bin/python /usr/sbin/update-software-center
> > --triggered /usr/share/locale-langpack
> > PythonArgs: ['/usr/sbin/update-software-center', '--triggered',
> > '/usr/share/locale-langpack']
> > SourcePackage: software-center
> > Title: update-software-center crashed with AttributeError in
> > __getattr__(): When using gi.repository you must not import static
> modules
> > like "gobject". Please change all occurrences of "import gobject" to
> "from
> > gi.repository import GObject". See:
> > https://bugzilla.gnome.org/show_bug.cgi?id=709183
> > UpgradeStatus: Upgraded to utopic on 2014-09-08 (0 days ago)
> > UserGroups:
> >
> > To manage notifications about this bug go to:
> >
> >
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1367017/+subscriptions
> >
> --
> Dr. Marco Gittoi
> Via Giotto, 11/A
> 09010 Uta (CA)
> Cell.: 3282629723
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1374794).
> https://bugs.launchpad.net/bugs/1367017
>
> Title:
> After update to 14.10, update-software-center crashed with
> AttributeError in __getattr__(): When using gi.repository you must not
> import static modules like "gobject". Please change all occurrences of
> "import gobject" to "from gi.repository import GObject".
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1367017/+subscriptions
>

GN (gjn-aus) wrote :

All,

I no longer have the laptop causing the problem. I cannot provide anymore
advice.

On Mon, Jun 29, 2015 at 7:12 AM, Michael Heuberger <
<email address hidden>> wrote:

> Any news on this one old ticket??
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1385582).
> https://bugs.launchpad.net/bugs/1367017
>
> Title:
> After update to 14.10, update-software-center crashed with
> AttributeError in __getattr__(): When using gi.repository you must not
> import static modules like "gobject". Please change all occurrences of
> "import gobject" to "from gi.repository import GObject".
>
> Status in software-center package in Ubuntu:
> Confirmed
>
> Bug description:
> See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: software-center 13.10-0ubuntu4.1
> ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
> Uname: Linux 3.16.0-14-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.7-0ubuntu2
> Architecture: amd64
> Date: Mon Sep 8 23:53:27 2014
> ExecutablePath: /usr/share/software-center/update-software-center
> InstallationDate: Installed on 2014-05-20 (111 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140417)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/update-software-center
> --triggered /usr/share/locale-langpack
> PythonArgs: ['/usr/sbin/update-software-center', '--triggered',
> '/usr/share/locale-langpack']
> SourcePackage: software-center
> Title: update-software-center crashed with AttributeError in
> __getattr__(): When using gi.repository you must not import static modules
> like "gobject". Please change all occurrences of "import gobject" to "from
> gi.repository import GObject". See:
> https://bugzilla.gnome.org/show_bug.cgi?id=709183
> UpgradeStatus: Upgraded to utopic on 2014-09-08 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1367017/+subscriptions
>

Alex Petralia (alex-petralia) wrote :

How is this not an issue for more people?

Marco Gittoi (marco-gittoi) wrote :

No

Il giorno dom 28 giu 2015 alle ore 23:20 Michael Heuberger <
<email address hidden>> ha scritto:

> Any news on this one old ticket??
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1372055).
> https://bugs.launchpad.net/bugs/1367017
>
> Title:
> After update to 14.10, update-software-center crashed with
> AttributeError in __getattr__(): When using gi.repository you must not
> import static modules like "gobject". Please change all occurrences of
> "import gobject" to "from gi.repository import GObject".
>
> Status in software-center package in Ubuntu:
> Confirmed
>
> Bug description:
> See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
>
> ProblemType: Crash
> DistroRelease: Ubuntu 14.10
> Package: software-center 13.10-0ubuntu4.1
> ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
> Uname: Linux 3.16.0-14-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.7-0ubuntu2
> Architecture: amd64
> Date: Mon Sep 8 23:53:27 2014
> ExecutablePath: /usr/share/software-center/update-software-center
> InstallationDate: Installed on 2014-05-20 (111 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140417)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/sbin/update-software-center
> --triggered /usr/share/locale-langpack
> PythonArgs: ['/usr/sbin/update-software-center', '--triggered',
> '/usr/share/locale-langpack']
> SourcePackage: software-center
> Title: update-software-center crashed with AttributeError in
> __getattr__(): When using gi.repository you must not import static modules
> like "gobject". Please change all occurrences of "import gobject" to "from
> gi.repository import GObject". See:
> https://bugzilla.gnome.org/show_bug.cgi?id=709183
> UpgradeStatus: Upgraded to utopic on 2014-09-08 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1367017/+subscriptions
>
--
Dr. Marco Gittoi
Via Giotto, 11/A
09010 Uta (CA)
Cell.: 3282629723

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.