softwarecenter.backend.reviews - WARNING - error creating bsddb: Invalid argument -- BDB0054 illegal flag combination specified to DB_ENV->open

Bug #1313884 reported by Chris Bainbridge on 2014-04-28
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

I opened software-centre. I installed gimp. I then clicked Games>Arcade and software-center hung.

~/.cache/software-center/software-center.log says:

2014-04-28 19:51:03,631 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2014-04-28 19:51:04,637 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2014-04-28 19:51:04,641 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2014-04-28 19:51:04,654 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2014-04-28 19:51:04,654 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2014-04-28 19:51:04,712 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2014-04-28 19:51:05,417 - softwarecenter.backend.reviews - WARNING - error creating bsddb: '(22, 'Invalid argument -- BDB0054 illegal flag combination specified to DB_ENV->open')' (corrupted?)
2014-04-28 19:51:05,418 - softwarecenter.backend.reviews - ERROR - trying to repair DB failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 358, in _save_review_stats_cache_blocking
    self._dump_bsddbm_for_unity(outfile, outdir)
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 377, in _dump_bsddbm_for_unity
    0600)
DBInvalidArgError: (22, 'Invalid argument -- BDB0054 illegal flag combination specified to DB_ENV->open')
2014-04-28 19:51:12,635 - softwarecenter.db.utils - INFO - software-center-agent finished with status 0
2014-04-28 19:56:46,059 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2014-04-28 19:56:57,263 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

Starting software-center from the command line results in this error every time.

apt-get purge and installing software-center did not fix
rm -rf ~/.cache/software-center did not fix

Bug #1309398 looks similar

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: software-center 13.10-0ubuntu4.1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Apr 28 19:54:04 2014
InstallationDate: Installed on 2014-03-27 (32 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

Unsure about the hang but the warning in the title is an invalid db api use

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu10

---------------
software-center (13.10-0ubuntu10) wily; urgency=medium

  * debian/control: updated standards version
  * debian/patches/clean_gwibber_use.patch:
    - don't try to use gwibber, there is no such service anymore and it
      leads only to warnings (lp: #1501393)
  * debian/patches/correct_db_use.patch:
    - DB_NOMMAP needs to be set using set_flags,
      it's not valid in DBEnv.open (lp: #1313884)

 -- Sebastien Bacher <email address hidden> Mon, 05 Oct 2015 17:48:09 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers