Software Center crashes when uninstalling after installing

Bug #1253531 reported by Jeb E. on 2013-11-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

The Software Center tends to crash when uninstalling an app after installing the same app not too long before deciding to uninstall. This happens almost every time on my computer, and it gets very annoying and tends to break package links and my system overall. I've tried reinstalling Ubuntu GNOME, but the exact same problem always occurs.

The same problem even happens sometimes when I'm installing a large package file or lots of apps at once.
This can be a serious problem for users and future releases. A fix needs to be made and pushed out immediately.

Attached is a system report and specs with benchmarking results automated in HardInfo.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: software-center 13.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Thu Nov 21 02:49:45 2013
InstallationDate: Installed on 2013-11-10 (11 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release amd64 (20131017)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Jeb E. (jebeld17) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers