software-center crashed with TypeError in exists(): coercing to Unicode: need string or buffer, NoneType found

Bug #1227277 reported by Łukasz Zaniepodam on 2013-09-18
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
Status tracked in Trunk
Rodney Dawes
software-center (Ubuntu)
Rodney Dawes
Rodney Dawes

Bug Description

[Test Case]
Verify this does not occur with the new version of software-center by using the error report on

Original Report
I downloaded Ubuntu 13.10 32bit daily build. I installed it on newly created filesystem. I updated it via sudo apt-get update sudo apt-get dist-upgrade. I added to /etc/apt/sources.list.d/ddebs.list link to debug symbols. I updated and upgraded. I installed apport-retrace and suggested packages. I restarted system. I downloaded .deb file of steam from official valve page. I wanted to install steam, so I clicked on .deb, then I confirmed that deb is trustworthly, and it is the point where crash occured. But window of software-center there is still visible and I could continue the installation.

ProblemType: CrashDistroRelease: Ubuntu 13.10
Package: software-center 13.09-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
Uname: Linux 3.11.0-7-generic i686
ApportVersion: 2.12.2-0ubuntu1
Architecture: i386
Date: Wed Sep 18 19:53:09 2013
ExecutablePath: /usr/share/software-center/software-center
InstallationDate: Installed on 2013-09-18 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130917)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /home/username/Pulpit/steam_latest.deb
 PATH=(custom, no user)
PythonArgs: ['/usr/bin/software-center', '/home/username/Pulpit/steam_latest.deb']SourcePackage: software-center
Title: software-center crashed with TypeError in exists(): coercing to Unicode: need string or buffer, NoneType found
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Mike McCracken (community): Approve on 2013-11-18
information type: Private → Public
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Mark Murphy (mokmeister) wrote :

Tried to install ICA client and witnessed same behaviour. ICA client continued to install despite error. 32 bit Ubuntu 13.10 fully updated as of 30/09/13.

Felix Möller (felix-derklecks) wrote :

Tried to install pencil, by just clicking the link on

I attempted to install a 32bit package on my 64bit platform. while software center attempted to update, it failed.

Darcy Casselman (dscassel) wrote :

Tried to install Skype for 12.04 multi-arch. ( . Software Centre crashed as above.

Rodney Dawes (dobey) on 2013-11-26
Changed in software-center:
status: New → Fix Committed
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Changed in software-center (Ubuntu Saucy):
status: New → In Progress
Changed in software-center (Ubuntu Trusty):
assignee: nobody → Rodney Dawes (dobey)
Changed in software-center (Ubuntu Saucy):
assignee: nobody → Rodney Dawes (dobey)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu2

software-center (13.10-0ubuntu2) trusty; urgency=low

  * debian/patches/01_bzr-typeerror.patch:
    - Avoid creating a launcher without .desktop files. (LP: #1227277)
  * debian/patches/02_bzr-drop-distroseries.patch:
    - Drop the use of DISTROSERIES. (LP: #1254892)
 -- Rodney Dawes <email address hidden> Tue, 26 Nov 2013 10:16:14 -0500

Changed in software-center (Ubuntu Trusty):
status: Fix Committed → Fix Released
Rodney Dawes (dobey) wrote :

Is anyone able to get this error to happen consistently? I've tried several times to force the error to happen here, but am unable to do so. The problem is clear from the traceback, but it needs to be testable in order to push the SRU, and I want to make certain the fix actually fixes it for those who are seeing the problem.

Rodney Dawes (dobey) on 2014-01-29
Changed in software-center (Ubuntu Saucy):
status: In Progress → Triaged
assignee: Rodney Dawes (dobey) → nobody
Filiprino (filiprino) wrote :

This bug appeared while installing the Dropbox debian package from the Dropbox website.

Filiprino (filiprino) wrote :

I'm using Ubuntu 13.10, so it's not fixed.

Matthew Paul Thomas (mpt) wrote :

Both today and over the past month, this is the #2 most common reported error for all Ubuntu users.

Michael Vogt (mvo) wrote :

@Matthew: thanks for the reminder. I uploaded a fix and we can use errors.u.c to verify that it works.

Hello Łukasz, or anyone else affected,

Accepted software-center into saucy-proposed. The package will build now and be available at in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at . Thank you in advance!

description: updated
Changed in software-center (Ubuntu Saucy):
status: Triaged → Fix Committed
tags: added: verification-needed
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in software-center (Ubuntu Saucy):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers